PDA

View Full Version : Fwd: [slim] 2 small bugs in fishbone skin



kdf
2004-05-21, 14:03
patch attached.

----- Forwarded message from Roland Fischer <slimp3user (AT) graben13 (DOT) at> -----
Date: Fri, 21 May 2004 22:41:06 +0200
From: Roland Fischer <slimp3user (AT) graben13 (DOT) at>
Reply-To: Slim Devices Discussion <discuss (AT) lists (DOT) slimdevices.com>
Subject: [slim] 2 small bugs in fishbone skin
To: discuss (AT) lists (DOT) slimdevices.com

I'm using the current slimserver version from cvs (~5 hours old). (and after
some problems with CRLF conversion in the CPAN directory the server is
running as expected:)
1)
whenever i open http://localhost:9000 in internet explorer i get the
following html error, but it disappears when the first refresh of the
playlist frame occurs.
Errormessage:
Line: 7
Character: 31
Error: ';' expected
Code: 0
URL: http://localhost:9000/browse.html?dir=&&page=Browse Music
Folder&player=00:04:20:04:02:55
The funny thing on this error ist both browser.html files (while ie displays
the error and after the first refresh) are equal. any idea where it comes
from?
The files begin with
"<html>
<head>
<title></title>
<link rel="stylesheet" href="/slimserver.css">
<script language="JavaScript">
<!--Hide
parent.header.browse.Browse Music Folder.selected=true;
--></script>
</head>"
And line 7 would be the one with "parent...." beginning with 2 TAB
characters, so the ; is expected after the first space character (after
Browse), maybe IE has problems with the spaces in those line?
Mozilla Firefox doesn't show this error.
2)
In IE in the upper left corner there is a link "SLIMP3 Home" pointing to
"http://localhost:9000" and this opens the complete fishbone skin in the
upper left frame.... looks kinda funny ;) (you need to be at the home
location for this link, when i enter server settings it changes to
"javascript:parent.browser.location='/'+getHomeCookie('SlimServer-Browserpag
e') +'&player=00%3A04%3A20%3A04%3A02%3A55'").
But in Mozilla Firefox the location is everytime the right one (it's the
same for server settings and on the home location it changes to
"http://dagobert:9000/home.html?player=&page=browse.html?")
I tried to delete the cache of IE but nothing changed.

Regards, Roland