PDA

View Full Version : Cannot change library path



ob_kook
2011-02-18, 17:26
This one has me baffled. I'm a long time SB user and know my way around computers reasonably well. Last night I spent a couple of hours running an ethernet cable from my server room in the basement to a new jack I installed in the living room with the plan of finally getting past the dropouts issues I've been having with my Duet there.

No problems there at all.

I held the button on the front of the Duet and reset the networking settings and was excited to see if I could run FLAC files now without rebuffering. BUT...my music library was offline, and I kept getting prmpted to switch libraries.

So I logged into my squeezecenter server to see what's up. The network share from 2008 Server "MusicBox" is still properly mapped and I can browse it from within explorer on the squeezecenter server. But in the server settings, there is a little red x against it.

As an experiment, I set the music folder to the default music folder in Windows, and was able to scan the 3 default albums in there (Mr. Scruff).

Then I tried everything I could to set it back, but no matter what I do, the music folder keeps resetting back to C:users\public\music. It doesn't matter if I browse to the proper music folder, or type in the path directly, it will not stay or scan on the proper folder.

This tells me that SS cannot see the folder or doesn't have permissions for it, but I *can* browse to it on the same PC, and from within settings, so I don't get it. The share is online and healthy.

Any ideas?

No other changes made recently except an upgrade to 7.5.3 but that was a month ago...

pski
2011-02-18, 18:23
This one has me baffled. I'm a long time SB user and know my way around computers reasonably well. Last night I spent a couple of hours running an ethernet cable from my server room in the basement to a new jack I installed in the living room with the plan of finally getting past the dropouts issues I've been having with my Duet there.

No problems there at all.

I held the button on the front of the Duet and reset the networking settings and was excited to see if I could run FLAC files now without rebuffering. BUT...my music library was offline, and I kept getting prmpted to switch libraries.

So I logged into my squeezecenter server to see what's up. The network share from 2008 Server "MusicBox" is still properly mapped and I can browse it from within explorer on the squeezecenter server. But in the server settings, there is a little red x against it.

As an experiment, I set the music folder to the default music folder in Windows, and was able to scan the 3 default albums in there (Mr. Scruff).

Then I tried everything I could to set it back, but no matter what I do, the music folder keeps resetting back to C:users\public\music. It doesn't matter if I browse to the proper music folder, or type in the path directly, it will not stay or scan on the proper folder.

This tells me that SS cannot see the folder or doesn't have permissions for it, but I *can* browse to it on the same PC, and from within settings, so I don't get it. The share is online and healthy.

Any ideas?

No other changes made recently except an upgrade to 7.5.3 but that was a month ago...

Be sure you use the webUI to change the music source.

P

ob_kook
2011-02-18, 21:41
I've tried the web ui as well as the settings panel. I also tried to stop the squeeze server service and restart it. no go...

toby10
2011-02-19, 04:21
Might be an OS issue. I'm on XP also running 7.5.3 and I can freely change my SBS library from both locations.
SBS > Control Panel > Library
SBS > Settings > Basic

ob_kook
2011-02-19, 08:55
I don't think it's os related. Been running on Win7 for months without issue. No, something obviously changed in my system, somewhere, but damned if I can figure out what it might be...

Might have to consider a full re-install.

Mnyb
2011-02-19, 09:07
Can you use an unc path instead of a drive letter ?

If you are running sbs as a service that are active before any user logs in you can't use drive letters for mapped network drives on windows this is for users only you probably have to use an unc path ?

Says me that have not used modern versions of windows...

ob_kook
2011-02-19, 10:00
Here is the crux of the problem via screenshots:

1. The mapped drive can be seen in Explorer. I have set that SC must be started manually to ensure the mapped drive can be seen first by the OS just in case (note: this has been working for about a year now this way)

2. The same mapped drive can also be seen in Server Control Panel. However, when I select it and either apply or close the panel, it will revert back to a C:Users\music folder.

3. In the Server Web UI settings browser, if I click "browse" for the music folder, the drive does not show up. If I type the path in the box instead of browsing, it will revert as above.

Frustrating stuff...

mherger
2011-02-19, 10:09
> 1. The mapped drive can be seen in Explorer.

SBS can't see mapped drives if it's run as a service (at system startup). They only work if you run SBS only when you log in to Windows, as the mapped drives are only seen by your user.

--

Michael

ob_kook
2011-02-19, 19:17
You are correct Michael.

I looked through logfiles and now realize that I changed SC to start at system start. That was a couple of months ago. Everything was fine since the server never went down since then. 2 days ago, we tripped a breaker on the same circuit that the server is on. I assume it was from that point that the library disappeared.

I've changed the setting back to manual, rebooted the server, and have now been able to re-map and rescan my library.

Thanks for the hint!

Peter

rbz5416
2011-02-20, 06:15
Doesn't entering credentials from the account with the mapped drive alongside system start allow SBS to see it? Or is my memory failing me (again!)?

ob_kook
2011-02-20, 08:56
Not sure about that. You should be able to set dependencies on the service startup to make it work too. But since this is a virtual machine anyway, I just let it run, so not a big deal for me to leave it to manual.

Jaeath
2011-11-28, 16:23
Doesn't entering credentials from the account with the mapped drive alongside system start allow SBS to see it? Or is my memory failing me (again!)?

The Login info is for the service to be able to startup properly using a user account instead of the built in system account. Leave it blank unless you know how to set whatever account you chose to have "logon as service" rights. If you set the startup option to manual you can then set the path and then set the startup back to start when the system starts and the path will stick. If you are going to use the system start option you must use a unc path or a direct attached drive in the system. An iSCSI or USB connected drive should work as well with the system start option... If you are using mapped drives you must log in first.

emalvick
2011-11-29, 11:47
Couldn't you just set the path to

\\NAME\folders rather than Z:\folders

This way, you would never face the issue again.