PDA

View Full Version : L/R channel swap status?



Phillip Kerman
2004-09-09, 22:58
> > So, if I check my channels and then never switch to non-PCM then I
> > should be
> > locked in?
>
> AFAIK yes that is the case. I left my channel test looping
> for a couple
> days and it stayed synced.



Yeah, it seems to be working.

I added (and selected) the following to convert.conf:
mp3 wav * *
[lame] --mp3input --decode --silent $FILE$ -

So, when I do play an MP3 it doesn't switch modes. I have to test out the
MAC address targeting option (in a comment at the end of the convert.conf
file) so that I can opt out of this WAV/PCM setting on my wireless SB way at
the other end of the house.

The issues (when playing MP3 as WAV) remaining are: a tiny click at the
start of a song... and it seems to be using more processor power. Does that
make sense?

Thanks,
Phillip






>
> > Any ideas what the deal is with HDCD?
> >
>
> Never heard of this - do they still play ok? Does it go away
> if you max
> out the player's volume control? If that's the case then
> it's probably
> an issue in your receiver (it gets confused on more than 16 bits per
> sample).
>
> Other than that, PCM is just a stream of samples so I don't have any
> explanation as to why different FLAC files would behave differently.
> When volume is at max, it's the same as playing the CD. And the
> additional in-band signalling on the s/pdif line is the same - I've
> verified this with a protocol analyzer.
>
>

kdf
2004-09-09, 23:24
Quoting Phillip Kerman <lists (AT) phillipkerman (DOT) com>:

> > > So, if I check my channels and then never switch to non-PCM then I
> > > should be
> > > locked in?
> >
> > AFAIK yes that is the case. I left my channel test looping
> > for a couple
> > days and it stayed synced.
>
>
>
> Yeah, it seems to be working.
>
> I added (and selected) the following to convert.conf:
> mp3 wav * *
> [lame] --mp3input --decode --silent $FILE$ -
>
> So, when I do play an MP3 it doesn't switch modes. I have to test out the
> MAC address targeting option (in a comment at the end of the convert.conf
> file) so that I can opt out of this WAV/PCM setting on my wireless SB way at
> the other end of the house.
>
you can go into player settings for the wireless player and set the bitrate
limiting to 320 or less, instead of no limit. This will force mp3 conversion
to the required bitrate.

-kdf

seanadams
2004-09-10, 01:42
>
> Yeah, it seems to be working.
>
> I added (and selected) the following to convert.conf:
> mp3 wav * *
> [lame] --mp3input --decode --silent $FILE$ -
>
> So, when I do play an MP3 it doesn't switch modes. I have to test out
> the
> MAC address targeting option (in a comment at the end of the
> convert.conf
> file) so that I can opt out of this WAV/PCM setting on my wireless SB
> way at
> the other end of the house.
>
> The issues (when playing MP3 as WAV) remaining are: a tiny click at the
> start of a song... and it seems to be using more processor power.
> Does that
> make sense?
>
> Thanks,
> Phillip
>

Dean is more familiar with the conversion machinery so I'll let him
comment on this... my guess is that there are WAV headers which are
being sent through that shouldn't be. I've never tried server-side mp3
decoding but if there are any issues like that, they shouldn't be too
hard to fix.