PDA

View Full Version : On enable/disable software/firmware updates for old squeezebox players



blubstar
2011-01-04, 01:52
Hi there,

I have searched the existing threads thoroughly but found that non considers this in particular.


My setting:
* squeezebox (SB3), the old one
* MySB.com account
* SBS 7.4.2 running on ReadyNAS NV+ (7.5.x are buggy here)

My problem:
* my squeezebox player keeps updating its firmware whenever I switch between MySB.com and SBS
* it wants FW 130 for playing with my SBS
* it wants FW 131 for playing from MySB.com
* this always takes 2-3 minutes time (which is the really annoying thing)
* this cannot be turned off !!!



Variants 1 - SBS "up" or "down

* SBS "up": when switching, update starts automatically ("progress bar on player"), then reboots, then plays

* SBS "down": when switching (means: I am playing from SBS, then turning SBS off, then do the switching), I am asked to "press and hold brightness key", after that update runs as usual (progress bar, reboot, ..)

Side-effect when SBS is "down": here I can press and hold "left" instead of "bringtness"; this brings me into the advanced settings menu on the squeezebox player, where I can set "auto updates" to "off" (note, this menu CANNOT be reached through the normal menue). Unfortunately, setting this to "off" has no effect. Updates will still occur on every switch.



Variants 2 - remotes: I have recognized that the update procedure on my squeezebox player behaves also slightly different with different remote controls (the "normal on", the web one on mysqueezebox.com and my iPhone app "iPeng") but this might be another story. Maybe more variants exist.



The PRIMARY ISSUE is: How can I DISABLE the SOFTWARE UPDATES on my squeezebox effectively?


Thank you for solutions.

Kai

Mnyb
2011-01-04, 02:05
* you can listen to all your radio service trough the NAS , so the obvius solution is to not switch to mysb.com , this works if the nas have proper DNS and if your mysb.com creds is filled in the mysb.com tab in squeeezeboxserver.

* In general an upgrade will brake on many linux machines , a completely clean install works better all traces of old ss/sc/sbs must be gone,cache clean migth not be enough prefs must also be gone.
Older slimserver ,squeezecenter users and services can still be running etc.
Don't do this if 7.4 works for you if you have no new players or new functions you must have.

I think clean installs is recommended by Logitech on the netgear NAS.

Search the forum (I'm at work cant peek in my server)

But you can replace the firmware file and version file in 7.4 with the never firmware so that the sb always run 131 , this might give you some other problems instead but it will not upgrade/downgrade .

aubuti
2011-01-04, 08:33
Side-effect when SBS is "down": here I can press and hold "left" instead of "bringtness"; this brings me into the advanced settings menu on the squeezebox player, where I can set "auto updates" to "off" (note, this menu CANNOT be reached through the normal menue). Unfortunately, setting this to "off" has no effect. Updates will still occur on every switch.

<snip>
The PRIMARY ISSUE is: How can I DISABLE the SOFTWARE UPDATES on my squeezebox effectively?
Actually turning "auto updates" off on the SB3 firmware menu does have an effect. It's just not the effect you are expecting. If auto updates is off, you need to press the Brightness button on the remote to activate install new firmware. If auto updates is on, the SB3 proceeds to update to new firmware without needing to press the Brightness button. However, in either case, the SB3 wants the fw that corresponds to whatever version of the server software it is connecting to.

To avoid switching every time, do as Mnyb says and do everything via your ReadyNAS NV+. There is no need to switch explicitly to mysb.com.

Mnyb
2011-01-04, 10:55
Does not a surprisingly large amount of NAS user have some DNS problems too .
To compound the problem, so that their local ss/sc/sbs is not able to contact mysb.com or the internet ?

The best thing to do is to solve that problem, can be a configuration error on the nas or whatnot.

blubstar
2011-01-04, 11:23
Thanx for your feedback.

1. For bug reasons, I cannot use SBS 7.5.x 8-(

2. For energy reasons, I am not using my NAS 24/7 --> I have to switch!

3. Believe me: DNS, etc. are ok!

4. For emotional and personal health reasons, I better not think of that "auto update" issue anymore.


So, I will try to tell my SBS 7.4.2 to provide the FW131 to my SB. Good info! I'll keep you updated...

Kai

aubuti
2011-01-04, 11:33
2. For energy reasons, I am not using my NAS 24/7 --> I have to switch!
Do you listen to your SB 24/7? If not, then your NAS doesn't have to run 24/7 -- just when you want to listen to your SB.

If that's too inconvenient or wasteful of energy for you, consider running SBS 7.5.2 on your computer when you want to listen to local music, and then switching over to mysb.com when you want to shut the computer down.

Note that these are only temporary measures, until whatever bugs are plaguing you on the ReadyNAS are resolved.

Pascal Hibon
2011-01-04, 12:28
The ReadyNAS series are not very power hungry. There are some things you can tweak to reduce power consumption at idle state. The biggest optimizer is to let the disks spin down after x minutes of inactivity. My NVX is running 24/7 and at idle the power consumption is less than 7 watts.
If you leave your NV+ running you wont need to switch from SBS to mySB, which is the source of the auto updates.