PDA

View Full Version : Finally found the cause of multiple music stoppage problems



rgro
2010-10-29, 20:53
So, I've experienced several of the issues that other folks have posted about here and in other SB forums. I've had music stop playing (though it still looks like it should be playing, but wouldn't restart), having to switch to mysb.com and back to get things restarted and a few other annoying but related glitches. I may have a solution---maybe not the only solution, but one that's certainly solved my problem! In short, it's NOT been a Touch/Logitech problem, it's been a Win 7 problem.

Even though I'm running my computer that runs SBS 24/7 and have set the Power Management option on it to "never sleep", my sense was that something was still causing the NIC card to sleep anyway, thus terminating the connection from SBS to the Touch, causing the seemingly random stops in the music, etc. Once the music stopped, it appeared that switching to msyb.com and back to "My Music" (SBS server) sent a WOL command which then woke the NIC card up.

I had played endlessly with the Power Management options for the NIC card which are accessed in Win 7 through the Device Manager. None of the combinations seemed to work to keep it awake---even though I had the "allow the computer to turn [the Nic] off to save power" UNCHECKED!

So after poring through a bunch of other tech and Microsoft forums the past few days, stumbled on something which seems to have finally done the trick. Under the "Advanced" tab in the Device Manager for the NIC (which is an Intel 82567V-2 Gigabit), there is an option called the "System Idle Power Saver" which was enabled. I changed it to disabled and that has finally prevented the NIC card from going to sleep and, thus, kept SBS and the Touch happily connected. Now, maybe this is completely obvious to everybody else but I'm not a technical wizard at all and it seems, shall we say, a bit obscure.

Why, Microsoft....when you choose the the "never sleep" option in the computer's Power Mangement, it still allows the NIC to sleep, is baffling; why, when you UNcheck the "allow the computer to turn off device does the NIC still turn off; and why the option to really, really disable the NIC's sleep state is in the "Advanced" tab instead of in the "Power Mangement" tab in the NIC device manager is all just plain lame, Microsoft (I've self-censored, here)!

I feel like I just trapped the annoying mouse in the attic that's been running around for months in the middle of the night and waking me up. Plus--and even better---I won't have to do any more wife hand-holding/explaining when the music inexplicably stops....always, coincidentally, about 20 min or so after I've stopped using the computer. ;>)

Off to play around with my Revue, now, heheheh.

garym
2010-10-30, 04:52
Thanks for posting this. could be very helpful to some frustrated users!

dsdreamer
2010-10-31, 09:55
Good detective work and thanks for sharing it!

This particular Windows behavior has been driving people nuts for several years now. E.g., see the following thread...

http://forum.notebookreview.com/lenovo-ibm/322532-network-connections-drop-screen-blank.html