PDA

View Full Version : SV: SV: Slimserver stops and starts by itself



Craig, James (IT)
2004-09-01, 01:52
Hi Tore,
From the output you've sent I'm guessing that you are running SlimServer as a Windows service?

For some reason Windows services can't talk to other applications using OLE so my plugin will not work in this way.
The time taken for it to find out it can't talk to iTunes is causing the Squeezebox to lose the connection it seems?

If you want to use the plugin you need to either not run SlimServer as a service (just put slim.exe in your startup folder) or use the new 'indirect' update method in the new version I released last week.
This is all explained in the readme file that comes with the plugin.

James

-----Original Message-----
From: discuss-bounces (AT) lists (DOT) slimdevices.com [mailto:discuss-bounces (AT) lists (DOT) slimdevices.com] On Behalf Of Tore Johnsson
Sent: 31 August 2004 22:39
To: 'Slim Devices Discussion'
Subject: SV: SV: SV: [slim] Slimserver stops and starts by itself

I have removed all of ITunes from the computer and I got the old behavior
back without SB starts and stops.

I don't know what's the reason for having it.
Perhaps those people who are using it, could tell me.

So my problem is solved.

Thanks for all help
Kind Regards
Tore



-----Ursprungligt meddelande-----
Från: discuss-bounces (AT) lists (DOT) slimdevices.com
[mailto:discuss-bounces (AT) lists (DOT) slimdevices.com] För kdf
Skickat: den 31 augusti 2004 20:29
Till: Slim Devices Discussion
Ämne: SV: SV: [slim] Slimserver stops and starts by itself

Quoting Tore Johnsson <tore (AT) torejohnsson (DOT) se>:


> 2004-08-31 20:08:08.1275 ==logTrackToiTunesWin()
> 2004-08-31 20:08:08.1280 Attempting to make connection to iTunes...
> 2004-08-31 20:08:39.4018 Failed to launch iTunes through OLE!!!

I'm guessing this is output from the iTunes Updater plugin. That's a long
time
to be trying before failing. If this is somehow blocking any playback
packets,
it would cause a dropout eventually. This output with d_slimproto on as well
would likely confirm this, though it would be a lot of debug output to sift
through. The best thing would be to try to figure out why it cannot connect
to
iTunes OLE interface.

-kdf