PDA

View Full Version : Scanner crashes on SBS machine, not Win 7 machine (same library!)



bossanova808
2010-08-28, 03:43
I have exactly the same music library on two machines (synced nightly) - one at my work, on Small Business Server 2003 machine, and the other at home on a Win 7 ultimate machine.

At home, on Win 7, this library scans perfectly.

At work, on the SBS machine, the scanner terminates unexpectedly on directory scan. It does this in different spots (as far as I can tell from the log) - and there are no useful messages in either the scanner log or the main log. I have tried fully disabling anti-virus to see if that has an effect (the AV is the same on both machines anyway) - this does not solve the problem.

Latest server (7.5.1) - any ideas on how I can track this problem down further, or what it might be??

Mnyb
2010-08-28, 04:35
Do you have the same setting in the AV at both places !

to exclude *.MYD and *.MYI files .

Some versions of MSE does not honor thi settings

Sometime you get the telltale "can write to file.... bla bla .myd" or create that file , it's usually the AV blocking MySQL .

Another sad fact disabling an AV does not infact disables it completely something is still running in most of them ? so unistall is the unly way to be sure.

bossanova808
2010-08-28, 04:59
Yes, same settings at either end and all the SS directories are exccluded as are *.MYD and *.MYI files. The scanner crashes when the AV is completely disabled.

Mnyb
2010-08-28, 07:11
Yes, same settings at either end and all the SS directories are exccluded as are *.MYD and *.MYI files. The scanner crashes when the AV is completely disabled.

As in unistalled ok ( Even if many AV software has a disable setting this is not really happening ) .

But better do you have a server.log or scanner.log file's from the crashing machine don't just snip a couple of lines via the web-Ui it's often not enough logging.

make zip files of them and add to the tread .

I'm not good at MS server OS ,but some other people are at this forum

bossanova808
2010-08-28, 15:59
Ok - Anti-Virus (Vipre) not running.

Logs - http://dl.dropbox.com/u/108804/SBS%20Errrors.zip (server log going back months, and latest scanner log).

The last time I ran a scan was 28/08/10 - and there's no errors in the logs I can see for those days....

On the Win 7 machine, no crash, I get:
1320 albums with 18052 songs by 667 artists.

On the SBS machine:
1262 albums with 17279 songs by 1436 artists.

The error report is:

Directory Scan (17403 of 18053) Complete 00:16:20

G:\Music Library\Various\2009 - Cafe Copacabana - The Essence of Latin Chill\10 - Purificar O Subae.mp3

Music scan terminated unexpectedly (Directory Scan)
Total Time: 00:16:20 (Friday, August 27, 2010 / 10:49 PM)

Note, if I rescan, it will crash on a different track.

MrSinatra
2010-08-30, 20:38
while i can't say what your issue is, i had an issue where [not] bad artwork crashed a windows machine, but not a linux one.

the trick would be to find out if its just one file that is causing your crash.

http://bugs.slimdevices.com/show_bug.cgi?id=4699