PDA

View Full Version : Connection/setup issues



paulbellchambers
2010-08-13, 07:33
Hi,

I am trying to connect a SB Classic to my network.
I have had the box working ok but it is intermittent.
I connect to the Internet via BT Home Hub 2. From there I have ethernet wot a switch which then connects 2 PCs and a netwrok printer.

I have a Zyxel wireless router connected to the hub on a separate ethernet cable. I connected the SB to this hub but the PC running the server couldnt see it. I then tried connecting the SB via the ethernet switch but again it could not be seen. I then tried a crossover cable which worked. I had to extend the cable with another crossover with a connecter and this worked ok.

However have turned teh SB and PC off over night the set up would not work today. I thought perhaps I need to assign a static IP to the SB but I cant get that to work either. If I ping the ip address I assigned it fails. If I ping 127.0.0.1 it works so the cable is connected ok. The SB doesnt see the ethernet currently and the wireless signal is too weak for it to connect.

I can get it to work from time to time but the SB set up is not stable.
Any ideas?

Thanks in advance.

paul

tedfroop
2010-08-13, 10:38
Hi,
I have a Zyxel wireless router connected to the hub on a separate ethernet cable.

paul

Welcome to the forum paulbellchambers.

Where is the cable plugged in to the wireless router?

Using the configuration you describe it should be connected to the "lan" portion of the router. To make it work like you want you need to turn the Zyxl into an access point.

To do this you want to:
1. Give the Zyxl a static address. Make the address the same as the BT Home Hub except change the last set of number to one number higher (if the BT address is less than .256) or lower than the BT. Write it down too so you can go back and manage the Zyxl as this will become the web page address for managing the Zyxl. Use the BT address for the Gateway and DNS addresses.
2. Turn off the DHCP server on the Zyxl.
3. While you are there I would change the wireless channel to 1 or 11 to see if that improves your wireless reception.

Last but not least - buy a longer cable and remove the extension. If possible buy one long enough you can move the Zyxl closer to your Squeezebox as that will (obviously) improve reception.

Phil Leigh
2010-08-13, 22:21
I'm confused... why do you have BOTH a HomeHub AND a router?
The HomeHub does everything (but only has 2 wired ethernet ports, so you'd plug a switch into it to get more...)
You only want one device handing out IP addresses to your devices - that should be the HomeHub.

Also, I've plugged SB's into many different HH's many times - no need for a crossover cable as both the devices are autosensing.
It's extremely rare to find any device that needs a crossover cable these days as most devices are autosensing.