PDA

View Full Version : Downgrading Slimserver from 5.3.0.b1 to 5.2.1 - firmware??



Simon Turner
2004-08-27, 05:40
I want to uninstall the Slimserver vs 5.3.0b1 and reinstall 5.2.1.
Is this possible and do I have to do anything special to downgrade my
firmware (other than press and hold the brightness button)?

Thanks for any help

Simon Turner
Brighton UK

Daryle A. Tilroe
2004-08-27, 07:19
Simon Turner wrote:
> I want to uninstall the Slimserver vs 5.3.0b1 and reinstall 5.2.1.
> Is this possible and do I have to do anything special to downgrade my
> firmware (other than press and hold the brightness button)?

You have to manually put the appropriate downgrade entries into
squeezebox.version.

--
Daryle A. Tilroe

kdf
2004-08-27, 09:42
Quoting Simon Turner <simon (AT) brighton (DOT) co.uk>:

> I want to uninstall the Slimserver vs 5.3.0b1 and reinstall 5.2.1.
> Is this possible and do I have to do anything special to downgrade my
> firmware (other than press and hold the brightness button)?
>

installing the older slimserver should do it all, tho uninstalling first would
be safest. to handle the firmware, you have to 'downgrade' that first, I
think. FW33 is not compatible with older server versions. Look in the
Firmware folder of the slimserver install, find squeezebox.version and edit it.
if you have, for example FW33 installed, add:
33 29

Then restart the server and press and hold brightness. This will take your
player back to FW29. This might be too far back, but I wanted to be sure you
would get to teh right FW for 5.2.1. Then you can install 5.2.1 and if the FW
included with that is above 29, the player will say that an upgrade is
required. Press and hold brightness again and you should be done.

There may be more steps here than are required, but I'm being cautious :)

-kdf