PDA

View Full Version : Any good Windows 7 FTP client



RichardEvans
2010-06-23, 14:23
Hi everybody.

First to explain the problem. My Mum and dad have a Squeezebox using my old TS-101 as a server, and they have just bought a new computer with Windows 7. When I connected it to the TS-101, the TS-101 kept crashing. I found out from some internet searching that there are issues with Windows networking between Windows7 and NAS devices.

So I've tried switching off the windows networking on the TS-101, and it now runs perfectly again. Obviously the snag is how do we now transfer music files.
I also heard that IP networking is not a problem, so I'm thinking we could use FTP instead, but for that I need a good easy to use FTP client. It needs to be fairly easy to use for mum and dad, any ideas.

Thanks.

Richard.

EDIT:
A quick update. Things are perhaps worse than I thought. I tried something called Filezilla, and I also tried to connect using the WinSCP installed on my Laptop (using Windows XP). I found the connection kept timing out, I then found that the server stopped responding to Ping requests after attempting an FTP connection, plus the Qnap web interface also stopped responding. Basically any attempt to make an FTP connection seemed to cause the network connection to fail, although strangely, the Squeezebox was still able to connect to the server and play music. That was very confusing, even while the Squeezebox was playing, I couldn't ping the server. That part has got me really confused.

I think perhaps my best option is to wait for somebody to work out what the problem is between Windows7 and NAS devices, and find a solution.

Heuer
2010-06-29, 04:36
Richard

Firstly be careful with Filezilla as it has no encryption of passwords and there are Trojan's out there specifically designed to exploit its weaknesses. Just Google 'Filezilla Security' for more information. It is free and does work though, just delete password information after use. Alternative is FireFTP a FTP Client add-on for Firefox.

I still use a Qnap TS-101 (although mostly for backup of music and pictures from the ReadyNAS) and have no problems using Windows Networking to drag and drop files to it from Windows 7 or XP. I have Windows Networking switched on, all other services are off, fixed IP address, mapped network drive in Windows Explorer and the Qnap is on f/w 2.3.0 build 025T. I am not running the Squeeze server on it though.

kesey
2010-06-29, 05:39
CuteFTP 8 is pretty easy to use.

bakker_be
2010-06-29, 06:56
The old LeechFTP still gets my vote, even for Win 7.

garym
2010-06-29, 10:10
Firstly be careful with Filezilla as it has no encryption of passwords and there are Trojan's out there specifically designed to exploit its weaknesses. Just Google 'Filezilla Security' for more information. It is free and does work though, just delete password information after use. Alternative is FireFTP a FTP Client add-on for Firefox.

Re security see also for a different take on this:
http://forum.filezilla-project.org/viewtopic.php?f=4&t=1328

Heuer
2010-06-30, 01:48
Yes, that is the guy who designed Filezilla and is taking a rather odd stance - "All other software is vulnerable so why should Filezilla be any different". Passwords are held in plain text and Filezilla remembers the last passwords you put in even if you you have not deliberately stored them. Not really a problem if you are mucking about locally but if you use Filezilla for updating web sites it is more problematic. Lots of people have had their sites hijacked this way. Best to keep Filezilla on a USB memory stick and use it that way.

RichardEvans
2010-07-03, 22:36
Thanks for the replies, and sorry I've been slow getting back here (working too much).

I shouldn't think the security in Filezilla would be much of a problem, as it is only for local file transfers, not over the internet, and actually it didn't fix the problem anyway.

Perhaps it may be a matter of updating the TS-101 to the latest firmware. It was a long time ago that I gave it to them, so the firmware is probably very old by now. That may be something else to try next time I go around there.

The impression I got was that many people were having problems accessing all sorts of NAS devices using Windows 7. Perhaps they were old messages, and perhaps the problem has been fixed now. So perhaps a firmware upgrade might fix it.

slate
2010-07-04, 02:24
The TS-101 is an old geezer and it doesn't look like QNAP have made new software for it since
Update date 2008/9/4
Version 1.0.0 Build 0827

http://www.qnap.com/download_detail.asp?pl1=download.asp%3Fpl%3D1&p_mn=67&Keypl=1&pl=1&ct_name=Latest

But if it is older than that.... then an upgrade would be the first thing to do.

pski
2010-07-08, 21:44
cuteftp 8 is pretty easy to use.

+1

peebee
2010-07-13, 11:49
I think perhaps my best option is to wait for somebody to work out what the problem is between Windows7 and NAS devices, and find a solution.

I had a similar problem when first trying to connect from my new Win7 PC to my Buffalo Linkstation Pro NAS. Searching the web found various posts to do with changing authentication settings (NTLM rings a bell here) in the Registry, and sure enough, following these sorted out the problem.

I would like to say that I kept a note of the Registry changes I had to make and the websites that I got the info from but I can't! Sorry for being so vague and unhelpful but at least you know now that the answer is out there. I'll dig around and see if I can find the info again.

Edit: Try this post - http://forums.techarena.in/networking-security/1296293.htm#post4782404

"This issue can be solved by changing the NTLM authentication level to Send LM & NTLM - use NTLMv2 session security if negotiated after this go to run type regedit and press the enter key and fthen find

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Lsa

Now Create a DWORD key under Lsa and set:
Name: LmCompatibilityLevel
Value: 1
Then Restart the system"

I can confirm that I have this setting made on my PC and can set up mapped drives and access network shares on my NAS.

PB

RichardEvans
2010-07-22, 12:54
"This issue can be solved by changing the NTLM authentication level to Send LM & NTLM - use NTLMv2 session security if negotiated after this go to run type regedit and press the enter key and fthen find

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Lsa

Now Create a DWORD key under Lsa and set:
Name: LmCompatibilityLevel
Value: 1
Then Restart the system"


Thanks, and sorry it's taken me so long to reply, Busy busy busy :-(
I'll make a copy of those instructions to try out next time I go around to my mum and dads.

Richard.