PDA

View Full Version : Error message : “Preset 1# not define”



cabby777
2010-05-31, 13:14
I have a duet and a classic and I’m running 7.5.1

I use a third party product (Nuvo) which allows me to remotely access my pre-configured favorites listed on the Squeezebox Server or my pre-configured favorites on Squeezebox.com. I’ve configured the Nuvo keypad to send the corresponding IR commands based on the JVC DVD player (IR command = “favorites 1, or favorites 2, or etc.) to the classic. Within seconds of receiving the IR command, the Squeezebox Classic would connect and play that URL listed in that favorite.

For almost 2 years everything worked great.
But in April, the Classic would no longer respond to IR commands sent from the Nuvo system. I’m not sure what changed. I can access my favorites via the Squeezebox Controller, or from the web based remote control program so I know the configuration is correct and the players and servers are communicating with each other.

I get this error message when I send the IR command to the Squeezebox Classic. I can see the error message on the Squeezebox Controller. It says “Preset 1# not define”. I also get an error message on the classic screen: “Preset 1# (hold to save)”. Prior to April 2010 the Squeezebox Classic would just connect to the favorites.

I perform a few debugs. The IR information makes it to the Squeezebox Classic, but doesn't see the information (URL) in the favorite.

[10-05-31 14:43:21.1783] Slim::Hardware::IR::lookupFunction (530) irCode not defined: [5.repeat] for mode: [INPUT.List]
[10-05-31 14:43:21.1786] Slim::Hardware::IR::repeatCode (987) irCode = [undef] timer = [1387774.058] timediff = [0.0470000000204891] last = [preset_5]
[10-05-31 14:43:21.2242] Slim::Networking::Slimproto::client_readable (395) Slimproto frame: IR , len: 10
[10-05-31 14:43:21.2247] Slim::Hardware::IR::lookupCodeBytes (450) 0000f7a6 -> code: 5
[10-05-31 14:43:21.2249] Slim::Hardware::IR::processIR (702) 0000f7a6 1387774.104 1275331401.22481
[10-05-31 14:43:21.2252] Slim::Hardware::IR::lookup (479) Found button 5 for 0000f7a6
[10-05-31 14:43:21.2254] Slim::Hardware::IR::lookupFunction (530) irCode not defined: [5.repeat] for mode: [INPUT.List]
[10-05-31 14:43:21.2256] Slim::Hardware::IR::repeatCode (987) irCode = [undef] timer = [1387774.104] timediff = [0.046000000089407] last = [preset_5]
[10-05-31 14:43:21.4753] Slim::Hardware::IR::lookup (479) Found button 5 for 0000f7a6

Another debug log entries says that the preset number 4 - not an audio entry

[10-05-31 15:14:38.6976] Slim::Buttons::Common::__ANON__ (922) Can't play preset number 4 - not an audio entry
[10-05-31 15:15:08.7236] Slim::Buttons::ScreenSaver::screenSaver (182) Mode [IDLESAVER.superdatetime] not found, using default
[10-05-31 15:15:08.7239] Slim::Buttons::Common::pushMode (2062) Pushing button mode: screensaver
[10-05-31 15:15:08.7242] Slim::Buttons::ScreenSaver::setMode (276) Going into screensaver mode.
[10-05-31 15:15:46.1022] Slim::Buttons::Common::popMode (2221) Popped to button mode: INPUT.List
[10-05-31 15:15:48.8577] Slim::Buttons::Common::__ANON__ (922) Can't play preset number 3 - not an audio entry

Not sure if this an issue with the menus or something else.

Thanks
Cabby