PDA

View Full Version : OPB.org stream keeps rebuffering?



plympton
2010-05-15, 15:41
This is weird - I know there's a few Oregonians here that listen to OPB.org's (NPR) station. I have 2 squeezeboxes - an SB2, and a Touch - synced. Using the latest 7.5.1 nightly, and latest 7.5.1 on the Touch.

The link is this:
http://www.opb.org/programs/streams/opb-radio.pls

1. If I play local music, it plays perfectly (in sync, no rebuffing)
2. If I play Pandora, it plays perfectly.
3. If I play net radio (Radio Paradise), again, perfect.
4. If I play OPB.org, on 1 squeezebox, it plays perfectly.
**
5. If I play OPB.org, on 2 synced squeezeboxes, it plays the promo item (10 secs), ~12 seconds of feed, and then oscillates between 0-4-8% rebuffering.
**

I've tried using Proxied and Direct streaming settings, I use "The Syncronizer" plugin, I've messed with Sync settings, but nothing helps.

This is in my log (disabling it now to see what happens)


[10-05-15 14:05:59.0036] Slim::Plugin::AudioScrobbler::Plugin::_handshakeEr ror (367) Error handshaking with Last.fm: Connect timed out: Bad file descriptor
[10-05-15 14:09:04.0184] Slim::Plugin::AudioScrobbler::Plugin::_handshakeEr ror (367) Error handshaking with Last.fm: Connect timed out: Bad file descriptor
[10-05-15 14:09:32.0072] Slim::Plugin::AudioScrobbler::Plugin::_handshakeEr ror (367) Error handshaking with Last.fm: Connect timed out: Bad file descriptor
[10-05-15 14:10:21.9494] Slim::Plugin::AudioScrobbler::Plugin::_handshakeEr ror (367) Error handshaking with Last.fm: Connect timed out: Bad file descriptor
[10-05-15 14:11:42.0075] Slim::Plugin::AudioScrobbler::Plugin::_handshakeEr ror (367) Error handshaking with Last.fm: Connect timed out: Bad file descriptor
[10-05-15 14:13:17.0054] Slim::Plugin::AudioScrobbler::Plugin::_handshakeEr ror (367) Error handshaking with Last.fm: Connect timed out: Bad file descriptor


** HELP! **

(Yes, it could very well be an OPB.org problem, as they do funky things to the stream possibly, but then why would it work pefrectly on ONE squeezebox?)

-Dan

toby10
2010-05-16, 03:51
OPB is playing fine on my synced Radio & Boom.
SBS 7.5.1, basic SBS sync option, no proxy

Did you try disabling the error scrobbling yet?

Mark Miksis
2010-05-16, 11:33
OPB is playing fine on my synced Radio & Boom.
SBS 7.5.1, basic SBS sync option, no proxy

FYI, I believe that anytime you have players synced, SbS is proxying the stream regardless of the "no proxy" setting.

Mnyb
2010-05-16, 11:35
tried it, plays perfect on one player rebuffers when synced ? for me it's only an 48k stream what gives ?

toby10
2010-05-16, 11:39
FYI, I believe that anytime you have players synced, SbS is proxying the stream regardless of the "no proxy" setting.

So I'm proxying by proxy. ;)

Mnyb: I just tried it again, plays fine here, still synced.

plympton
2010-05-17, 09:45
tried it, plays perfect on one player rebuffers when synced ? for me it's only an 48k stream what gives ?

Are you syncing a Touch and an SB3? I'm still tracking this down - been building some (physical) doors, so no time this weekend. I *THINK* it could be a Touch bug, or a server bug.

I *THINK* I also got rebuffering with JUST my Touch.

Toby10: Yes, disabled the scrobbling, no effect.

Yeah, it's a 48k stream - with my 20 Mbit connection, shouldn't be an issue. :-)

-Dan

Mnyb
2010-05-17, 10:03
Touch,Boom,Radio in Sync .

I have 100mB internet but i'm on the wrong continent it could matter.

Interesting, leaving out my SqueezePlay players and syncing Boom and My SB3 works OK ?

I have to note that my server Boom and Touch are wired Radio and SB3 are on wifi

plympton
2010-05-17, 10:08
Rebuffers on Squeezeplay, no syncing, too.

Sounds like Chipmunks, but at the 20 second or so mark, it rebuffers, and then every 10 seconds or so. I turned on a bunch of logging in Squeezeplay, but haven't found anything of note.

I have a call into OPB to talk with one of their engineers, since this happens once a year or so, and is just enough pain to just be frustrating.

NPR people are just nuts, aren't we? :-)

-Dan

plympton
2010-05-17, 10:40
Interesting, leaving out my SqueezePlay players and syncing Boom and My SB3 works OK ?


So it could be a SqueezePlay / SqueezeOS firmware thing.

Filed bug:
http://bugs.slimdevices.com/show_bug.cgi?id=16233

-Dan

andyg
2010-05-19, 14:52
If a stream sounds wrong (chipmunks) and rebuffers it means it's being played at the wrong sample rate, thus consuming data too fast and that's why you get rebuffering. Please file a bug.

andyg
2010-05-19, 14:52
Sorry I see you did already file a bug. :)

plympton
2010-05-19, 15:06
Sorry I see you did already file a bug. :)

No problem - this one is driving me nuts. I was playing with it (again) today for a while.

Looks like it's actually a sync & touch problem. The Touch can play the stream fine, the SB3 can play the stream fine, but synced together, they (or just the touch, can't tell) timeout and rebuffer.

Really killing my WAF. I'll take a workaround - any workaround - at this point.

-Dan

BigPotato
2010-05-19, 15:49
I have the same issue with KUOW, the local Seattle NPR station. I've found the that problem only occurs on the "high-quality" MP3 stream. If I use the low quality 64kbps MP3 stream, it works fine even when multiple boxes are synced.

Does OPB have a low quality stream? It might be worth trying if you can live with lower quality. For voice and casual listening I find the 64kbps stream acceptable if not ideal.

plympton
2010-05-19, 15:57
I have the same issue with KUOW, the local Seattle NPR station. I've found the that problem only occurs on the "high-quality" MP3 stream. If I use the low quality 64kbps MP3 stream, it works fine even when multiple boxes are synced.

Does OPB have a low quality stream? It might be worth trying if you can live with lower quality. For voice and casual listening I find the 64kbps stream acceptable if not ideal.

YEAH YOU HAVE THE PROBLEM, TOO! :-)

Do you ONLY have the problem when it's the high-quality stream, *AND* you sync a Touch to <anything>? Do you get the problem with just the Touch (or just an SB3)?

They appear to have a high and low quality stream, except I can't tune to them reliably - no matter what URL I give it, it still sends me the same stream. I'm assuming there's some kind of handshaking going on.

Unfortunately, the regular quality stream is the one that the Touch doesn't like. :-(.

-Dan

BigPotato
2010-05-19, 16:05
If I listen to the HQ stream on a single Touch, Radio or SB3 it works fine. I know for sure that when I try to sync a Radio and an SB3 on the HQ stream it doesn't work. I get the intro and then constant rebuffering. The 64kbps stream works perfectly with any combination.

I haven't tried two SB3's or two Radio's but I can try that later tonight.

BigPotato
2010-05-19, 16:11
Also to note, this definitely isn't a networking or server CPU issue on my side. I can happily sync 128kbps Pandora or Last.fm on any mix of Radio/Touch/2xSB3 without an issue. Same for my local music collection at much higher bit rates.

BigPotato
2010-05-19, 19:13
SB3 on its own works.
Touch on its own works.
Radio on its own works.
SB3 + SB3 works.
SB3 + Touch fails.
SB3 + Radio fails.
Touch + Radio fails.

Looks like syncing with any Squeezeplay based device in the mix doesn't work.

This is with 7.5.1.

The problematic stream is at http://128.208.34.80:8002/

plympton
2010-05-20, 06:22
SB3 on its own works.
Touch on its own works.
Radio on its own works.
SB3 + SB3 works.
SB3 + Touch fails.
SB3 + Radio fails.
Touch + Radio fails.

Looks like syncing with any Squeezeplay based device in the mix doesn't work.

This is with 7.5.1.

The problematic stream is at http://128.208.34.80:8002/

Thanks for testing this out! I wonder if this could be an NPR-wide thing, as I'm sure they share ideas/techniques between stations.

-Dan