PDA

View Full Version : gittery streaming in winxp but not in linux



Ben Gladstone
2004-08-16, 08:11
i had a similar sounding problem which i cured by reinstalling the
latest intel NIC drivers from
http://support.intel.com/support/network/adapter/index.htm#PRO
and following the FAQ instructiosn ---

Once you have the latest version, to disable the feature in question:
Right click My Computer and click Properties
Click the Hardware tab and click Device Manager
Click the + next to Network adapters and double-click your ethernet
adapter
Click Advanced, and select Offload TCP Segmentation.
Set the Value: field to Disabled and click OK.

> -----Original Message-----
> From: discuss-bounces (AT) lists (DOT) slimdevices.com
> [mailto:discuss-bounces (AT) lists (DOT) slimdevices.com] On Behalf Of
> Haisam K. Ido
> Sent: 16 August 2004 15:59
> To: Discuss (AT) lists (DOT) slimdevices.com
> Subject: [slim] gittery streaming in winxp but not in linux
>
> Until recently I was able to stream mp3's to my slimp3 via my
> dual boot
> system, linux and winxp, without any significant problems. They both
> share the same harddrive which contains the mp3. However,
> now in linux
> all is well, but in winxp the mp3's are gittery when played
> back via the
> slimp3. I've looked at the winxp driver for the NIC but nothing is
> unusual. What could have happend and how do I solve this? I
> am using the
> same version of the slimpserver.
>

Haisam K. Ido
2004-08-16, 18:29
I have the ability to disable what you mention below, and it is already
disabled, without even upgrading the driver. Does this mean that I must
still upgrade? The only difference from when it used to work is that now
I am using a longer ethernet cable!!!.

Of course, in linux all is well :-)

> i had a similar sounding problem which i cured by reinstalling the
> latest intel NIC drivers from
> http://support.intel.com/support/network/adapter/index.htm#PRO
> and following the FAQ instructiosn ---
>
> Once you have the latest version, to disable the feature in question:
> Right click My Computer and click Properties
> Click the Hardware tab and click Device Manager
> Click the + next to Network adapters and double-click your ethernet
> adapter
> Click Advanced, and select Offload TCP Segmentation.
> Set the Value: field to Disabled and click OK.
>
>> -----Original Message-----
>> From: discuss-bounces (AT) lists (DOT) slimdevices.com
>> [mailto:discuss-bounces (AT) lists (DOT) slimdevices.com] On Behalf Of
>> Haisam K. Ido
>> Sent: 16 August 2004 15:59
>> To: Discuss (AT) lists (DOT) slimdevices.com
>> Subject: [slim] gittery streaming in winxp but not in linux
>>
>> Until recently I was able to stream mp3's to my slimp3 via my
>> dual boot
>> system, linux and winxp, without any significant problems. They both
>> share the same harddrive which contains the mp3. However,
>> now in linux
>> all is well, but in winxp the mp3's are gittery when played
>> back via the
>> slimp3. I've looked at the winxp driver for the NIC but nothing is
>> unusual. What could have happend and how do I solve this? I
>> am using the
>> same version of the slimpserver.
>>

seanadams
2004-08-16, 19:40
If you're talking about SLIMP3 (not Squeezebox) then TCP settings do
not matter.

The only thing I can think of (since you mentioned a longer ethernet
cable) is perhaps that slimp3 firmware v2.3 has a bug fix for the
ethernet interface which fixes needless collisions under certain
conditions.

Please check your firmware rev - hold power to reset and then look in
the bottom-right corner of the display.

Sean

On Aug 16, 2004, at 6:29 PM, Haisam K. Ido wrote:

> I have the ability to disable what you mention below, and it is already
> disabled, without even upgrading the driver. Does this mean that I
> must
> still upgrade? The only difference from when it used to work is that
> now
> I am using a longer ethernet cable!!!.
>
> Of course, in linux all is well :-)
>
>> i had a similar sounding problem which i cured by reinstalling the
>> latest intel NIC drivers from
>> http://support.intel.com/support/network/adapter/index.htm#PRO
>> and following the FAQ instructiosn ---
>>
>> Once you have the latest version, to disable the feature in question:
>> Right click My Computer and click Properties
>> Click the Hardware tab and click Device Manager
>> Click the + next to Network adapters and double-click your ethernet
>> adapter
>> Click Advanced, and select Offload TCP Segmentation.
>> Set the Value: field to Disabled and click OK.
>>
>>> -----Original Message-----
>>> From: discuss-bounces (AT) lists (DOT) slimdevices.com
>>> [mailto:discuss-bounces (AT) lists (DOT) slimdevices.com] On Behalf Of
>>> Haisam K. Ido
>>> Sent: 16 August 2004 15:59
>>> To: Discuss (AT) lists (DOT) slimdevices.com
>>> Subject: [slim] gittery streaming in winxp but not in linux
>>>
>>> Until recently I was able to stream mp3's to my slimp3 via my
>>> dual boot
>>> system, linux and winxp, without any significant problems. They both
>>> share the same harddrive which contains the mp3. However,
>>> now in linux
>>> all is well, but in winxp the mp3's are gittery when played
>>> back via the
>>> slimp3. I've looked at the winxp driver for the NIC but nothing is
>>> unusual. What could have happend and how do I solve this? I
>>> am using the
>>> same version of the slimpserver.
>>>

Haisam K. Ido
2004-08-17, 06:02
I have firmware 2.2, but the same slimp3 works fine when i boot into linux
on the same pc!!

>
> If you're talking about SLIMP3 (not Squeezebox) then TCP settings do
> not matter.
>
> The only thing I can think of (since you mentioned a longer ethernet
> cable) is perhaps that slimp3 firmware v2.3 has a bug fix for the
> ethernet interface which fixes needless collisions under certain
> conditions.
>
> Please check your firmware rev - hold power to reset and then look in
> the bottom-right corner of the display.
>
> Sean
>
> On Aug 16, 2004, at 6:29 PM, Haisam K. Ido wrote:
>
>> I have the ability to disable what you mention below, and it is already
>> disabled, without even upgrading the driver. Does this mean that I
>> must
>> still upgrade? The only difference from when it used to work is that
>> now
>> I am using a longer ethernet cable!!!.
>>
>> Of course, in linux all is well :-)
>>
>>> i had a similar sounding problem which i cured by reinstalling the
>>> latest intel NIC drivers from
>>> http://support.intel.com/support/network/adapter/index.htm#PRO
>>> and following the FAQ instructiosn ---
>>>
>>> Once you have the latest version, to disable the feature in question:
>>> Right click My Computer and click Properties
>>> Click the Hardware tab and click Device Manager
>>> Click the + next to Network adapters and double-click your ethernet
>>> adapter
>>> Click Advanced, and select Offload TCP Segmentation.
>>> Set the Value: field to Disabled and click OK.
>>>
>>>> -----Original Message-----
>>>> From: discuss-bounces (AT) lists (DOT) slimdevices.com
>>>> [mailto:discuss-bounces (AT) lists (DOT) slimdevices.com] On Behalf Of
>>>> Haisam K. Ido
>>>> Sent: 16 August 2004 15:59
>>>> To: Discuss (AT) lists (DOT) slimdevices.com
>>>> Subject: [slim] gittery streaming in winxp but not in linux
>>>>
>>>> Until recently I was able to stream mp3's to my slimp3 via my
>>>> dual boot
>>>> system, linux and winxp, without any significant problems. They both
>>>> share the same harddrive which contains the mp3. However,
>>>> now in linux
>>>> all is well, but in winxp the mp3's are gittery when played
>>>> back via the
>>>> slimp3. I've looked at the winxp driver for the NIC but nothing is
>>>> unusual. What could have happend and how do I solve this? I
>>>> am using the
>>>> same version of the slimpserver.
>>>>

Niek Jongerius
2004-08-17, 06:11
>> The only thing I can think of (since you mentioned a longer ethernet
>> cable) is perhaps that slimp3 firmware v2.3 has a bug fix for the
>> ethernet interface which fixes needless collisions under certain
>> conditions.

> I have firmware 2.2, but the same slimp3 works fine when i boot into linux
> on the same pc!!

The point is that the Windows driver might behave dirrerent than the
Linux one (for instance, more "agressively"). This could trip some bug
in the SlimP3 stack, which might have been fixed in v2.3.

might-could-might... anyway, v2.3 is not a bad thing to try.

Regards, Niek.

seanadams
2004-08-17, 10:16
OK I would still upgrade for 2.3 but one more thing to check is if you
have any VPN software running on the PC. VPN clients are notorious for
needlessly interfering with local LAN traffic. In server settings that
is a field "Max bytes to send in a UDP packet"... you might try
changing that from 1400 to 1200.


On Aug 17, 2004, at 6:02 AM, Haisam K. Ido wrote:

> I have firmware 2.2, but the same slimp3 works fine when i boot into
> linux
> on the same pc!!
>
>>
>> If you're talking about SLIMP3 (not Squeezebox) then TCP settings do
>> not matter.
>>
>> The only thing I can think of (since you mentioned a longer ethernet
>> cable) is perhaps that slimp3 firmware v2.3 has a bug fix for the
>> ethernet interface which fixes needless collisions under certain
>> conditions.
>>
>> Please check your firmware rev - hold power to reset and then look in
>> the bottom-right corner of the display.
>>
>> Sean
>>
>> On Aug 16, 2004, at 6:29 PM, Haisam K. Ido wrote:
>>
>>> I have the ability to disable what you mention below, and it is
>>> already
>>> disabled, without even upgrading the driver. Does this mean that I
>>> must
>>> still upgrade? The only difference from when it used to work is that
>>> now
>>> I am using a longer ethernet cable!!!.
>>>
>>> Of course, in linux all is well :-)
>>>
>>>> i had a similar sounding problem which i cured by reinstalling the
>>>> latest intel NIC drivers from
>>>> http://support.intel.com/support/network/adapter/index.htm#PRO
>>>> and following the FAQ instructiosn ---
>>>>
>>>> Once you have the latest version, to disable the feature in
>>>> question:
>>>> Right click My Computer and click Properties
>>>> Click the Hardware tab and click Device Manager
>>>> Click the + next to Network adapters and double-click your ethernet
>>>> adapter
>>>> Click Advanced, and select Offload TCP Segmentation.
>>>> Set the Value: field to Disabled and click OK.
>>>>
>>>>> -----Original Message-----
>>>>> From: discuss-bounces (AT) lists (DOT) slimdevices.com
>>>>> [mailto:discuss-bounces (AT) lists (DOT) slimdevices.com] On Behalf Of
>>>>> Haisam K. Ido
>>>>> Sent: 16 August 2004 15:59
>>>>> To: Discuss (AT) lists (DOT) slimdevices.com
>>>>> Subject: [slim] gittery streaming in winxp but not in linux
>>>>>
>>>>> Until recently I was able to stream mp3's to my slimp3 via my
>>>>> dual boot
>>>>> system, linux and winxp, without any significant problems. They
>>>>> both
>>>>> share the same harddrive which contains the mp3. However,
>>>>> now in linux
>>>>> all is well, but in winxp the mp3's are gittery when played
>>>>> back via the
>>>>> slimp3. I've looked at the winxp driver for the NIC but nothing is
>>>>> unusual. What could have happend and how do I solve this? I
>>>>> am using the
>>>>> same version of the slimpserver.
>>>>>

Haisam K. Ido
2004-08-17, 16:41
Ok I upgraded to 2.3 firmware and upgraded the driver for my NIC card and
made sure that the appropriate settings are disabled, but still the same
problem :-(

>>> The only thing I can think of (since you mentioned a longer ethernet
>>> cable) is perhaps that slimp3 firmware v2.3 has a bug fix for the
>>> ethernet interface which fixes needless collisions under certain
>>> conditions.
>
>> I have firmware 2.2, but the same slimp3 works fine when i boot into
>> linux
>> on the same pc!!
>
> The point is that the Windows driver might behave dirrerent than the
> Linux one (for instance, more "agressively"). This could trip some bug
> in the SlimP3 stack, which might have been fixed in v2.3.
>
> might-could-might... anyway, v2.3 is not a bad thing to try.
>
> Regards, Niek.
>

Haisam K. Ido
2004-08-19, 16:55
That's awsome. That fixed the problem :-) I did install VPN software a
couple of weeks ago.

This should be in a FAQ.

2.3 firmware did'nt fix the problem.

Thank you.

>
> OK I would still upgrade for 2.3 but one more thing to check is if you
> have any VPN software running on the PC. VPN clients are notorious for
> needlessly interfering with local LAN traffic. In server settings that
> is a field "Max bytes to send in a UDP packet"... you might try
> changing that from 1400 to 1200.
>
>
> On Aug 17, 2004, at 6:02 AM, Haisam K. Ido wrote:
>
>> I have firmware 2.2, but the same slimp3 works fine when i boot into
>> linux
>> on the same pc!!
>>
>>>
>>> If you're talking about SLIMP3 (not Squeezebox) then TCP settings do
>>> not matter.
>>>
>>> The only thing I can think of (since you mentioned a longer ethernet
>>> cable) is perhaps that slimp3 firmware v2.3 has a bug fix for the
>>> ethernet interface which fixes needless collisions under certain
>>> conditions.
>>>
>>> Please check your firmware rev - hold power to reset and then look in
>>> the bottom-right corner of the display.
>>>
>>> Sean
>>>
>>> On Aug 16, 2004, at 6:29 PM, Haisam K. Ido wrote:
>>>
>>>> I have the ability to disable what you mention below, and it is
>>>> already
>>>> disabled, without even upgrading the driver. Does this mean that I
>>>> must
>>>> still upgrade? The only difference from when it used to work is that
>>>> now
>>>> I am using a longer ethernet cable!!!.
>>>>
>>>> Of course, in linux all is well :-)
>>>>
>>>>> i had a similar sounding problem which i cured by reinstalling the
>>>>> latest intel NIC drivers from
>>>>> http://support.intel.com/support/network/adapter/index.htm#PRO
>>>>> and following the FAQ instructiosn ---
>>>>>
>>>>> Once you have the latest version, to disable the feature in
>>>>> question:
>>>>> Right click My Computer and click Properties
>>>>> Click the Hardware tab and click Device Manager
>>>>> Click the + next to Network adapters and double-click your ethernet
>>>>> adapter
>>>>> Click Advanced, and select Offload TCP Segmentation.
>>>>> Set the Value: field to Disabled and click OK.
>>>>>
>>>>>> -----Original Message-----
>>>>>> From: discuss-bounces (AT) lists (DOT) slimdevices.com
>>>>>> [mailto:discuss-bounces (AT) lists (DOT) slimdevices.com] On Behalf Of
>>>>>> Haisam K. Ido
>>>>>> Sent: 16 August 2004 15:59
>>>>>> To: Discuss (AT) lists (DOT) slimdevices.com
>>>>>> Subject: [slim] gittery streaming in winxp but not in linux
>>>>>>
>>>>>> Until recently I was able to stream mp3's to my slimp3 via my
>>>>>> dual boot
>>>>>> system, linux and winxp, without any significant problems. They
>>>>>> both
>>>>>> share the same harddrive which contains the mp3. However,
>>>>>> now in linux
>>>>>> all is well, but in winxp the mp3's are gittery when played
>>>>>> back via the
>>>>>> slimp3. I've looked at the winxp driver for the NIC but nothing is
>>>>>> unusual. What could have happend and how do I solve this? I
>>>>>> am using the
>>>>>> same version of the slimpserver.
>>>>>>