PDA

View Full Version : plugins dont show up



anthony webb
2004-08-15, 00:59
I have 18 plugins in the directory with checkboxes, only 16 show up in the player..

Any idea why that would happen?

-Anthony

anthony webb
2004-08-15, 01:15
Answered my own question... My plugin was not comiling correctly so it wouldn't work right. Got it going fine now though, compiled and showing up in the list OK...


----- Original Message -----
From: anthony webb
To: Slim Devices Discussion
Sent: Sunday, August 15, 2004 1:59 AM
Subject: [slim] plugins dont show up


I have 18 plugins in the directory with checkboxes, only 16 show up in the player..

Any idea why that would happen?

-Anthony


------------------------------------------------------------------------------

Jules Taplin
2004-08-15, 02:54
Yup. That'll do it.

I recommend that before you restart slimserver to check your changes, you do a quick:

'perl -ICPAN -c Plugins/<name_of_your_plugin>.pm'

(You'll need your current directory to be the slimserver root (/usr/local/slimserver for linux systems).

That'll save a lot of time restarting and being irritated ;)

-- Jules

----- Original Message -----
From: anthony webb
To: Slim Devices Discussion
Sent: Sunday, August 15, 2004 9:15 AM
Subject: [slim] plugins dont show up


Answered my own question... My plugin was not comiling correctly so it wouldn't work right. Got it going fine now though, compiled and showing up in the list OK...


----- Original Message -----
From: anthony webb
To: Slim Devices Discussion
Sent: Sunday, August 15, 2004 1:59 AM
Subject: [slim] plugins dont show up


I have 18 plugins in the directory with checkboxes, only 16 show up in the player..

Any idea why that would happen?

-Anthony


----------------------------------------------------------------------------