PDA

View Full Version : Make Squeezebox Server 7.3.3 appears as 7.4.1 (use with SB Radio)



Decap_dk
2010-04-06, 08:46
If you like me have a NAS drive with SBS installed using ipkg chances are that you have version 7.3.3 installed. If you have bought one of Logitech's new Squeezebox devices (such as the Radio) you will find that this require SBS 7.4.x to be able to run.

I have found (with credit to Simon300 for his signature that made me think in these lines ) that a easy mod can make your SBS 7.3.3 install appear as 7.4.1 and be accessible from SB Radio.

In your Squeezebox install folder you need to edit the content of two files:

/opt/share/squeezecenter -> slimserver.pl and slimservice.pl

These files contain the line:

our $VERSION = '7.3.3'; (for slimserver.pl) and
our $VERSION = '7.3.3-sn'; (for slimservice.pl

Now just change the version to e.g. 7.4.1 and restart the server (/opt/etc/init.d/S99squeezecenter stop/start)

Hope this will be helpfull to someone. It made my life a lot easier (as I didnt want to install SBS 7.5.x)

Regards
Decap_dk

andyg
2010-04-06, 08:49
On Apr 6, 2010, at 11:46 AM, Decap_dk wrote:

>
> If you like me have a NAS drive with SBS installed using ipkg chances
> are that you have version 7.3.3 installed. If you have bought one of
> Logitech's new Squeezebox devices (such as the Radio) you will find
> that this require SBS 7.4.x to be able to run.

This is a terrible idea, please don't do this or recommend it to anyone else. There is a reason it requires 7.4, and just changing the version number is no guarantee things will work properly. I would hate to see someone calling support and saying you are running 7.4.1 when in reality you just changed the version number. What a huge waste of time that would be. Just update to the correct version!

t_e_b
2011-09-23, 09:32
Hi guys
I have the same problem- my SB Radio will not connect to the SB Server on my Buffalo LinkStation Live. Before I try this method just wanted to check how you got on with the above method of tricking the Radio? Did it work in the longterm?
Thanks very much
Toby

mikael_b
2011-09-23, 09:42
Exactly what did you not understand in Andys answer.
Decaps idea is at best "not recommended".
Update to the current (or required ) version.

t_e_b
2011-09-24, 09:14
As far as I know there isn't a way to put anything newer that SBServer 7.3 on a Buffalo Linkstation. I understand that the above method is not recommended however the question was for Decap_dk; if he has not experienced any problems then it would be a good solution to my problem.

dsdreamer
2011-09-25, 21:56
As far as I know there isn't a way to put anything newer that SBServer 7.3 on a Buffalo Linkstation. I understand that the above method is not recommended however the question was for Decap_dk; if he has not experienced any problems then it would be a good solution to my problem.

You can upgrade to any SBS that is supported by SSODS, currently 7.6.1. I personally have Version: 7.6.2 - r33496 running on an old LS-GL running F/W 1.15.

If you have root access to an ARM based Linkstation, using SSODS as an environment to run SBS is easier than the previous "easiest install ever." Just follow the instructions at http://oinkzwurgl.org/ssods.

t_e_b
2011-09-26, 11:43
hi dsdreamer
thanks for the advice! I have followed the instructions on that page but am stuck on number 4

-when I enter the command tar -xzvpf /share/public/ssods-4.13-arm.tar.gz
I get the response:
"tar: /share/public/ssods-4.13-arm.tar.gz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error exit delayed from previous errors"

-the ssods-4.13-arm.tar.gz file is in the share/public directory so I don't know why it will not extract.

I have followed all the instructions on the page upto their. Would appreciate any help since I am a linux beginner. Thanks, Toby

dsdreamer
2011-09-26, 12:40
-when I enter the command tar -xzvpf /share/public/ssods-4.13-arm.tar.gz
I get the response:
"tar: /share/public/ssods-4.13-arm.tar.gz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error exit delayed from previous errors"


I can see that you are telling tar to look in /share/public/ssods-4.13-arm.tar.gz, but the file is probably to be found at /mnt/disk1/share/ssods-4.13-arm.tar.gz

I say "probably," because the absolute path depends on the exact type of LinkStation you are using and whether you have a raid array or not.

If you type "df -h" at the command line you should see what mount points exist. Looking at the "mounted on" column of the output of df -h will give you a good clue where to find your ssods tar file. If you see /mnt/disk1 there, cd to do it "cd /mnt/disk1" and type "ls" to see what files and directories are there. If you see "share" then "cd ./share" to get into that directory and again type "ls" to see what files are there.

Report back if still in doubt.

t_e_b
2011-09-26, 13:00
I can see that you are telling tar to look in /share/public/ssods-4.13-arm.tar.gz, but the file is probably to be found at /mnt/disk1/share/ssods-4.13-arm.tar.gz

I say "probably," because the absolute path depends on the exact type of LinkStation you are using and whether you have a raid array or not.

If you type "df -h" at the command line you should see what mount points exist. Looking at the "mounted on" column of the output of df -h will give you a good clue where to find your ssods tar file. If you see /mnt/disk1 there, cd to do it "cd /mnt/disk1" and type "ls" to see what files and directories are there. If you see "share" then "cd ./share" to get into that directory and again type "ls" to see what files are there.

Report back if still in doubt.

thanks very much, I ran "root@Nas:/opt/ssods4# tar -xzvpf /mnt/disk1/share/ssods-4.13-arm.tar.gz" and it worked :)

However the next step didn't seem to work according to plan either:

"root@Nas:/opt/ssods4# LC_ALL= /opt/ssods4/etc/init.d/rc.ssods start
/opt/ssods4/etc/ssods.conf: line 201: warning: setlocale: LC_ALL: cannot change locale (en_GB.UTF-8): No such file or directory
/opt/ssods4/bin/bash: warning: setlocale: LC_ALL: cannot change locale (en_GB.UTF-8)
/opt/ssods4/etc/ssods.conf: line 201: warning: setlocale: LC_ALL: cannot change locale (en_GB.UTF-8)
SSODS: checking system ...
ERROR: no user 'ssods' and/or no group 'ssods' found!

You have two options:

a) create the user 'ssods' and the group 'ssods'.

b) create a file /opt/ssods4/etc/ssods-local.conf with three lines:

SSUSER=a_user_name
SSGROUP=a_group_name
THTTPDUSER=a_user_name

Then try again.

Note: the chosen user and/or group must have read permissions on the music library."

What would you recommend. Thanks again for help. Toby

t_e_b
2011-09-26, 14:51
I have been on Linkstation Web Settings and added the user SSODS and group SSODs, and restarted the NAS. However still getting the error:

root@Nas:~# LC_ALL= /opt/ssods4/etc/init.d/rc.ssods start
SSODS: checking system ...
ERROR: no user 'ssods' and/or no group 'ssods' found!

You have two options:

a) create the user 'ssods' and the group 'ssods'.

b) create a file /opt/ssods4/etc/ssods-local.conf with three lines:

SSUSER=a_user_name
SSGROUP=a_group_name
THTTPDUSER=a_user_name

Then try again.

Note: the chosen user and/or group must have read permissions on the music library.

Any ideas what to do next? cheers!

t_e_b
2011-09-26, 15:01
OK I found a previous post of yours: http://forums.slimdevices.com/showthread.php?t=83892 (post 5)

- I ran"adduser ssods" and now it is letting me install the SqueezeServer :)

"root@Nas:~# adduser ssods
Enter new UNIX password:
Retype new UNIX password:
passwd: password updated successfully
root@Nas:~# LC_ALL= /opt/ssods4/etc/init.d/rc.ssods start
SSODS: checking system ..... OK.
Starting SqueezeboxServer .. skipping, auto start is disabled.
Updating /opt/ssods4/etc/sudoers .. OK.
Starting thttpd-ssods ...... OK.
root@Nas:~# mkdir -p /usr/local/etc/rc.d/
<s4/etc/init.d/rc.ssods /usr/local/etc/rc.d/ssods.sh
root@Nas:~# ln -s /opt/ssods4/etc/init.d/rc.ssods /usr/local/etc/rc.d/ssods.sh"

-however you advised to delete the ssods-local.conf, so that SSODS goes back to using user and group 'ssods'. I didn't know how to do this so have omitted it: should I be worried?
Thanks again
Toby

dsdreamer
2011-09-26, 18:22
[QUOTE=t_e_b;659874
-however you advised to delete the ssods-local.conf, so that SSODS goes back to using user and group 'ssods'. I didn't know how to do this so have omitted it: should I be worried?
Thanks again
Toby[/QUOTE]

In the context of that other thread, someone had created a ssods-local.conf to work around the lack of the preferred {user, group} IDs to run ssods. If you didn't create ssods-local.conf, there is no need to delete it.

In other words, it is best not to try to work around the lack of a defined user ssods, but simply to add the user "ssods," which is what the SSODS scripts expect by default on the Linkstation.

Have you got SBS 7.6.1 up yet? It seems like you're close.

t_e_b
2011-09-27, 11:33
7.6.1 we are GO! very happy.
I just need to sort out autostart now: when I restarted the LinkStation I had to run "$ LC_ALL= /opt/ssods4/etc/init.d/rc.ssods start" to get it going again.

- I have enabled autostart in SSODS websettings (Toggle autostart Autostart is enabled.)
-I have run the commands:
$ mkdir -p /usr/local/etc/rc.d/
$ ln -s /opt/ssods4/etc/init.d/rc.ssods /usr/local/etc/rc.d/ssods.sh

Any help appreciated as always =)
Toby

dsdreamer
2011-09-27, 13:15
7.6.1 we are GO! very happy.
I just need to sort out autostart now: when I restarted the LinkStation I had to run "$ LC_ALL= /opt/ssods4/etc/init.d/rc.ssods start" to get it going again.

- I have enabled autostart in SSODS websettings (Toggle autostart Autostart is enabled.)
-I have run the commands:
$ mkdir -p /usr/local/etc/rc.d/
$ ln -s /opt/ssods4/etc/init.d/rc.ssods /usr/local/etc/rc.d/ssods.sh

Any help appreciated as always =)
Toby

Different Linkstations do this differently, but I am pretty sure start-up scripts in /usr/local/etc/rc.d/ are not activated at boot time on any Linkstation, hence the failure.

Can you check if you have a directory named /opt/etc/init.d ? If you "cd" to that directory, and type "ls" you should be able to confirm this point.

If so, please try Ropewalk's method from this post: http://forums.slimdevices.com/showpost.php?p=546909&postcount=23

If not, please report back here and I will try to help.

t_e_b
2011-09-27, 18:41
Hi
I tried to cd to it but got a 'no such directory' message:

"root@Nas:~# cd /opt/etc/init.d
-sh: cd: /opt/etc/init.d: No such file or directory
root@Nas:~# cd opt/etc/init.d
-sh: cd: opt/etc/init.d: No such file or directory"

Toby

dsdreamer
2011-09-27, 22:22
Hi
I tried to cd to it but got a 'no such directory' message:

"root@Nas:~# cd /opt/etc/init.d
-sh: cd: /opt/etc/init.d: No such file or directory
root@Nas:~# cd opt/etc/init.d
-sh: cd: opt/etc/init.d: No such file or directory"

Toby

I recommend running the following command to make a symbolic link to the startup script:


ln -s /opt/ssods4/etc/init.d/rc.ssods /etc/init.d/ssods.sh


After that, it depends on the Linkstation type and age as to how we get that script to run. The output of the command "cat /etc/inittab" will help determine what to do next. Please paste the output of that command in a message on this forum.

One possibility has us directly editing /etc/init.d/rcS to invoke the startup script, another possibility has us creating new symbolic links in various sub-directories of /etc/rc.d/ to start and stop ssods when various run-levels are entered. Does the directory /etc/rc.d exist on your system?

t_e_b
2011-09-28, 00:18
1) Here is the output:

"root@Nas:~# ln -s /opt/ssods4/etc/init.d/rc.ssods /etc/init.d/ssods.sh
root@Nas:~# cat /etc/inittab
::sysinit:/etc/init.d/rcS

::restart:/sbin/init
::shutdown:/etc/init.d/rcDown
::shutdown:/bin/umount -r /
root@Nas:~# "

2)yes I think it exists:
"root@Nas:~# cd /etc/rc.d
root@Nas:/etc/rc.d# ls
extensions.d rc0.d rc3.d rc6.d
init.d rc1.d rc4.d sysinit.d
initweb.d rc2.d rc5.d
root@Nas:/etc/rc.d# "

Thanks, Toby

dsdreamer
2011-09-28, 07:41
1) Here is the output:

"root@Nas:~# ln -s /opt/ssods4/etc/init.d/rc.ssods /etc/init.d/ssods.sh
root@Nas:~# cat /etc/inittab
::sysinit:/etc/init.d/rcS

::restart:/sbin/init
::shutdown:/etc/init.d/rcDown
::shutdown:/bin/umount -r /
root@Nas:~# "

2)yes I think it exists:
"root@Nas:~# cd /etc/rc.d
root@Nas:/etc/rc.d# ls
extensions.d rc0.d rc3.d rc6.d
init.d rc1.d rc4.d sysinit.d
initweb.d rc2.d rc5.d
root@Nas:/etc/rc.d# "

Thanks, Toby

The /etc/rc.d/rc3.d directory on your LS contains some symbolic links, that you can verify by doing "cd /etc/rc.d/rc3.d; ls -l" If you could paste the output of that command here, it would be helpful to verify the next step.

What I *think* the next step will be is to make a couple of symbolic link as follows:


cd /etc/rc.d/rc3.d
ln -s ../init.d/ssods.sh ./S99ssods
ln -s ../init.d/ssods.sh ./K01ssods


This assumes that you already made the link I requested in my last post:


ln -s /opt/ssods4/etc/init.d/rc.ssods /etc/init.d/ssods.sh


One way to pre-test this is by stopping and starting SSODS by hand as follows:


/etc/rc.d/init.d/ssods.sh stop
/etc/rc.d/init.d/ssods.sh start


If this works, and the above S99ssods and K01ssods links are in place, then it is quite likely that you are done and that a reboot should bring up SSODS and with it SBS.

I am not 100% confident because my LinkStation has different startup scripts than yours and so I am giving you instructions based on my general knowledge of Linux. But let me know how you get on.

t_e_b
2011-09-28, 10:00
this is the output
"root@Nas:~# cd /etc/rc.d/rc3.d
root@Nas:/etc/rc.d/rc3.d# ls -l
lrwxrwxrwx 1 root root 15 Sep 28 2011 S47ipsec -> ../init.d/ipsec
root@Nas:/etc/rc.d/rc3.d# "

I haven't done anything else yet, would prefer to be (more) sure first!!

NB. I have already made the link "ln -s /opt/ssods4/etc/init.d/rc.ssods /etc/init.d/ssods.sh"

Thanks again.

dsdreamer
2011-09-28, 20:47
this is the output
"root@Nas:~# cd /etc/rc.d/rc3.d
root@Nas:/etc/rc.d/rc3.d# ls -l
lrwxrwxrwx 1 root root 15 Sep 28 2011 S47ipsec -> ../init.d/ipsec
root@Nas:/etc/rc.d/rc3.d# "

I haven't done anything else yet, would prefer to be (more) sure first!!

NB. I have already made the link "ln -s /opt/ssods4/etc/init.d/rc.ssods /etc/init.d/ssods.sh"

Thanks again.

It seems that /etc/rc.d/extensions.d is the better place to put these links.

I recommend trying the following:


cd /etc/rc.d/extensions.d
ln -s ../../init.d/ssods.sh S80_ssods.sh
ln -s ../../init.d/ssods.sh K20_ssods.sh
ls -l


The last "ls -l" is just a check to see if the new links are in place are visually similar to all the links put there by Buffalo.

You should then see something like:


lrwxrwxrwx 1 root root 21 Sep 28 19:51 K20_ssods.sh -> ../../init.d/ssods.sh
lrwxrwxrwx 1 root root 22 Sep 28 19:36 K40_twonky.sh -> ../../init.d/twonky.sh
lrwxrwxrwx 1 root root 30 Sep 28 19:36 K40_webaxs.sh -> /usr/local/webaxs/sbin/init.sh
lrwxrwxrwx 1 root root 26 Sep 28 19:36 K60_bittorrent.sh -> ../../init.d/bittorrent.sh
lrwxrwxrwx 1 root root 24 Sep 28 19:36 K60_lighttpd.sh -> ../../init.d/lighttpd.sh
lrwxrwxrwx 1 root root 22 Sep 28 19:36 K60_mtdaapd.sh -> ../../init.d/itunes.sh
lrwxrwxrwx 1 root root 21 Sep 28 19:36 K60_mysql.sh -> ../../init.d/mysql.sh
lrwxrwxrwx 1 root root 23 Sep 28 19:36 K60_pocketu.sh -> ../../init.d/pocketu.sh
lrwxrwxrwx 1 root root 20 Sep 28 19:36 K60_sshd.sh -> ../../init.d/sshd.sh
lrwxrwxrwx 1 root root 25 Sep 28 19:36 K61_foolwatch.sh -> ../../init.d/foolwatch.sh
lrwxrwxrwx 1 root root 25 Sep 28 19:36 S39_foolwatch.sh -> ../../init.d/foolwatch.sh
lrwxrwxrwx 1 root root 22 Sep 28 19:36 S40B_twonky.sh -> ../../init.d/twonky.sh
lrwxrwxrwx 1 root root 26 Sep 28 19:36 S40_bittorrent.sh -> ../../init.d/bittorrent.sh
lrwxrwxrwx 1 root root 24 Sep 28 19:36 S40_lighttpd.sh -> ../../init.d/lighttpd.sh
lrwxrwxrwx 1 root root 22 Sep 28 19:36 S40_mtdaapd.sh -> ../../init.d/itunes.sh
lrwxrwxrwx 1 root root 21 Sep 28 19:36 S40_mysql.sh -> ../../init.d/mysql.sh
lrwxrwxrwx 1 root root 23 Sep 28 19:36 S40_pocketu.sh -> ../../init.d/pocketu.sh
lrwxrwxrwx 1 root root 20 Sep 28 19:36 S40_sshd.sh -> ../../init.d/sshd.sh
lrwxrwxrwx 1 root root 30 Sep 28 19:36 S40_webaxs.sh -> /usr/local/webaxs/sbin/init.sh
lrwxrwxrwx 1 root root 21 Sep 28 19:50 S80_ssods.sh -> ../../init.d/ssods.sh


Hopefully this will do it. If something doesn't look right as you go through these remaining steps, please post accordingly.

t_e_b
2011-09-29, 07:19
It worked! thankyou so much dsdreamer, wouldn't have been able to get my set up running without you. truly appreciated =)

dsdreamer
2011-09-29, 08:09
It worked! thankyou so much dsdreamer, wouldn't have been able to get my set up running without you. truly appreciated =)

You're welcome.