PDA

View Full Version : One for the gurus and boffins - connection time out issue



EarthWalker
2010-03-26, 05:48
OK this problem is, I think, one for the IT boffins and squeezebox gurus. It is a very long term problem that even baffled the squeezebox help centre. My initial report was bug 8581. Sadly the problem was not solved.


Firstly the problem is one of connection timed out at song change on my SB3. Basically the unit stops playing at the end of a song. The problem is intermittent as sometimes the player will play several songs in a row and other times just one or sometimes even none.


The problem appeared when I purchased a new notebook PC in early 2008 and is only related when I use that notebook.


Testing eliminated
the SB3 - as the unit plays all day without faults at home with another PC and router using wireless. Firmware on SB3 is now version 130.
The router as the fault occurs using 3 different routers and also on direct xover cable connection
Device Drivers the notebook has had all the drivers updated and is running the latest Vista ultimate software updates, always has.
Squeezecentre the problem has occurred on all versions of the software from 2007 on as I have even ran previous versions to fault find. Im now running version 7.4.2 r30215
Connections the fault occurs regardless of connection method (4 different cables have been used and two different wireless networks)
Virus and firewall problems there is a different security suite running than in 2008 (although same company) and the problem occurs also when the firewall is shut down.
Drives the fault occurs no matter what drive is used. Have tested 4 separate drives including the internal drive of the notebook. All the external drives are USB connected.
The music files themselves There is no system as to which files will fail. Even help centre tested the files and determined they were OK.


Basically Im left with the notebook as the source of the problem. In 2008 the final diagnosis was the interference running through the soundcard was surmised to extend to other locations including the network card thus creating a drop of the network at song change. The motherboard was replaced under warranty and the notebook fault fixed.


Short testing of the setup with the dud notebook after the repair indicated the SB3 was at the time working OK but this setup was then packed away and wasnt used for a year or so.


Now having to use the same setup with this dud notebook the same problem is reoccurring. The previous testing indicating all was OK was too short and longer sessions exposed the time out problem again. This time around the SB3 doesnt require a reboot to clear the fault as it did in 2008 (Big thank you Squeezeboxen engineers) and pressing next song sometimes kicks the unit into playing again for a song or two.


Having spent a considerable amount of time testing and trying to work around the problem Im stumped.


One lead I have is I noticed that some users were having "Connection timed out" issues when they were using a raid NAS when a storage control automatically activated during the latter stages of the music file being streamed. This got me thinking as I did see a storage matrix program installed on this PC (by Dell). Opening up the Intel Storage Matrix Controller I found the drivers for this program are not able to be loaded and the program hangs. Diving further into the problem looks like this notebook SATA controller doesnt use RAID or AHCI control which the Intel program is for it as uses IDE.


What does the brains collective here think? Am I on the right track and this Matrix controller needs to go? I cannot normally uninstall as it states the program is being used by a drive yet the device manager doesnt show it.


Are there any other suggestions. Im loathed to use the support centre again as they were so good and spent a lot of time trying to solve this in 2008. Especially since the problem lies with my notebook somewhere and is not any fault of the squeezebox system.


Can anyone give me some pointers on where to go from here?

EarthWalker.

FYI The Server logs shows this error

10-03-24 14:01:11.2576] Slim::Player::Squeezebox2::failedDirectStream (777) Oh, well failed to do a direct stream for: file:///F:/Iomega%20500/files%20not%20in%20backup/MUSIC/Compilations/Austin%20City%20Limits%20Music%20Festival%2004/01%20Debaser-%20Pixies.flac [Connection timed out]


[10-03-24 14:01:21.3449] Slim::Player::Squeezebox2::failedDirectStream (777) Oh, well failed to do a direct stream for: file:///F:/Iomega%20500/files%20not%20in%20backup/MUSIC/Compilations/Austin%20City%20Limits%20Music%20Festival%2004/02%20Hands%20Down-%20Dashboard%20Confessional.flac [Connection timed out]

yerma
2010-03-30, 00:34
Did you try a different OS? Make a backup or change the HDD, and for a test, install SC under Ubuntu. Not as a permanent solution, but to see if it's a software bug (maybe some broken Windows driver) or a hardware error. If the problem persists, it's your hardware...

Phil Leigh
2010-03-30, 00:59
In the Bios, is the internal hard disk shown as "IDE" (rather than AHCI) - if not, change it to IDE. I think you should fully uninstall the Intel matrix drivers but you may need to reformat your disk and reinstall Vista to achieve this.

EarthWalker
2010-04-08, 04:17
I must apologise for the very tardy reply.

I have been busy over the last week or so re installing the OS and programs on this notebook which has never played with the SB3 well.

I think I have finally fixed it (says he grabbing a piece of wood).

My guess is it was the "Beeping" security suite I have been battling with since I bought this notebook. After painstakingly going through and installing the software that was once loaded, this machine started to crash again with the same problems as soon as the security suite was installed. There were no other programs only what Dell provided on the PC at the time of supply.

Have flicked off the security suite (CA suite 2009) and now have McAfee running and all is sweet.

Testing the SB3 now via wireless it has played for nearly two hours without a single hicup.

The security suite made sence as the SB3 would always fail at song change. I'm betting the security suite was vetting the file access and occasionally would be too slow to load the next file up which in turn caused the connection to time out.

I'm one very happy SB3 owner now!!! :-)

EarthWalker