PDA

View Full Version : Problem: Unable to Convert Stream



tgraan
2010-02-21, 09:23
Sudden appearance inability to play Apple Lossless files.

HP Compac /Windows Vista / hardwired to network
Squeezebox / SqueezeboxServer 7.4.1 / wireless
10,000 song library, all ALAC

Everything was working fine for many months, then abruptly stopped working with "Problem: Unable to Convert Stream" message appearing on Squeezebox. After searching these forums, I: rescanned music, installed 7.4.2 pre-release, installed 7.3.4 Squeezecenter, all without solving the problem. Added an mp3 file to the music library and it plays without problem. Log shows: [10-02-21 10:03:22.2741] Slim::Player::Song::open (486) Error: Bad file descriptor: While creating conversion pipeline for: file:///K:/iTunes%201/iTunes%20Music/Sade/Soldier%20Of%20Love/02%20Soldier%20Of%20Love.m4a

Need a little help here.

tgraan
2010-02-24, 08:47
Did I post this to the right forum?

Is the question too simple, or too difficult?

Help.

mherger
2010-02-24, 08:51
did you recently install new antivirus or firewall? What product are you using?

tgraan
2010-02-24, 10:11
Windows Firewall
Avast! v5.0 for antivirus. Both have been installed for at least 1 yr, both kept updated.

Avast! replaced McAfee for me after I traced down Squeezebox problems to McAfee behavior.

tgraan
2010-03-21, 13:20
Problem still not resolved.

Turned off Avast anti-virus and all Avast real-time shields.
Turned off Windows firewall.
Connected SB3 via ethernet.

Rebooted computer and SB3. Still unable to play any ALAC files, with same error message.
???

tgraan
2010-03-23, 08:40
Under the Advanced/File Types tab, I found a solution to my problem. Under the Apple Lossless file type, disabling the conversion to FLAC allowed my ALAC music files to be played (conversion to WAV is enabled). Re-enabling the ALAC/FLAC conversion produced no music, with the "Problem: Unable to convert stream" error message re-appearing. Could there be a problem with the ALAC/FLAC conversion software in my copy of SqueezeCenter?