PDA

View Full Version : SBS on Virtual PC (Win 7)



vagskal
2010-02-20, 02:51
I got a new PC running Win 7 64-bit, which has a virtual PC function. I Installed SBS 7.5 (not the embedded variety) on a virtual PC in XP mode to try that version out. The music seems to be found (it is scanning now), but I cannot see any of my players. The new Win 7 PC is of course connected (wired) to my home network. SBS 7.4.2 is running on an XP PC in the network and the connected devices are listed in my signature. The players work fine with the SBS 7.4.2 music source.

I am quite sure that when I previously installed a separate instance of SBS on another XP PC in the network, the players all showed up automatically and I could just choose the new music source on the players.

Am I missing something obvious here like some setting in the Windows firewall for Win 7?

vagskal
2010-02-20, 03:58
OK, now SBS has found the players, but when I try to use the web UI to switch a player (wired SB3) to the new server the player cannot find the server. And the new server is still not showing up in iPeng. It does not work to manually enter the IP address of the Virtual PC XP machine, as reported by SBS, in the player interface.

pski
2010-02-20, 16:00
OK, now SBS has found the players, but when I try to use the web UI to switch a player (wired SB3) to the new server the player cannot find the server. And the new server is still not showing up in iPeng. It does not work to manually enter the IP address of the Virtual PC XP machine, as reported by SBS, in the player interface.

This is probably a virtual machine setting. I would recommend letting the VM have it's own static IP address rather than sharing it with the "host."

P

vagskal
2010-02-21, 01:37
This is probably a virtual machine setting. I would recommend letting the VM have it's own static IP address rather than sharing it with the "host."
P

Thanks. The Virtual Machine was set to share the physical PC's network connection, which means that the Virtual Machine is not visible on the network. Selecting a physical network card instead made everything work.