PDA

View Full Version : Assigning fixed IP addresses to RADIO etc (NOT THE COMPUTER)



jimbo45
2010-02-18, 03:28
Hi there
is there any way to assign fixed IP addresses to a Duet / Radio running on a LAN

I'm often testing stuff remotely as well and with a router for example you often need to "Port Forward" to specific machines on your LAN. For example you want to access a HOME computer from work via RDP (Windows users) then you need to port forward port 3389 to a specific machine on your local LAN at home.

Now if my computer is down and I've re-started the Squeezebox devices before re-booting the computer the squeezebox devices "Grab" the IP address that I've assigned to the computer with - predictable results as you can guess.

Even if you assign a fixed IP address to your computer it doesn't stop the squeezebox devices grabbing IP addresses if you start them BEFORE your computer.

It's not really convenient to ensure all the squeezebox devices are turned OFF before re-booting the computer.

On a LAN with a lot of testing (I'm running 5 or 6 Virtual Machines as well on this LAN) I really would like the squeezebox devices to have their own IP addresses to avoid a lot of silly networking problems.

BTW a lot of people having connectivity problems can usually solve these by switching off their squeezebox devices, restart their router, reboot the computer and THEN switch on the squeezebox devices.

Cheers
jimbo

andynormancx
2010-02-18, 03:41
You can assign static IP addresses to the Radio, Touch and Controller.

However you could also probably resolve this issue at your router. Set aside a range in your address space for static IP addresses and set your computer and VMs to static addresses rather than relying on DHCP.

Relying on your computer and VMs to get their addresses via DHCP if you want them to end up with the correct addresses is a fragile approach, with out without Squeezeboxes in the mix.

If you really do want your Squeezeboxes on static IPs, then turn of DHCP on your router and then run through the network setup on the Squeezeboxes again, you'll get the option to enter a static address. Then turn DHCP back on on your router.

jimbo45
2010-02-18, 03:53
Hi there
thanks again for a solution.

I'm fairly new to all this networking stuff -- this basic info is actually quite hard to get hold of if you aren't used to dealing with it.

I'm OK at setting up applications etc but "Networking" has always been a closed book to me.

Cheers
jimbo

nk7z
2010-02-18, 05:10
Hi,

Most routers will allow you to set an IP address for a specific MAC address. I use a Netgear Router, and it assigns the same address to any device I have set it to. Look under Attached Devices to get the MAC, then look under IP Assignments. Add the IP you want, add the MAC for the device, and you are set... That way you don't even have to touch the remote hardware.

Dave

funkstar
2010-02-18, 07:22
Hi,

Most routers will allow you to set an IP address for a specific MAC address. I use a Netgear Router, and it assigns the same address to any device I have set it to. Look under Attached Devices to get the MAC, then look under IP Assignments. Add the IP you want, add the MAC for the device, and you are set... That way you don't even have to touch the remote hardware.

Dave
This is what I do, everything has it's own permanent IP served by DHCP. I also split it up, networking hardware is 10.0.0.1-9, server and PCs are 10.0.0.10-99, Squeezeboxes are 10.0.0.100+

I don't use them all obviously, but it makes finding a device on the network a lot easier.

bobkoure
2010-02-18, 10:26
...get their addresses via DHCP if you want them to end up with the correct addresses is a fragile approach
AFAIK, this is only fragile with windows wireless clients, and is in an issue in the ms wireless stack. Shouldn't be any kind of issue with SBs.
If you're using the same device for a DHCP server and a DNS proxy (the normal case with home firewalls) you get the advantage that reserved DHCP addresses are returned to DNS queries (so you can use "sb1" rather than "10.3.2.64").

andynormancx
2010-02-18, 11:15
The fragility that I'm talking about has little to do with MSFT's network stack and everything to do with the typically lousy DHCP implementation on consumer level routers. I'd also not recommend using address reservation on many consumer routers, the ones I auditioned last year all had big problems in that area.

Either use a real DHCP server or go to fully static addresses for devices you really want to have unchanging IP addresses.

Edit:

I should say that the problem with DHCP on consumer routers only seems to kick in when you load them up with a lot of wifi clients, they typically worked well with a couple of clients. Once loaded up with a couple of laptops, a couple of iPhones and 4 squeezeboxes they fell to pieces.

Which is why I returned to a DHCP server running on a Linux box and Ethernet for all my Squeezeboxes :(

tcutting
2010-02-18, 11:22
I had quite a few problems running dynamic addressing with my Squeezeboxes plus laptop, desktop, printer. I think it was related to the "consumer router DHCP implementation" that andynormancx talked about. Currently everything but my Laptop and my Radio are using "true" static addresses. My router doesn't support reserved addresses. I haven't spent the time to figure out how to set my radio to static addressing... I imagine I could use the "trick" to turn-off DHCP on my router and see if the right dialog comes up when I try to connect, or I recall there's a way to configure it by logging in with SSH and modifying config file(s).

aubuti
2010-02-18, 14:26
I don't have my Radio nearby and don't remember the exact placement of things on the Radio's flavor of Linux, but first place I'd look/edit is /etc/networking/interfaces

Mnyb
2010-02-18, 16:38
I don't have my Radio nearby and don't remember the exact placement of things on the Radio's flavor of Linux, but first place I'd look/edit is /etc/networking/interfaces

Thats what I've done with my controller ssh to it and edit that file.

Turn on remote login in the advanced settings and have a look, must be very similar.