PDA

View Full Version : Squeezebox server hangs System Preferences in OS X



peridot
2010-02-15, 06:14
My Squeezebox Server, which is running under Mac OS X (10.5) has stopped working (was fine up to now).

Opening System Preferences and clicking on the Squeezebox Server icon causes the spinning beachball for a long time although the preference pane does eventually appear. At that point though, the System Preferences app has crashed and I can't select anything on the preference pane.

I followed the instructions in the Wiki to completely uninstall the Server and did a fresh install (7.4.1). This has made no difference.

Any ideas on where to go next? The only other recent change to the machine is the installation of some Presstore backup software. Everything else in System Preferences is working fine.

TIA

mherger
2010-02-15, 08:15
> My Squeezebox Server, which is running under Mac OS X (10.5) has stopped
> working (was fine up to now).

Did you change something? Patch? OSX update? SBS update?

There is a known issue which is not easily reproducible:
https://bugs.slimdevices.com/show_bug.cgi?id=14025

I hope to find time to tackle this soon.

--

Michael

MrBrillo
2010-03-20, 15:25
Same problem here. I've had this for a while. However, I've just downloaded 7.5/30393 and it appears to be reasonably stable - at least no more bouncing beach balls.

I still think there's a problem although not necessarily connected to the server issue.

After re-installing the server I was using it with a degree of success to serve music to one of my SB Boom's. Fantastic - no issues. I then move to another part of the house and turn on my other two SB Boom's, which appear to synch ok. However, after a about four tracks, the first Boom freezes and only a mains unplug/replug seems to revive it. The other booms seem to be playing ok. However, the problem gets progressively worse, with the same issue happening to the other Boom's - so I've turned synchronization off, and all seems to be well (for the time being).

30393 is certainly better - good effort!

MrBrillo
2010-03-22, 10:35
... the server didn't automatically start when I rebooted. I had to manually Start Server - seems fine at present.

esbrewer
2010-03-22, 18:50
Sometimes I don't even bother to try and restart SBS via the pref pane because the hangups are so unpredictable. Restarting my iMac actually takes less time and avoids potential frustration. I think the problem has been present since the move to 7.4, and has persisted despite a clean install of both Mac OS 10.6 and SBS.

Doesn't happen every time though - and as with most others there are no problems with my other pref pane based apps.

mherger
2010-03-23, 00:04
Please note that the PrefPane hanging issue should be fixed in 7.5 nightlies. Please give them a try!

danco
2010-03-23, 01:53
Sometimes I don't even bother to try and restart SBS via the pref pane because the hangups are so unpredictable. Restarting my iMac actually takes less time and avoids potential frustration. I think the problem has been present since the move to 7.4, and has persisted despite a clean install of both Mac OS 10.6 and SBS.


The only hangups I have experienced are that I can't stop the server from the preference pane.

When I need to stop it, I wouldn't restart my Mac, which seems overkill. Going to Activity Monitor and quitting perl works fine.