PDA

View Full Version : Squeezebox Classic (SB3) distorts on max. vol.



bhaagensen
2010-02-07, 05:44
Hi,

my SB3 has recently started to distort really bad when the volume is turned high up. I have NO idea why. Here are the relevant facts (that I can think of):

-No transcoding, crossfading etc.
-AFAI(K/R) all settings are at default.
-Distortion occurs on flac and mp3.
-Duet and TP on same network does not do this.
-Started to occur recently.
-Speakers/amp sounds fine if SB3 volume is at e.g. 70 and I turn up the amp

I tried recording the distortion on my internal laptop mic. Not good. But I uploaded it anyway. The first 15 sec. showcases the distortion, the last part, how it should sound (I turned down the SB3 and then the amp up to illustrate that it isn't the recording)

http://dl.dropbox.com/u/110443/Lydoptagelse%203.mp3

Advice highly appreciated.

Bjørn

Mnyb
2010-02-07, 06:26
Hmm try a xilink reset ? it cures many odd behaviors ?

http://wiki.slimdevices.com/index.php/Hardware_Reset_commands#Reset_Audio_Hardware_.28ak a_Xilinx_Reset.29

bhaagensen
2010-02-07, 07:37
Mnyb: That seems to have done the job. Thanks. I should have thought of this; seems almost like the unsolvable problems are the best ones, because those are the ones the infamous 'xilnix'-reset often takes care of :)

Mnyb
2010-02-07, 09:20
Now lets start a tread over in audiophile on how often one should refresh the xilink for best sound...
But that would ban me for trolling, I'll pass on that one ;)

This reset also cures the "no sound but bar is moving syndrome".
And the "hellishly loud burst of noise at full volume syndrome".