PDA

View Full Version : SB Radio will immer wieder das Update



ing-michel
2010-01-30, 04:53
Hallo,
bei meinem SB Radio bekomme ich alle geschätzte 3-4 Tage die Meldung, dass das Update "7.4.2 r8423" verfügbar sei.
Ich installiere jedes mal - aber langsam nervt das. Kann mir jemand sagen, wie ich das abstellen kann?
-> Die SBS-Version ist (natürlich) stets die in der Signatur genannte
Gruß
Michel

bluegaspode
2010-01-30, 05:51
sicher dass es immer diese revision war ?

In der letzten Woche wurden 3 unterschiedliche Firmware-Versionen für Radio released. Das ist übrigens unabhängig von deinem SB-Server-Version. Da du die 7.4.2-Beta hast, bekommst du übers Internet fürs Radio immer die neueste Firmware.
Um potenzielle Probleme zu vermeiden sollte man auch den Server auf die aktuelle Version hochziehen.


Wenn dir das zu viel Arbeit ist, solltest du auf die offiziell freigegeben 7.4.1-Version gehen - die bleibt konstant.

jo-wie
2010-01-30, 06:24
@bluegaspode

Kein Wunder, wenn man Dich, Marc und Bklaas und diese einen kleinen Thread im Entwickler Forums sieht und liest (das verstehen habe ich zwischenzeitlich aufgegeben^^)

ing-michel
2010-01-30, 06:51
sicher dass es immer diese revision war ?

...bekommst du übers Internet fürs Radio immer die neueste Firmware.


Danke für Deine schnelle Antwort!

zur Revision: hätte es mit einer Wahrscheinlichkeit von 95 behauptet...

-> auch wenn ich auf dem Eigenen Server bin, werden die Updates über das Internet eingespielt?

Gruß
Michel

EDIT: Habe das Update des SBS durchgeführt. Habe jetzt das Problem, dass SBS nicht startet:


0174: 3. Run the .tar.gz version of Squeezebox Server which includes all required CPAN modules.
0173: 2. Update the module's package using apt-get, yum, etc.
0172: 1. Install the latest version of the module(s) using CPAN: sudo cpan Some::Module
0171: To fix this problem you have several options:


Ist mit der Version "squeezeboxserver-7.4.2-29959-arm-linux.tgz" was faul?

bluegaspode
2010-01-30, 11:18
-> auch wenn ich auf dem Eigenen Server bin, werden die Updates über das Internet eingespielt?


Jap - hat mich am Anfang auch immer verwundert. Aber bei den Server-Downloads sind die Firmwares nicht dabei, die werden tatsächlich nachgeladen.
Du bekommst immer die Version die hier
http://update.slimdevices.com/update/firmware/
runterzuladen ist - und für 7.4.2 werden die Dateien derzeit halt ab und zu noch ausgetauscht/erneuert damit du immer wieder neuen Spaß als Beta-Tester hast :)



EDIT: Habe das Update des SBS durchgeführt. Habe jetzt das Problem, dass SBS nicht startet:

Die konkrete Fehlermeldung hast du nicht gepostet.
Aber es könnte sein dass in deinem Download die 'CPAN'-libraries fehlen.

Ich verwende immer den *.deb-Download - der ist interessanterweise auch 14MB größer als der von dir verwendete Download, was die Vermutung bestätigt, dass bei dir Dateien fehlen.

Dummerweise habe ich keine Ahnung was sonst noch richtig sein könnte, am ehesten wohl der 55MB hier:
"Squeezebox Server: Unix Tarball (for Perl 5.8/5.10, Darwin, i386, x86_64, i386 FreeBSD, ARM EABI, PowerPC)"
(http://downloads.slimdevices.com/nightly/7.4/sc/29959/squeezeboxserver-7.4.2-29959.tgz)

Auch wenn da Unix steht - ausprobieren kann ja nicht schaden :) ...
(Übrigens - auch der tgz-Download unter http://downloads.slimdevices.com/SqueezeboxServer_v7.4.1/ ist 55MB - könnt also tatsächlich der 'richtigere' Download sein)

ing-michel
2010-01-31, 04:42
Hallo,
vielen Dank für Deine ausführliche Antwort.
Leider läuft die aktuelle 7.4.2 immer noch nicht bei mir (Fehler in der txt-datei).
Weder die
Squeezebox Server: Unix Tarball (for Perl 5.8/5.10, Darwin, i386, x86_64, i386 FreeBSD, ARM EABI, PowerPC)

noch die

Squeezebox Server: ARM Linux Tarball (for Perl 5.8/5.10, ARM EABI)

beide 29959

laufen nicht auf meiner DS107+ mit SSODS 4.4

bluegaspode
2010-01-31, 11:20
Ich fürchte da musst du dann beim SSODS-Entwickler nachfragen.
Das Startup-Script macht anscheinend irgendwas komisches (die ganzen 'Disabled' und 'Patching' Meldungen sind z.B. speziell nur bei SSODS), was ich nicht kenne.

Die konkrete Fehlermeldung ist:
0603: Audio::Scan (loaded 0.57, need 0.58)

Auf deinem System wird eine veraltete SqueezeCenter-Bibliothek (Audio::Scan) verwendet.

ing-michel
2010-02-01, 01:56
... werde ich machen, vielen Dank für Deine Hilfe soweit!
Michel