PDA

View Full Version : New product: Graphic Squeezebox



Michael Dubno
2004-08-05, 10:19
Even though perl is not my native language, I think it is about time to
start contributing. Do you have any links to documentation on the display
interface to look at?
Thanks - Mike

-----Original Message-----
From: discuss-bounces (AT) lists (DOT) slimdevices.com
[mailto:discuss-bounces (AT) lists (DOT) slimdevices.com] On Behalf Of kdf
Sent: Tuesday, August 03, 2004 11:21 PM
To: Slim Devices Discussion
Subject: [slim] New product: Graphic Squeezebox

Quoting Michael Dubno <michael (AT) dubno (DOT) com>:

> This is fantastic. What are changes have been made to access the new
> displays functionality from the command line interface?

none. what exists now is a replication of the existing features, using new
fonts capabilities. slider bars are done graphicly, as well as animation.
The
CLI features to access the text size controls, and send text are the same as
before. Patches for new features are welcome.

> Are fixed width fonts still supported?

the old style graphics are still suported, and ANY font can be supported.
the
server parses a BMP file for a font. checkout a copy of cvs and start
digging
:)

-kdf

Marty
2004-08-05, 10:33
I've browsed the forums for the past couple of months and haven't seen quite
this problem metioned, and if it was, I missed it, so here goes:

Upgraded my Windows 2000server machine to the nightly from 5-3-2004.
Everything worked perfectly. I was then streaming shoutcast today, browsing
through the stations, and low and behold, the same lost contact with server,
that was an issue before with shoutcast, came again. Usually when I ran
into this problem before, I would simply power cycle the SB and all would be
well. But this time, it didn't work. I've uninstalled that nightly,
replaced it with 8-4-04s and I still can't connect to the server. The
software IS running, I have no logs, and the SB IS getting an IP address
because I can ping it, it just can't connect to the slim server. I've even
tried installing the latest official release of 5.2.1 to no avail. I also
unplugged SB, let it sit for about 10 mins, and still no conatct w/server.
Tried rebooting server several times: nothing. I'm at a loss. Currently it
has firmware v.31 and server v.5.2.1 . HELP!

Marty

kdf
2004-08-05, 10:39
if you have downloaded the tar.gz or .zip version of the server, you have all
those .pm files :)

its so new, there really isn't any formal docs. Look for
Slim/Display/Graphics.pm and Slim/Player/SqueezeboxG.pm for the bulk of the new
stuff. If you have any questions about specifics, please feel free to join us
on the developers list and ask away. Its a bit of a learnign curve, but if a
total hack coder like me can get into it, anyone can :)

-kdf

Quoting Michael Dubno <michael (AT) dubno (DOT) com>:

> Even though perl is not my native language, I think it is about time to
> start contributing. Do you have any links to documentation on the display
> interface to look at?
> Thanks - Mike
>
> -----Original Message-----
> From: discuss-bounces (AT) lists (DOT) slimdevices.com
> [mailto:discuss-bounces (AT) lists (DOT) slimdevices.com] On Behalf Of kdf
> Sent: Tuesday, August 03, 2004 11:21 PM
> To: Slim Devices Discussion
> Subject: [slim] New product: Graphic Squeezebox
>
> Quoting Michael Dubno <michael (AT) dubno (DOT) com>:
>
> > This is fantastic. What are changes have been made to access the new
> > displays functionality from the command line interface?
>
> none. what exists now is a replication of the existing features, using new
> fonts capabilities. slider bars are done graphicly, as well as animation.
> The
> CLI features to access the text size controls, and send text are the same as
> before. Patches for new features are welcome.
>
> > Are fixed width fonts still supported?
>
> the old style graphics are still suported, and ANY font can be supported.
> the
> server parses a BMP file for a font. checkout a copy of cvs and start
> digging
> :)
>
> -kdf
>

Marty
2004-08-05, 13:40
I'm gonna reply to my own post:

I finally, as a last string went through the network setup again, after
plugging the SB back into the wall, and for some reason, I don't know if
it's just default, but it was looking for the software at the IP of my
router. The only thing that's changed is that I updated my Linksys -
WRT54g's firmware to the latest 3rd party version released by sveasoft.
Either way, I manually input the IP of the server, and all is well again. :)
So thanks to those of you who post before you read this.

Marty


----- Original Message -----
From: "Marty" <picard14 (AT) hotmail (DOT) com>
To: "Slim Devices Discussion" <discuss (AT) lists (DOT) slimdevices.com>
Sent: Thursday, August 05, 2004 1:33 PM
Subject: [slim] Lost Contact: won't come back!


> I've browsed the forums for the past couple of months and haven't seen
quite
> this problem metioned, and if it was, I missed it, so here goes:
>
> Upgraded my Windows 2000server machine to the nightly from 5-3-2004.
> Everything worked perfectly. I was then streaming shoutcast today,
browsing
> through the stations, and low and behold, the same lost contact with
server,
> that was an issue before with shoutcast, came again. Usually when I ran
> into this problem before, I would simply power cycle the SB and all would
be
> well. But this time, it didn't work. I've uninstalled that nightly,
> replaced it with 8-4-04s and I still can't connect to the server. The
> software IS running, I have no logs, and the SB IS getting an IP address
> because I can ping it, it just can't connect to the slim server. I've
even
> tried installing the latest official release of 5.2.1 to no avail. I also
> unplugged SB, let it sit for about 10 mins, and still no conatct w/server.
> Tried rebooting server several times: nothing. I'm at a loss. Currently
it
> has firmware v.31 and server v.5.2.1 . HELP!
>
> Marty
>