View Full Version : 5.3.0b1 Shuts down with Connecting Webstream

Thomas B. Malsbury
2004-08-05, 08:33
I just wanted to report that when a friend tried to connect to my
slimserver just using stream.mp3 over port 9000 it cuased slimserver to
shutdown. I have been using SoftSqueeze for months now, so I hadn't
tried the webstream since the update to 5.3.0b1. I have been able to
reproduce it myself using both Windows Media Player 9 and iTunes from
work and restart the server using putty, so if any logging would be of
assistance let me kow which ones to turn on and where to send them.

What seems to be happening is that the media player connects, streams
the silence over fine. Then when you open the web iterface you can see
the IP address in the list of player settings, but when you click on any
link or the player drop down menu slimserver shuts down. Putty'ing in
and using '/etc/init.d/slimserver status' shows that the slimserver is
stopped. I can restart it and everything works, I see that my 3 Slimp3s
at home reconnect and I can connect from work using SoftSqueeze, but as
soon as a Media Player connects to stream.mp3, the next action in the
web interface stops the server.

Here are the particulars:

-SlimServer 5.3.0b1 official release
-Fedora Core2 Server
-P4 1.5ghz w/ 512Ram
-5,600 MP3s @ 256kbps CBR
-Slimserver behind hardware FireWall with only ports 9000 and 22 open

-Microsoft W2k cuased problem using MediaPlayer9 after upgrade to
-Installed Softsqueeze and works fine over ssh

-Microsoft XP, been using SoftSqueeze over ssh fine since upgrade
-Windows MediaPlayer9 and iTunes both cuase the problem repeatedly