PDA

View Full Version : Missing WMVCORE.DLL, Can't Play WMA Under NT 4.0



Michael Sigalos
2004-08-04, 08:00
Running the latest nightly build on an NT 4.0 Server. Been running
SlimServer for ages with just MP3s. Last night I tried to play a WMA file
(non-DRM) and the Squeezebox stopped responding while the server displayed
a dialog box saying something to the effect that "WMADEC cannot find
WMVCORE.DLL in the path". True. WMVCORE.DLL isn't on the system. I had
to stop the service and restart to clear the error. Quick research says
that this DLL is related to Media Player 9. Unfortunately, Media Player
6.4 is the last version that is supported under NT 4.0. Would anyone have
a suggestion on how I can enable WMA support with a Squeezebox and NT 4.0?

kdf
2004-08-04, 10:37
Quoting Michael Sigalos <miguel.slimdevices (AT) zoemail (DOT) net>:

> Running the latest nightly build on an NT 4.0 Server. Been running
> SlimServer for ages with just MP3s. Last night I tried to play a WMA file
> (non-DRM) and the Squeezebox stopped responding while the server displayed
> a dialog box saying something to the effect that "WMADEC cannot find
> WMVCORE.DLL in the path". True. WMVCORE.DLL isn't on the system. I had
> to stop the service and restart to clear the error. Quick research says
> that this DLL is related to Media Player 9. Unfortunately, Media Player
> 6.4 is the last version that is supported under NT 4.0. Would anyone have
> a suggestion on how I can enable WMA support with a Squeezebox and NT 4.0?

the server used to use ffmpeg at one point. you could try using this again.
first, you will need to seek out a copy of ffmpeg for NT, and save it to a
folder in your PATH environment variable. For NT, a good pace would be
c:\WINNT or C:\WINNT\SYSTEM.

I found a copy here that might work for you:
http://freedom.dicea.unifi.it/ftp/pub/nt/ffmpeg.exe

edit the convert.conf so that you have the following:
wma wav squeezebox *
[ffmpeg] -i $FILE$ -f wav -

wma mp3 * *
[ffmpeg] -i $FILE$ -f wav - | $lame$ --slient -b $BITRATE$ - -

hope that helps.
-kdf

dean
2004-08-04, 13:53
Alas, I think you are out of luck if you want to use the wmadec that
ships with SlimServer, as you need an updated Windows Media Player
installed.

Consider Win2k...

-dean

On Aug 4, 2004, at 8:00 AM, Michael Sigalos wrote:

> Running the latest nightly build on an NT 4.0 Server. Been running
> SlimServer for ages with just MP3s. Last night I tried to play a WMA
> file
> (non-DRM) and the Squeezebox stopped responding while the server
> displayed
> a dialog box saying something to the effect that "WMADEC cannot find
> WMVCORE.DLL in the path". True. WMVCORE.DLL isn't on the system. I
> had
> to stop the service and restart to clear the error. Quick research
> says
> that this DLL is related to Media Player 9. Unfortunately, Media
> Player
> 6.4 is the last version that is supported under NT 4.0. Would anyone
> have
> a suggestion on how I can enable WMA support with a Squeezebox and NT
> 4.0?
>