PDA

View Full Version : Installing SqueezeboxServer on Sheevaplug by a Linux newbie: success



kesey
2009-12-24, 03:51
I'm about to embark on the voyage (hopefully short and sweet) to getting Squeezeboxserver 7.4.2 working on the Sheevaplug. This will be connected by ethernet cable to a router which delivers wired and wireless networking to my home. I've bought, after speaking with New It, the Multi-Boot Sheeva - Debian Squeeze 4Gb SD with an Additional SD card - Integral Ultima 4G class 6 with Debian Squeeze. I'll keep a list of Sheevaplug, SqueezeboxServer and other resources on this post, which I will update as I find my way around, for easy access.

I've been using the Squeezebox Classic for a number of years now. I also have a Duet and a Boom. I store my music on a desktop internal hard drive, but also keep copies on a number of USB-powered external drives. I've used mostly Windows variants (all flavours from 3.1 up to Windows 7 Pro 64 bit) up until now. I installed Ubuntu 8.04 and 9.04 on an old desktop and got Slimserver and later Squeezeserver running on that. The desktop was too blooming noisy so I did not do too much work on it, but I took the opportunity to play with Ubuntu a bit. I'm very much a Linux newbie as of December 2009 and have installed Ubuntu 9.04 on a laptop to dual boot with XP Pro SP3.

I would note that as a newbie, I've found it impossible to get Squeezeboxserver (7.4.1. or 7.4.2) on Ubuntu 9.10 to talk to my USB hard-drive, so I've reverted to Ubuntu 9.04 on which I've installed Squeezeboxserver 7.4.2. Ubuntu 9.04 shows my USB hard drive in /media/

Firstly, I want to thank New It for the marvellous service on delivery. I ordered on Friday afternoon Dec 18th, and the Sheevaplug was delivered to my home in Ireland on Tuesday Dec 22nd. That kind of service is as good as it gets.

Regarding SqueezeboxServer, I use 7.4.2 and update regularly to the new nightly. These are obtainable here:
http://downloads.slimdevices.com/nightly/7.4/
You can get 7.5 (the "unstable" i.e. development version) here: http://downloads.slimdevices.com/nightly/7.5/
7.4.2 is nominally the "testing" version, but is in fact very stable in both Windows and .deb flavours.

Installation:

1: Set up the serial USB connection as per http://plugcomputer.org/plugwiki/index.php/How-to_setup_PuTTY_for_the_SheevaPlug_on_Windows

As I was using a desktop with Windows 7, this entailed, for me, installing the WindowsTeraTermUSBDriver from the SheevaPlug Development Kit CD (for USB Port A, USB Port B and USP Port .i.e. 3 times). PuTTY then worked fine.

2: Connect your ethernet cable from your router to your Sheevaplug.

3: Open PuTTY. Log into Debian using the Username and Password in your documentation

4: Apt-get update

I tried apt-get install on the latest nightly 7.4.2 and it did not work for me, so next step was to try wget instead:

5: wget http://downloads.slimdevices.com/nightly/7.4/sc/29673/squeezeboxserver_7.4.2~29673_all.deb

dpkg -i squeezeboxserver_7.4.2~29673_all.deb
apt-get -f install

6: Use the web browser, on the computer you are running PuTTY from, to go to ShevaPlug_ip_address:9000 (for me 192.168.15.102:9000)

7: You should now be in the Squeezebox Server web-page.

USB HARD-drive

Note: I tried this with an NTFS drive on SheevaPlug Debian, and it said " mount: unknown filesystem type 'ntfs' "

courtesy of: http://www.linuxquestions.org/questions/mandriva-30/mount-an-external-ntfs-usb-hard-disk-201441/

"Plug the USB Hard-drive in and then open a terminal and enter the command dmesg . Look for something like:

usb 1-5: new high speed USB device using address 2
scsi2 : SCSI emulation for USB Mass Storage devices
Vendor: IC25N020 Model: ATCS04-0 Rev: CA2O
Type: Direct-Access ANSI SCSI revision: 02
SCSI device sda: 39070080 512-byte hdwr sectors (20004 MB)
sda: assuming drive cache: write through
sda: sda1
Attached scsi disk sda at scsi2, channel 0, id 0, lun 0
USB Mass Storage device found at 2
The details will be different but the important bit is the line
sda: sda1
Dmesg has seen an sda disk and it is calling it sda1. So if I open a terminal and become root I can
mount /dev/sda1 /some/empty/folder." In my case, the command is
mount /dev/sda1/ /media/

I formatted a Lacie 250Gig drive to Fat 32, copied a few files to it...:

THE RESULTS:
Version: 7.4.2 - r29673 @ Wed Dec 23 04:01:49 PST 2009
Hostname: debian
Server IP Address: 192.168.15.102
Server HTTP Port Number: 9000
Operating system: Debian - EN - utf8
Platform Architecture: armv5tel-linux
Perl Version: 5.10.1 - arm-linux-gnueabi-thread-multi
MySQL Version: 5.1.41-3
Total Players Recognized: 0

Library Statistics
Total Tracks: 9,368
Total Albums: 716
Total Artists: 717
Total Genres: 70
Total Playing Time: 688:58:55

Music Scan Details
Directory Scan (9368 of 9368) Complete 00:28:39

Playlist Scan (350 of 350) Complete 00:05:32

Merge Various Artists (693 of 693) Complete 00:01:23

Artwork Scan (716 of 716) Complete 00:21:30

The server has finished scanning your music collection.
Total Time: 00:57:04 (Thursday, December 24, 2009 / 3:51 AM)

Not bad at all, 57 mins total scanning time will work!





Resources:

New It:
http://www.newit.co.uk
Forums: http://www.newit.co.uk/forum/index.php/topic,188.0.html (post by NewIt_Marcus 5th on the page)

Slim Devices/Logitech:
Downloads: http://downloads.slimdevices.com/nightly/7.4/
http://downloads.slimdevices.com/nightly/7.5/
Forums: http://forums.slimdevices.com/
Wiki: http://wiki.slimdevices.com/index.php/Main_Page
http://wiki.slimdevices.com/index.php/SheevaPlug_Installation_guide

dave77
2009-12-24, 04:24
Nice write up :)