PDA

View Full Version : slimserver thinks m4a AAC files have zero length size



Torgeir Veimo
2004-08-01, 08:08
Can someone with the indepth knowledge about slimserver please check the
problems described in threads "Playing .m4a files?" and "prob w aac
playback under linux;..." ?

--
-Torgeir

Andrew W. Donoho
2004-08-01, 08:29
Torgeir,

As the guy who got faad2 running on Linux for SlimServer, I can
probably help you. I have been following your travails but have no
clear idea what your problem is?

I recommend that you follow my instructions, which are in the maillist
archive, March 2nd, 2004, below (I have edited it to incorporate my
current configuration):

Folks,

I want to report success getting AAC files to play on SqueezeBox at
high fidelity. (My previous posts on this area exposed a bug in the
codec that induced a hiss into the PCM stream and required a LAME work
around.) It now sounds as good from Linux into my Edirol Powered
Digital Monitors as either the Mac or Windows based QuickTime code
(mov123). Cudos to the team at AudioCoding.com, who host the FAAD2
decoder (Congrats Menno and Ivan!), who tracked down the bugs in the
decoder and fixed them. You PC folks may wish to consider their PC
encoder/CD/decoder products at Nero.com.

Now for the details to install on Linux (they are substantially similar
for Mac OS X but unnecessary there):

Using BASH to get the code while it is still in CVS before the next
interim release:

CVSROOT=:pserver:anonymous (AT) cvs (DOT) audiocoding.com:/cvsroot/faac
export CVSROOT
cvs login

(Hit return when asked for a password)

cvs co faad2
cd faad2
autoreconf -vif
../configure --with-mp4v2
make
sudo make install


Copy convert.conf to slimserver-convert.conf. Now edit
slimserver-convert.conf. Delete all non-commented lines (those without
a leading #). Then add the last two lines below.:

mov wav squeezebox *
[faad] -f 2 -w $FILE$

mov mp3 squeezebox *
[faad] -f 2 -w $FILE$ | [lame] -s 44.1 --resample 44100
--silent -q 9 -b $BITRATE$ -r -x - -


Go into server settings via the browser, turn on these two items. Turn
off the competing items that use mov123.

On Aug 1, 2004, at 10:08, Torgeir Veimo wrote:

> Can someone with the indepth knowledge about slimserver please check
> the
> problems described in threads "Playing .m4a files?" and "prob w aac
> playback under linux;..." ?
>
> --
> -Torgeir
>
>

Torgeir Veimo
2004-08-01, 08:56
On Sun, 2004-08-01 at 10:29 -0500, Andrew W. Donoho wrote:
>
>
>

kdf
2004-08-01, 11:40
think I see the problem. stay tuned.


Quoting Torgeir Veimo <torgeir (AT) pobox (DOT) com>:

> Can someone with the indepth knowledge about slimserver please check the
> problems described in threads "Playing .m4a files?" and "prob w aac
> playback under linux;..." ?
>
> --
> -Torgeir
>
>

kdf
2004-08-01, 12:01
Quoting Torgeir Veimo <torgeir (AT) pobox (DOT) com>:

> On Sun, 2004-08-01 at 10:29 -0500, Andrew W. Donoho wrote:
> >
> >
> >

Torgeir Veimo
2004-08-03, 05:45
On Sun, 2004-08-01 at 12:01 -0700, kdf wrote:
> Quoting Torgeir Veimo <torgeir (AT) pobox (DOT) com>:
>
> > On Sun, 2004-08-01 at 10:29 -0500, Andrew W. Donoho wrote:
> > >
> > >
> > >

Torgeir Veimo
2004-08-03, 06:15
On Tue, 2004-08-03 at 13:45 +0100, Torgeir Veimo wrote:
> On Sun, 2004-08-01 at 12:01 -0700, kdf wrote:
> > Quoting Torgeir Veimo <torgeir (AT) pobox (DOT) com>:
> >
> > > On Sun, 2004-08-01 at 10:29 -0500, Andrew W. Donoho wrote:
> > > >
> > > >
> > > >

Robin Bowes
2004-08-03, 06:19
On Tue, August 3, 2004 13:45, Torgeir Veimo said:
>
> Ok thx. The problem is still there, it thinks the size is zero.
>

This is definitely a bug in faad. I am now successfully playing m4a files in slimserver.

I suggest you do one of two things:

1. Follow Andrew W. Donoho's instructions to build from CVS but make sure you use the -D option to get the most recent revision no later than 26th February 2004, i.e. "cvs co -D 2004-02-26 faad2"

2. Speak nicely to Andrew W. Donoho ;o)

R.
--
http://robinbowes.com

Torgeir Veimo
2004-08-03, 06:32
On Tue, 2004-08-03 at 14:19 +0100, Robin Bowes wrote:
>
>
> This is definitely a bug in faad. I am now successfully playing m4a
> files in slimserver.

Are you 100% sure this is a bug in faad? To me it seems it doesn't even
try to play the file at all.

--
-Torgeir

Torgeir Veimo
2004-08-03, 06:36
On Tue, 2004-08-03 at 14:19 +0100, Robin Bowes wrote:
> On Tue, August 3, 2004 13:45, Torgeir Veimo said:
> >
> > Ok thx. The problem is still there, it thinks the size is zero.
> >
>
> This is definitely a bug in faad. I am now successfully playing m4a files in slimserver.
>
> I suggest you do one of two things:
>
> 1. Follow Andrew W. Donoho's instructions to build from CVS but make sure you use the -D option to get the most recent revision no later than 26th February 2004, i.e. "cvs co -D 2004-02-26 faad2"

cvs -d:pserver:anonymous (AT) cvs (DOT) sourceforge.net:/cvsroot/faac login
cvs -z3 -d:pserver:anonymous (AT) cvs (DOT) sourceforge.net:/cvsroot/faac co -D
2004-02-26 faad2
cd faad2
autoreconf -vif
../configure --with-mp4v2 (fails even without this)
make

results in

[...]
make[3]: Entering directory `/usr/local/src/faad2/plugins/mpeg4ip'
if /bin/sh ../../libtool --mode=compile g++ -DHAVE_CONFIG_H -I. -I. -
I../.. -I../../include -D_REENTRANT -DNOCONTROLS -fexceptions -g -O2
-MT faad2.lo -MD -MP -MF ".deps/faad2.Tpo" -c -o faad2.lo faad2.cpp; \
then mv -f ".deps/faad2.Tpo" ".deps/faad2.Plo"; else rm -f ".deps/faad2.
Tpo"; exit 1; fi
g++ -DHAVE_CONFIG_H -I. -I. -I../.. -I../../include -D_REENTRANT -
DNOCONTROLS -fexceptions -g -O2 -MT faad2.lo -MD -MP -MF .deps/faad2.Tpo
-c faad2.cpp -fPIC -DPIC -o .libs/faad2.o
faad2.cpp: In function `int aac_decode(codec_data_t*, long long unsigned
int,
int, int*, uint8_t*, unsigned int, void*)':
faad2.cpp:241: error: invalid conversion from `int' to `audio_format_t'

--
-Torgeir

Torgeir Veimo
2004-08-03, 11:42
On Tue, 2004-08-03 at 14:32 +0100, Torgeir Veimo wrote:
> On Tue, 2004-08-03 at 14:19 +0100, Robin Bowes wrote:
> >
> >
> > This is definitely a bug in faad. I am now successfully playing m4a
> > files in slimserver.
>
> Are you 100% sure this is a bug in faad? To me it seems it doesn't even
> try to play the file at all.

I got it working now, if I turn of cacheing. When I turn on the cache
again, it stops working. The added sox command takes care of the endian
issue. I found no CVS version of faad that compiled.

--
-Torgeir

kdf
2004-08-03, 11:51
Quoting Torgeir Veimo <torgeir (AT) pobox (DOT) com>:

> On Tue, 2004-08-03 at 14:32 +0100, Torgeir Veimo wrote:
> > On Tue, 2004-08-03 at 14:19 +0100, Robin Bowes wrote:
> > >
> > >
> > > This is definitely a bug in faad. I am now successfully playing m4a
> > > files in slimserver.
> >
> > Are you 100% sure this is a bug in faad? To me it seems it doesn't even
> > try to play the file at all.
>
> I got it working now, if I turn of cacheing. When I turn on the cache
> again, it stops working. The added sox command takes care of the endian
> issue. I found no CVS version of faad that compiled.

server settings->additional server settings->performance.

click wipe cache. that will clear all stale information from the cache file,
and it should then work with the cache on.

-kdf