View Full Version : Squeezebox Remote - "Please Wait"

2009-12-16, 13:53
Hi people,

I just bought a Squeezebox Duet, and store my music on a Synology DS210j NAS box.

Whenever I pick up my remote (after leaving it down for a while) the diplay says "Please Wait" for about 60-90 seconds, before I can start navigating the menus.


I have tried running Squeezebox Server on a (fast!) PC, and it did not help any. (I was afraid my Synology was maybe too slow).

I am running on a wide open wireless network, reception is fine on the remote, around 70-80%.

So I'm wondering.... why the long "wakeup" period. Any ideas for tuning or tweaking my setup?


2009-12-16, 13:57
A power saving feature in the remote (controller) is that it will sleep after a certain amount of time. This is what is happening.

If it is sleeping too quickly for you or if you rather it didn't sleep at all, you can change it in the controller settings.

I don't have a controller in front of me so I can't tell you how to naviate to the change.

2009-12-16, 14:08

Yes, the Controller (or SBC for SqueezeBox Controller as it is more familiarly known on the Forum) does go into suspended mode and usually takes a while to recover. You can disable this by going to Settings->Advanced->Factory Test->Power management. Here you can set the Sleep and Suspend timeout somewhat longer than default. The values are seconds, so the maximum Suspend timeout is one hour. It's even possible to disable Suspend altogether. Be aware that the battery will run flat if you leave the Controller outside of the cradle with Suspend disabled.

I'd guess most Duet users here have tweaked these settings to get the Controller into an usable state. What you experienced and described clearly isn't quite that.

Server performance doesn't affect this behaviour.

I'm sure you'll grow to love the SqueezeBox!


2009-12-16, 15:01
Thanks for your answers, but... :-)

Whats exactly does the following menu items mean:

Sleep Timeout (values from 10 to 120)
Suspend Timeout (values from 10 to 3600)
Suspend Enabled (true or false)
Wireless Power Save (true or false)


Can't seem to find these documented anywhere....

Again, thanks..