PDA

View Full Version : Impossible to boot controller



ksahav
2009-12-08, 11:40
hi,

I had some trouble with my controller one week ago : it was rebooting all the time.
So I tried to update the firmware with an SD card, and now it's worse, it doesn't boot at all (I tried factory reset / hold "+"). Different core file are generated on the SD card (wpa suppliant, jive).
In the log there is this error : Error -3 while decompressing!
What does it mean ? It doesn't not happen at the same step...

The controller's firmware is 7.4.1 r7915.
I attach 2 different log file with the problem.

Is anybody can help me to correct this ?
Thanks

gizek
2009-12-08, 18:05
I'm not sure if you can do firmware upgrade without some boot up and loading part of the system in Controller. I might be wrong though.
You can easily connect to Controller with SSH to play with it.
However there are 2 conditions, system must boot up to the point of initializing wireless card and option via SSH is on. That's the only way you can connect. There is also serial port adapter right at the bottom of your Controller but forget about it.
The firmware of Controller is in jive file, simply compressed file which content is directly copied onto system files of Controller.
If your Controller boots up to the point when it shows "free your music" graphics, it's a fix. It loads primary system Linux and then squeeze software for Controller. Even when it resets at this point, you still have like 20-30 sec. to do some things. This is exactly what happened to me.
I was messing with fonts and some graphics and got Controller stuck in a resetting loop. Used SSH and default all software- it works again. I got some much interest in that technology that I'm beginning to write some applets.

gizek
2009-12-08, 19:22
Did you try to remove battery ?

ksahav
2009-12-09, 01:47
Thanks for your answer gizek.
I remove the battery almost every time I try to reboot. Yesterday I let the controller about 6 hours without battery, and it was the same when I reboot.
In the log I can see that the Linux is booting, but the wireless module is not configured (factory reset ...) so I can't connect on it with ssh.
Sometime the controller boot to the "free you music" image, sometime It ask me if I want to send a crash report, sometime I can choose the language, and sometime there is nothing at all... at the end it crashes.
Is there a way to boot from files located on the SD card ?
Or is it possible to launch scripts to check the validity of the files on the controller's flash ? On the wiki I read that it is possible to put scripts on the SD card which will be launched on boot (only on 7.1 ?) , but It doesn't work for me. Are these scripts launched on Linux boot or on jive boot ?

gizek
2009-12-09, 17:38
Well, if you see "Free your music" graphics, that's definitely Jive loading.
Controller keeps the previous, factory firmware and if this one is no go that could mean basic Linux is altered or some hardware failure, can't really see the reason behind different points up to which system loads, unless it's combination of hardware and software crashing.
In the end you can try serial adapter approach. That will have you logged as root in Linux and go from there - http://wiki.slimdevices.com/index.php/SqueezeOS_Upgrades look at the bottom of the page.
I'll try to find out more about scripting from SD card.

ksahav
2009-12-11, 14:59
Thanks for your answers gizek.

Now my controller is very bad, and it doesn't write any file log. I can only see the logitech logo and nothing happens after. It looks bad.
These evening I have mailed to the logitech support and I will see ...

gizek
2009-12-11, 21:54
Sorry to hear that. Keep us posted what Logitech support says.
If you're still under warranty they should replace it.
Just curious - you did try to reset Controller with no SD inside, didn't you ? Can't tell if it makes any difference though.

ksahav
2009-12-23, 08:04
Just curious - you did try to reset Controller with no SD inside, didn't you ? Can't tell if it makes any difference though.

No difference.

So I contacted the Logitech's support, and explained my problems. They sent me a new duet, and now it works perfectly. The old one is out of order.
Logitech support : :cool:

gizek
2009-12-24, 00:07
Glad to hear that Logitech replaced Controller and now you can enjoy Duet.