PDA

View Full Version : Duet can't connect to public IP



justinm
2009-11-22, 20:40
I'm trying to connect my duet to a public IP (slim server) and keeps saying it can't find it.

I've setup the firewall correctly and can get my V3 squeezebox to to get on the server fine but this duet wont.
Whats really ticking me off is if I add a library and pick a random IP I see an attempt on my routers log of the outgoing traffic. But when I put in my servers IP I get nothing in the log. I have confirmed by sshing to the duet that it can ping my servers public IP, so it's not network (routing) related either.

I first tried adding 9000tcp 3483tcp and 3483udp to my firewall and this allowed my old one to connect, but still not the duet. Then I just allowed anything coming from my home IP to my server, the old one still connects but nnot the duet. Also why would they not include telnet in the duet OS? I can't even do proper testing.

Thank you for reading this, I've been at it for 3 days and I just can't get anything. I spent the first 2 figuring out a firmware update that went bad.

FYI if holding + while power on doesn't work for a "Factory reset" try holding volume up. It does a "revert" according to support. Don't know what that's all about.

kantblue
2009-11-23, 12:13
Hi Justinm

This does seem very odd behaviour, just to confirm, if you select a random PUBLIC ip address, you can see system trying to connect to the random address but it doesn't do this when you put your own public IP address in?

Have you tried connecting to mysqueezebox.com by entering it as a library at (I think!) 89.202.121.131 and seeing if this works? [I'm assuming you did set up a squeezebox account when setting up?]

Something strange is going on, I've partly replied to bump your thread up, but I have to say I'm not using slimserver with a public IP address though that shouldn't be a problem, but I would hazard a guess most users are using private (eg local) ip address schemes, which may limit replies.

If you want to PM me with your public IP address, I could always try adding it as a library here, but I fully understand if you don't want to try this, not so much for security reasons, more for those embarassing tracks we all have lurking on our systems LOL!

kantblue