View Full Version : Squeezebox v3 - keeps rebooting, please help

2009-11-12, 14:11

I bought a Squeezebox 3 in early 2006. It's always given me stellar performance and so in good faith I sold it to someone. The person has emailed me telling me it does not work. It shows the logitech logo then reboots - repeating this process continuously.

Now, I don't have reason to not believe him as he is a trusted person so I've told him to send it me back if he can't fix it. He's tried a hardware reset (pressing and holding add then booting up, and has also tried an audio reset (pressing 1), but the problem continues.

Is this a firmware or hardware problem? Could anyone offer any other advice on what he could try before sending it back to me? Your help would be highly appreciated.

Thank you!

Julius D.
2009-11-12, 14:46
This is an issue that our technical support team can assist you with.

I recommend sending an email to support for additional assistance with this matter.

Please follow the link below the click on the Email Support link.

Please be sure to select the correct product in the product selection drop down menu.

Audio > Network Music Players > then select the correct Squeezebox product you are requesting support for.

http://www.logitech.com/index.cfm/support_downloads/&cl=US,EN <http://www.logitech.com/index.cfm/support_downloads/&cl=US,EN>

2009-11-12, 15:01
Hi Julius.

I don't have the SB on me at the moment, where would the PID, S/N or PN be? Is there anything generic I could fill these fields out with to describe a Slimdevices SB 3 silver and black version?

2010-01-03, 16:28
I bought my SBv3 in July 2006 and recently (December 2009) I ran in the exact same problem : stellar performance => logitech logo continuously repeating !

One morning the SB freezed while playing a song (from library) and after reboot the continous logo appeared. The reset procedure ("Add" button while powering on the device) has no effect.

Our problem and dates are strangely similar... Dead internal battery ?
I emailed Support (same problem with numbers, I only have the MAC address).

2010-01-03, 19:34
I've had the exact same problem with my SB2, and I called support. They said that they had never heard of the problem before and were unable to help me. However, it looks like I am not the only one.

I've posted about this before:

2010-01-04, 00:12
Hi Nikhil,

Thanks for your answer, I just read your post.
Well, we are at least 3 in the same situation, all during December 2009 after several years without problem...

I'm quite sure I have no problem with my electric outlet.
The reset with the "1" button has no more effect than the one with "Add" button.
Even when trying for days, my SB3 never comes on.

2010-01-04, 01:47
Have you tried going to an earlier firmware? I was thinking of 7 or 7.2 or even one of the 6.x, but since it is running at the moment, I am scared to try anything.

I ran SS 6.11 for years on my LinkStation without any problems - the new SBS seems unnecessarily bloated as compared to that release.

2010-01-04, 12:05
Unfortunately because of the continuous reboot, I can't reach the step where I usually point to the right server (SS 6.11), which would trigger the firmware update.

Is there a way to force a firmware update locally (without SS) ?

2010-01-24, 14:40
I have the same problem! has anyone solved this?

I bought two SB3's from a forum member, and one is working great, the other (which looks to be an older one) is now stuck in perpetual reboot cycle.

That's $175 down the drain if I can't get this fixed. (I updated firmware to 123 before the rebooting started)

All suggestions or pointers welcomed. Are some older players not able to handle newer firmware? What's the deal?

[tried diff power supplies, tried removing wireless card - no dice]


2012-06-17, 07:07
Hi everybody,

I have the same problem and it conincidentially hit two of my Squeezeboxes, a Squeezebox V3 and my Squeezebox Boom.

For both, the Boom and the V3, I managed to get it working via wired ethernet, but as soon as I try to reactivate the WLAN, I end up in the endless reboot cycle, which can only be stopped by doing a hardware reset and then I can connect to the wired LAN as my only option...

It is very strange indeed that this happens to two of my Squeezeboxes at the same time... My Transporter, which is always connected through wired ethernet doesn't make any problems, nor does my Squeezebox Touch.

I don't know whether this is a coincidence, but it happen right after doing the June Updates on the Windows 7 PC that runs the Logitech Media Server and the two Squeezeboxes were the only Squeezeboxes that were connected wirelessly to the LMS (the Transporter connects via Ethernet, the Touch via WLAN, but was disconnected from the powerline when it happened to the V3 and Boom). What was also strange is that my LMS showed a message in the LMS control panel for the first time telling my that I didn't have the proper rights to make changes and/or start services. Most options were greyed out. It didn't make a difference whether I Started the LMS control panel directly or as the administrator.

Any idea what this could be? Did both WLAN adapters die on me, literally in the same second? We didn't have a thunderstorm here in Stuttgart, Germany and I never had any damage due to high voltage.

Any help is appreciated!