View Full Version : Squeezebox Controller "already registered"

2009-11-07, 08:24
After upgrading to 4.0, my Controller cannot connect to My Apps. On mysqueezebox.com the Apps I require (Podcasts for example) are all there, but when I try to access My Apps on the Controller, the message says that "This player is already registered to another user".

If I look at Players on mysqueezebox.com, it is actually completely wrong, showing incorrect names for all my players. The controller, identified by it's MAC address, shows up as "Player" on there.

Something has got seriously out of whack and i would really appreciate a little help. I emailed support a week ago and have heard nothing. I searched the site here but couldn't find anyone with a similar experience.

So far I have tried reinstalling the Controller software and resetting it to factory settings, neither of which have worked.

Does anyone have any thoughts?


2009-11-07, 10:52
I would delete all the of the players on mysqueezebox.com and start over. Something has gotten bollixed up somehow.

You will need to connect to mysquezebox.com for every device you have. I'm assuming you have a Receiver since you have a Controller, and your Receiver should also show up there once you connect to mysqueezebox via the Controller.

I may be one of the lucky ones, but my Controller, Receiver, and five Squeezeplayers all show up. I have been able to rename them and enter certain settings for each device on mysqueezebox.com.

(Attached is a screenshot of *my* mysqueezebox.com)