PDA

View Full Version : Runaway LAME



wakey
2009-11-02, 19:06
I hope this is the right place for this...

I use Squeezebox Server to play my iTunes library from my Mac (Snow Leopard) to my Squeezebox Classic (it wasn't "classic" when I got it...) over a wireless network. I have LAME installed because I understand I need that to play my AAC tracks. But I've noticed recently in Activity Monitor that the 'lame' process can take up something like 50-60% of my CPU. Even if I'm not playing anything at the moment, even if the Squeezebox is turned off, 'lame' will still be there using up lots of cycles.

So I guess my question is twofold: do I still really need to use LAME? And is there a way to set the server software to quit LAME when it's not needing it anymore?

bpa
2009-11-03, 00:45
LAME is used to encode streams intoi MP3 usually because of player bandwidth issues.

You do not need LAME for AAC. AAC will be transcoded into Flac by default but if your network is not capable of supporting Flac traffic, it is usually suggested to enable bit rate limiting which requires LAME.

wakey
2009-11-03, 13:26
Yeah, that's why I installed it. I just wish I could make it let go of my system when it's not being used.

Thanks.

bpa
2009-11-03, 13:30
If you are playing a stream it will run as long as the a stream runs. If you are playing tracks - it will start with each track do a big burst of encoding and then stop when track is finished.

Are you sure it is not stopping when playing tracks - check the process id to see if it changes ?

Nonreality
2009-11-03, 21:06
If you have a good network you can turn off lame in the settings and force flac instead. It's under settings and audio under the players settings I think. You may have to look around. You can try that and see if that helps. I'm not up on macs so you'll have to use trial and error. Hope it helps. Also you could get a couple of itouches and run ipeng so that it was easy to see and control. It's a nice option for us with bad eyesight.

wakey
2009-11-05, 02:10
Yeah, I originally added LAME because I was getting dropouts and rebuffering in some songs, which was annoying. I didn't investigate very closely whether it was always AAC tracks rather than MP3s, but after installing LAME and playing with the settings a bit, it stopped stalling. First I'll pay closer attention to its behavior in the Activity Monitor, though like I said I noticed it running once when I wasn't playing anything at all, I don't think. And then maybe I'll try disabling it to see if I still need it.