PDA

View Full Version : Wake on LAN problem - urgently need help!



superbonham
2009-10-28, 15:00
Hi there,

I've got a Controller and two Receivers and have serious problems trying to wake my computer via WOL. First of all: the build in WOL feature never ever worked for me; but here is the full story:

That's how I would like to use my Squeezebox system:
1. Listen to some music from "My Music" (Squeezebox Server)
2. Switch Receiver to mysqueezebox.com (just to prevent the annoying blue light that shows up after step 3)
3. Let the server suspend after say 10 min. idle time
4. Pick up the Controller and wake up the server (choosing "My Music" again)
5. Go to step 1

So here's my first question: can this be done in the first place or does the Controller has to remain connected to SBS (even though the server will be suspended) to wake up the server and reconnect to SBS again?

Every time I pick up the Controller at step 4 I get an empty "My Music" menu entry.

That's my set-up:
- Intel-based music server running Win XP Pro SP2 (with integrated NIC that's perfectly WOL capable)
- FRITZ!Box Fon WLAN 7270 router
- music server connected via ethernet cable to router, static IP adress
- SqueezeboxServer (7.4.1 r28947)
- Controller (7.4.1 r7915)
- 2 Receivers (Firmware 65)
- Controller and both Receivers connected via WLAN/WIFI, dynamic IP adress (DHCP)

Waking the server using my iPhone and iPeng works like a charm in every situation; so WOL generally seems to work correctly. Everything also worked fine with Squeezecenter 7.3.3 and the WOL Squeezeplay applet by Thomas Houlberg (not with the Controller's built-in WOL feature, though), but I can't seem to get the WOL applet installed with Controller firmware 7.4.1.

I also tried the Server Power Control plugin by Gordon Harris, but when I try to wake up the server again, the whole SPC menu entry has vanished and only comes back _after_ I restarted SBS with iPeng and re-estabblished the Controller's connection.

Somehow the Controller seems to "forget" the SBS and IP address it has been connected to previously.

Is there anyone with the same kind of problems or even with a solution? Any hints would be greatly appreciated!

Thanks

superbonham

aubuti
2009-10-28, 15:10
I don't have any solutions for you, but can confirm from other threads and personal experience that (1) WOL on the SBC appears to be broken in the current firmware, (2) Thomas H's applet doesn't work with the current fw, and (3) SrvrPowerCtrl has not been updated to work with 7.4.x yet. It's really messy right now.

superbonham
2009-10-28, 15:17
aubuti,

thanks for your quick reply! At least I know now that I am not too stupid to get it working.

So let's hope that the next update will fix the WOL feature soon ...