PDA

View Full Version : Squeezecenter not starting - mysqld.exe error



rbijok
2009-10-19, 10:05
I run Squeezecenter on an HP 475 Windows Home Server (a version of Windows Server 2003) and use a Transporter on the network. I upgraded to 7.4 a few weeks ago. I have done a number of library rescans, and everything has been working well for weeks. Yesterday, however, Sqeezecenter stopped running. I tried a number of Squeezecenter restarts, reboots, and finally removed 7.4 and reinstalled 7.3.3. 7.3.3 worked for a while, but then same Squeezecenter shutdown. It tries to start, but never gets off the ground, and of course, web access shows the server inaccessible.

Upon reboot, I get a message asking to send error information to Microsoft. The message says "mysqld.exe has stopped". A search turned up this recommendation:

Go to menu Start and select Run.
Type the following command and press Ok: services.msc
Then right click on €œmysqld€ and select Properties.
In the tab Connection Check "Allow service to interact with desktop"
Click on Apply to confirm all configurations.

However, mysqld does not appear in the list of running services.

The odd thing is that Squeezecenter was working for weeks. I can't imagine what changed on the Home Server, unless it relates to recent Microsoft patches.

Any ideas or solutions?

gcurrie
2009-10-19, 13:00
However, mysqld does not appear in the list of running services.

The odd thing is that Squeezecenter was working for weeks. I can't imagine what changed on the Home Sewrver, unless it relates to recent Microsoft patches.

Any ideas or solutions?
It's called SqueezeMySQL in the list of services. Should be right underneath Squeezebox Server. Both should be Started and have Startup Type: Automatic.

Did you recently install Microsoft Security Essentials on there (the new Microsoft A/V package)? Apparently, that is known to have an issue with MySQL, for which there is no current workaround.

rbijok
2009-10-19, 21:36
I upgraded to 7.4.1 for WHS and still no success - SC runs for half a day and then stops and won't restart.

I set SqueezeMySQL to allow to interact with the desktop, and set it and Squeezebox Server to automatic. I can get the SqueezeMySQL service to start, but the Squeezebox Server service will still not start. Attempting to do so is unsuccessful and stops the SqueezeMySql service as well.

I did not deliberately install MS security essentials and do not have any other AV software running on the server. Just recent MS updates.

Phil Leigh
2009-10-19, 23:50
I upgraded to 7.4.1 for WHS and still no success - SC runs for half a day and then stops and won't restart.

I set SqueezeMySQL to allow to interact with the desktop, and set it and Squeezebox Server to automatic. I can get the SqueezeMySQL service to start, but the Squeezebox Server service will still not start. Attempting to do so is unsuccessful and stops the SqueezeMySql service as well.

I did not deliberately install MS security essentials and do not have any other AV software running on the server. Just recent MS updates.

You dont want "interact with the desktop"

rbijok
2009-10-20, 07:15
I set SqueezeMySql to interact with desktop on internet advice (see my original post.) Regardless, whether set to interact with desktop or not, SBS refuses to start.

Phil Leigh
2009-10-20, 07:40
I set SqueezeMySql to interact with desktop on internet advice (see my original post. regardless, whether st to interact with desktop or not, SBS refuses to start.

It does not need to interact with the desktop!!!
The reason it is not starting is not that.
Something should be written to server.log...

rbijok
2009-10-20, 11:03
I have attached the server log. As far as I can tell, all it says is "MySql not working" near the end. Perhaps someone who knows the SBS startup process can tell me more.

rbijok
2009-10-20, 11:34
Here is database error log file as well.

rbijok
2009-10-21, 07:15
Have contacted Slim devices support. Will report if they come up with anything.

Phil Leigh
2009-10-21, 08:26
Have you tried cleaning the cache and doing a full rescan?

rbijok
2009-10-21, 21:30
It worked!!!

Open Squeezebox Server Control Panel, by double clicking the tray icon.
Open the "advanced" tab
Highlight "Clean cache folder..."
Select Run Cleanup.

Thanks for your help!