PDA

View Full Version : Sluggish Interface



DiSNEYN
2009-10-18, 23:18
Only me that thinks that the new color Interface/Menu is very very sluggish compared to the old monocrome/VFD menus?

I Hope that this only is a minor setback in early firmware and that you will be able to fine-tune this to get a "fluid feeling" in the new color interface system.

I want FLUID moving menus. Not jumpy/choppy movement.

Any developers that have something to say about this? When changing to the color system i hope that you had this in mind? Or isn't the new screen able to show fluid movement?

Please respond.

/Hans, Sweden.

Owner of SliMP3, Squeezebox Classic, Squeezebox Boom, Squeezebox Radio

Sike
2009-10-19, 01:21
Got mine on Saturday.

I second DiSNEYNs' opinion.

unclemat
2009-10-19, 06:13
Oh, yeah, very slow. Sometimes there is like 1 sec or long lag before the screen reacts to inputs.

Between crappy interface and bugs I decided to send my back.

ern
2009-10-19, 06:18
Mine works fine... Everything is smooth sailin.. Maybe its ur network? Try connecting with ethernet and see if its still choppy?

DiSNEYN
2009-10-19, 06:20
Mine works fine... Everything is smooth sailin.. Maybe its ur network? Try connecting with ethernet and see if its still choppy?

i will try that, thanks.

/H

toby10
2009-10-19, 08:27
Mine seems quite snappy using WiFi. Probably a bit slower screen changes than my SB3, but not by much and it doesn't seem sluggish to me.
Might just be the way the new players operate, dunno.

gweempose
2009-10-19, 09:27
Overall, the menus seem relatively responsive to me. There is definitely some sluggishness when you do certain things, though. For example, there is often a delay when you hit the power button.

bobpenn
2009-10-19, 10:17
Speed seems fine to me on wifi. I think the color screen is much better in many ways than the Boom display. If there's a lag or it's slower, it not noticeable to me.

aubuti
2009-10-19, 14:24
Only me that thinks that the new color Interface/Menu is very very sluggish compared to the old monocrome/VFD menus?

I Hope that this only is a minor setback in early firmware and that you will be able to fine-tune this to get a "fluid feeling" in the new color interface system.

I want FLUID moving menus. Not jumpy/choppy movement.
Mine seems fluid at present, although I also see the short delay when pressing the power/standby button. Does it seem to happen with some commands/menus in particular (eg, those showing album art, or those where a long artist list is being generated), or is it all of them?

How are you navigating the menus, with the knob or with an IR remote from one of your other SBs? I don't know why it would make a difference, but thought it would be a good idea to make sure we are talking about the same thing. I use the knob exclusively -- the screen is so small that I have to get up close anyway.

Philip Meyer
2009-10-19, 17:17
I believe a recent firmware update removed some debug code that was slowing the interface down. Mine feels quite responsive now.

Matt Wise
2009-10-19, 18:50
The LUA SqueezePlay UI work right now is focusing (obviously) on fixing major bugs... but trust me that performance is always something we're paying attention to. As Phillip mentioned, a recent update before the release (r7790) removed some debug code that lead to a huge improvement in the UI responsiveness and fluidity.

I would recommend two things...
a) its possible that a known memory leak in the Now Playing screen has lead to your slow UI feel... does it go away when you reboot the unit? If so, when 7.4.1 is released (very very soon), it should solve the issue.

b) if the issue is present for you on a fresh-bootup, I'd recommend taking a small movie of the issues your seeing (most modern digital cameras can do this for you), and opening a bug @ http://bugs.slimdevices.com with the movie attached. Try to keep the movie small please.

If the issue is a new one... expect it may take a little while in the priority list to get to it, but rest assured that as we continue to develop SqueezePlay-based products the performance, reliability and "general wow-factor" will only continue to improve.

DiSNEYN
2009-10-19, 22:03
I believe a recent firmware update removed some debug code that was slowing the interface down. Mine feels quite responsive now.

This is just the problem that you state above.. "Mine feels QUITE responsive" I want FLUID menus, with FLUID scrolling. A product from Squeezebox shouldnt just be "This is the way the new color screen works (a little bitt choppy)" I will make a movie compareing Classic/Boom with Radio.

I also noticed that Radio has less settings for scrolling/interface. Why?

Atbi: I can't see much diffrens when i use knob or remote.

/Hans

DiSNEYN
2009-10-19, 22:22
The LUA SqueezePlay UI work right now is focusing (obviously) on fixing major bugs... but trust me that performance is always something we're paying attention to. As Phillip mentioned, a recent update before the release (r7790) removed some debug code that lead to a huge improvement in the UI responsiveness and fluidity.

I would recommend two things...
a) its possible that a known memory leak in the Now Playing screen has lead to your slow UI feel... does it go away when you reboot the unit? If so, when 7.4.1 is released (very very soon), it should solve the issue.

b) if the issue is present for you on a fresh-bootup, I'd recommend taking a small movie of the issues your seeing (most modern digital cameras can do this for you), and opening a bug @ http://bugs.slimdevices.com with the movie attached. Try to keep the movie small please.

If the issue is a new one... expect it may take a little while in the priority list to get to it, but rest assured that as we continue to develop SqueezePlay-based products the performance, reliability and "general wow-factor" will only continue to improve.

a) No the choppyness stays whenever i reboot the unit or not. Just compare scrolling from a menu to another with Classic/Boom.

Yes, it's gotten a little bit better with the new 7.5 beta but again. I want FLUID movment with no choppyness.

b) I will fix a small movie to show the diffrent (i know, some of you maybe dont think this is a issue, but i always have had products from Slimdevices that is top-of-the-line and i'm counting on the staff to fix this minor issue) I understand that right now maybe there are more importment bugs to fix, but it's good to know that you are working for that "Wow-feealing" to come back to this unit, so it will be as good as the other products?

Movie about the scrolling problem:
http://www.youtube.com/watch?v=cHj1PoaznGA

Bug filed!
https://bugs.slimdevices.com/show_bug.cgi?id=14852

Thanks for listing to your users!

/Hans