PDA

View Full Version : Moodlogic crashes



Francesco Depasquale
2004-07-08, 14:55
I need help guys.

I upgraded my server to 5.2.1 and have moodlogic installed, version 2.7

When I try to run moodlogic on my squeezebox and/or on the softsqueeze, I reach the stage of chosing the mood and, after that, the set tells me "Problem lost contact with Slim Server. Check if software is running".

I then chose to debug it to see what message it gives me and it gave me the following statement " Undefined subroutine &Slim::Buttons::InstantMix::specialPushLeft called at /PerlApp/Slim/Buttons/MoodWheel.pm line 59."

I am not that computer literate where it comes to pearl etc, even though I do try to understand how things work.

On the other hand, I am ecstatic about the squeeze box - such a great idea, unheard of where I live (Malta GC)

Please can someone tell me what is wrong and how I can solve the matter.

thanks a lot for everything and keepuo the good work ... its great!!

cesco

kdf
2004-07-08, 15:14
Quoting Francesco Depasquale <cesco (AT) keyworld (DOT) net>:

> I need help guys.
>
> I upgraded my server to 5.2.1 and have moodlogic installed, version 2.7
>
> When I try to run moodlogic on my squeezebox and/or on the softsqueeze, I
> reach the stage of chosing the mood and, after that, the set tells me
> "Problem lost contact with Slim Server. Check if software is running".

This is a known bug and is fixed in the nightly builds:
http://www.slimdevices.com/downloads/nightly/latest.

-kdf

Francesco Depasquale
2004-07-12, 14:01
Sorry to bother you again.

Did what you said and installed Slimserver 5.3

When I run moodlogic, I can select the mood etc however, once it mixes, the
player then indicates that it has 1 of 0 to play.

The debug reads as follows

Use of uninitialized value in concatenation (.) or string at
/PerlApp/Slim/Music/MoodLogic.pm line 412.

what can I do.

thanks

cesco
----- Original Message -----
From: "kdf" <slim-mail (AT) deane-freeman (DOT) com>
To: "Slim Devices Discussion" <discuss (AT) lists (DOT) slimdevices.com>
Sent: Friday, July 09, 2004 12:14 AM
Subject: [slim] Moodlogic crashes


> Quoting Francesco Depasquale <cesco (AT) keyworld (DOT) net>:
>
> > I need help guys.
> >
> > I upgraded my server to 5.2.1 and have moodlogic installed, version
2.7
> >
> > When I try to run moodlogic on my squeezebox and/or on the
softsqueeze, I
> > reach the stage of chosing the mood and, after that, the set tells me
> > "Problem lost contact with Slim Server. Check if software is running".
>
> This is a known bug and is fixed in the nightly builds:
> http://www.slimdevices.com/downloads/nightly/latest.
>
> -kdf
>

kdf
2004-07-12, 14:13
what artist/genre and what mood are you trying to select?
-kdf

Quoting Francesco Depasquale <cesco (AT) keyworld (DOT) net>:

> Sorry to bother you again.
>
> Did what you said and installed Slimserver 5.3
>
> When I run moodlogic, I can select the mood etc however, once it mixes, the
> player then indicates that it has 1 of 0 to play.
>
> The debug reads as follows
>
> Use of uninitialized value in concatenation (.) or string at
> /PerlApp/Slim/Music/MoodLogic.pm line 412.
>
> what can I do.
>
> thanks
>
> cesco
> ----- Original Message -----
> From: "kdf" <slim-mail (AT) deane-freeman (DOT) com>
> To: "Slim Devices Discussion" <discuss (AT) lists (DOT) slimdevices.com>
> Sent: Friday, July 09, 2004 12:14 AM
> Subject: [slim] Moodlogic crashes
>
>
> > Quoting Francesco Depasquale <cesco (AT) keyworld (DOT) net>:
> >
> > > I need help guys.
> > >
> > > I upgraded my server to 5.2.1 and have moodlogic installed, version
> 2.7
> > >
> > > When I try to run moodlogic on my squeezebox and/or on the
> softsqueeze, I
> > > reach the stage of chosing the mood and, after that, the set tells me
> > > "Problem lost contact with Slim Server. Check if software is running".
> >
> > This is a known bug and is fixed in the nightly builds:
> > http://www.slimdevices.com/downloads/nightly/latest.
> >
> > -kdf
> >

Francesco Depasquale
2004-07-12, 15:06
The problem appears to be happening with all

incidentally, I did carry out the update that Greg Hamilton mentionde to.

so it could be that.

will check out tomorrow

thanks

cesco
----- Original Message -----
From: "kdf" <slim-mail (AT) deane-freeman (DOT) com>
To: "Slim Devices Discussion" <discuss (AT) lists (DOT) slimdevices.com>
Sent: Monday, July 12, 2004 11:13 PM
Subject: [slim] Moodlogic crashes


> what artist/genre and what mood are you trying to select?
> -kdf
>
> Quoting Francesco Depasquale <cesco (AT) keyworld (DOT) net>:
>
> > Sorry to bother you again.
> >
> > Did what you said and installed Slimserver 5.3
> >
> > When I run moodlogic, I can select the mood etc however, once it mixes,
the
> > player then indicates that it has 1 of 0 to play.
> >
> > The debug reads as follows
> >
> > Use of uninitialized value in concatenation (.) or string at
> > /PerlApp/Slim/Music/MoodLogic.pm line 412.
> >
> > what can I do.
> >
> > thanks
> >
> > cesco
> > ----- Original Message -----
> > From: "kdf" <slim-mail (AT) deane-freeman (DOT) com>
> > To: "Slim Devices Discussion" <discuss (AT) lists (DOT) slimdevices.com>
> > Sent: Friday, July 09, 2004 12:14 AM
> > Subject: [slim] Moodlogic crashes
> >
> >
> > > Quoting Francesco Depasquale <cesco (AT) keyworld (DOT) net>:
> > >
> > > > I need help guys.
> > > >
> > > > I upgraded my server to 5.2.1 and have moodlogic installed,
version
> > 2.7
> > > >
> > > > When I try to run moodlogic on my squeezebox and/or on the
> > softsqueeze, I
> > > > reach the stage of chosing the mood and, after that, the set tells
me
> > > > "Problem lost contact with Slim Server. Check if software is
running".
> > >
> > > This is a known bug and is fixed in the nightly builds:
> > > http://www.slimdevices.com/downloads/nightly/latest.
> > >
> > > -kdf
> > >