PDA

View Full Version : Excessive buffering and tracks that wont play



RussT
2009-10-12, 09:35
I have a good set-up I think :-). I run a Squeezebox Boom and a Duet connected to my amplifier. I also have a QNAP Network Attached Storage device which has Squeezecentre installed and all my music on it. The music is stored in an iTunes Music folder. I back-up/copy my desktop iTunes folders once a week to the NAS. I have noticed a couple of problems however and was wondering if anyone has any pointers.

1) Some of the music does not play. Initially I thought it was DRM related as it seemed to be only albums I had purchased via iTunes but I have noticed it with other albums as well which I have ripped from CD's I own?

2) When playing the radio it interupts and buffers quite regularly. I have checked the network settings on the Wiki against my ISP's Netgear router and they seem fine but it still does it?

I would appreciate anyone cleverer than me offer a few words of advice :-)

Phil Leigh
2009-10-12, 09:40
I have a good set-up I think :-). I run a Squeezebox Boom and a Duet connected to my amplifier. I also have a QNAP Network Attached Storage device which has Squeezecentre installed and all my music on it. The music is stored in an iTunes Music folder. I back-up/copy my desktop iTunes folders once a week to the NAS. I have noticed a couple of problems however and was wondering if anyone has any pointers.

1) Some of the music does not play. Initially I thought it was DRM related as it seemed to be only albums I had purchased via iTunes but I have noticed it with other albums as well which I have ripped from CD's I own?

2) When playing the radio it interupts and buffers quite regularly. I have checked the network settings on the Wiki against my ISP's Netgear router and they seem fine but it still does it?

I would appreciate anyone cleverer than me offer a few words of advice :-)

What software did you use to rip?

RussT
2009-10-12, 09:48
iTunes

Phil Leigh
2009-10-12, 09:50
so can you see any correlation between files which will/won't play?
What exactly happens when you try and play one?

RussT
2009-10-12, 10:43
I thought the the files which wouldnt play were only the ones I had purchased and downloaded from iTunes but now its both them and ones which I ripped via Itunes but others which were ripped via iTunes play so there does not seem to be any ryhme or reason. When I try to play one it comes up on the controller or iPeng on my iPhone and then just wont respond to the play normally when you select a track or album it automatically starts playing...


Also the internet radio keeps buffering... and cutting out and I dont know why?

Thanks for your help

Phil Leigh
2009-10-12, 10:50
I thought the the files which wouldnt play were only the ones I had purchased and downloaded from iTunes but now its both them and ones which I ripped via Itunes but others which were ripped via iTunes play so there does not seem to be any ryhme or reason. When I try to play one it comes up on the controller or iPeng on my iPhone and then just wont respond to the play normally when you select a track or album it automatically starts playing...


Also the internet radio keeps buffering... and cutting out and I dont know why?

Thanks for your help
what format are your files? - m4a?
I presume all of your files are in one place?

You may need to turn on some logging and have a look at server.log

RussT
2009-10-12, 11:12
a mixture of M4a and MP3, yes all the files are in an Itunes Music folder on my NAS copied from my Itunes folder on my PC

Phil Leigh
2009-10-12, 11:15
a mixture of M4a and MP3, yes all the files are in an Itunes Music folder on my NAS copied from my Itunes folder on my PC

Well I guess that rules out the obvious problems... time to take a look in server.log

Matt Wise
2009-10-12, 11:30
a mixture of M4a and MP3, yes all the files are in an Itunes Music folder on my NAS copied from my Itunes folder on my PC

what kind of wireless access point?

RussT
2009-10-13, 01:19
Phil, How do I look at the server logs?

Matt, I run a Netgear DG834GT which is supplied by my service provider

Phil Leigh
2009-10-13, 01:29
Phil, How do I look at the server logs?

Matt, I run a Netgear DG834GT which is supplied by my service provider

Russ - you need the help of a Qnap/Linux expert here (not me!)

pski
2009-10-13, 20:16
iTunes

Did you select "use error correction?"

If not, you will need to re-rip.

P

RussT
2009-10-17, 03:45
I re-ripped a cd that was not playing with error correction and it still did not play?