PDA

View Full Version : Can IR receiver be disabled?



unclemat
2009-10-11, 19:34
So I am playing with the Radio in a room where I have a Classic. If I use the remote usually both devices respond. Is there a way to disable IR receiver on a player?

Radio in particular. One of its uses might be on my bed nightstand and I have a SB2 in my bedroom as well. When I use the remote to control the SB2 I don't want the Radio to come up.

unclemat
2009-10-11, 20:06
Well, I found Remote settings panel for the Boom, but there isn't one for Radio :(

aubuti
2009-10-11, 20:32
Ooh, very good catch. I just filed a bug for it: https://bugs.slimdevices.com/show_bug.cgi?id=14718

It's a problem with the SB Touch, too.

gdpeck
2009-12-15, 07:52
So I am playing with the Radio in a room where I have a Classic. If I use the remote usually both devices respond. Is there a way to disable IR receiver on a player?

Radio in particular. One of its uses might be on my bed nightstand and I have a SB2 in my bedroom as well. When I use the remote to control the SB2 I don't want the Radio to come up.

I just discovered a way to do this, thanks to some help from another forum member. What I did is SSH into the Radio and rename /usr/share/jive/jive/irMap_default.lua to /usr/share/jive/jive/irMap_default.lua.old. Then re-start the Radio, and the remote won't work. Perfect for what I need, and easily reversible, by renaming the file back, or worst case by reset to factory defaults.

Here's a step-by-step way to do this using MacOS X Terminal:
ssh -l root "IP Address of Player" <Return>
root password (default is 1234) <Return>
mv /usr/share/jive/jive/irMap_default.lua /usr/share/jive/jive/irMap_default.lua.old <Return> to rename the file.
ls /usr/share/jive/jive <Return> to verify that the irMap_default.lua.old is in the folder and that you didn't make any typos.
reboot <Return>

Quit Terminal application.

YMMV (but not much) depending on which terminal software you use

BTW, this doesn't disable iPeng or other network based remote control functionality, just IR.

Thanks!
George

Soulkeeper
2010-07-07, 05:51
Thanks for the guide. (The relevant bug is now bug 14718 (http://bugs.slimdevices.com/show_bug.cgi?id=14718) if anybody wants to go vote.)

A little bit more detailed Instructions (primarily aimed at Windows users):

Enable SSH login on the Radio, using the interface on the Radio:
Settings -> Advanced -> Remote Login -> Enable SSH

Find the Radio's IP address. Either in
Squeezebox Server -> Settings -> Information
or in the Radio user interface
Settings -> Advanced -> Diagnostics

Using PuTTY (http://www.putty.org/), connect to the Radio's IP address (use the default settings in PuTTY). Login with username root and password 1234.

After that, run the commands provided by gdpeck:


mv /usr/share/jive/jive/irMap_default.lua / /usr/share/jive/jive/irMap_default.lua.old <Return> to rename the file.

ls /usr/share/jive/jive <Return> to verify that the irMap_default.lua.old is in the folder and that you didn't make any typos.

reboot <Return>

Quit PuTTY, and you're done.

peterw
2010-07-07, 06:40
...
Quit PuTTY, and you're done.

I would disable remote access, too.

Philip Meyer
2010-07-07, 06:46
There's an easier way: use Erland's Patch manager addon.

This provides a mechanism for applying patches on the Squeezeplay player. There is a patch to disable IR remote.

The benefit is that these patches can be automatically applied after firmware updates, and you can enable/disable the patches at any time (so if you want to use IR Remote one day, you can re-enable it at the player by unticking the patch in the addon).

Soulkeeper
2010-07-08, 02:23
I've edited this info into a wiki article, which I hope you can help me to improve:

http://wiki.slimdevices.com/index.php/Disable_IR_remote_reception

copperstate
2010-07-08, 03:19
I've edited this info into a wiki article, which I hope you can help me to improve:

http://wiki.slimdevices.com/index.php/Disable_IR_remote_reception

The SB3 works the same way the Boom does (as should all ip3k-based devices). :)

Soulkeeper
2010-07-08, 04:08
Thanks, I've updated the article.

unclemat
2010-08-17, 20:17
Thanks for posting the hack. I re-bought Radio after sending back last fall (when it was flat out unreliable mess). It works reasonably now, but I am still shocked they haven't brought back this feature yet. Without it makes Radio unusable with any other Squeezebox in shared space. It makes sense to disable the remote on the Radio being it's more portable kind.

Soulkeeper
2010-08-18, 04:01
I suppose you've noticed that there's now step by step instructions for enabling it via Erland's Patch Installer. Did these work fine for you?

Myself, I'm contemplating switching the IR receptor on again on my Radio. It shares the bedroom with a Boom; they're on each side of the double bed. If I point the RC straigt up at the roof, both units receive the signal. If I point it at one of the units, the other unit doesn't react. Enabling IR on both units will enable me to activate snooze on the Radio alarm when the madam refuses to hear it and I want 10 extra minutes of sleep.

But maybe it only works this way because the RC is low on battery, IDK. I got it with my second hand Boom.

Philip Meyer
2010-08-18, 15:50
>But maybe it only works this way because the RC is low on battery, IDK.
>I got it with my second hand Boom.
>
Quite possibly.

I have a Touch and Boom in opposite corners in a medium sized room (Touch acting as a controller for the Boom). I found that no matter where I pointed an IR Remote within the room, the signal was received by both players. I had to disable one player from interpretting IR Remote commands, otherwise control was impossible.

As the Touch is on a desk, within arms reach, there was no need for IR Remote control, so I disabled this. I too am suprised there is no built-in option to control IR Remote useage, like Classic player settings, seeing that it was simple to patch.

Phil