PDA

View Full Version : Setting the alarm for 06xx



dsf
2009-10-08, 11:35
So, I've just fired up my new Radio and am already in love with it (but I knew I would). Got it online, apps installed, facebook on the go, tested the sound quality, etc etc, all great. After all that I thought, OK, time to set the alarm.

I can't pick a time in 06xx.

Seriously. When I scroll through the hours, as slow as I possibly can, I can choose any value for the hour except 6. I know I can go set the alarm on mysqueezebox.com and so on, but still! Has anyone else seen this?

ccrome2
2009-10-08, 11:41
Woah! I see it too, except I can't set it for 05xx. You're in 24 hour mode, correct?

dsf
2009-10-08, 11:47
Woah! I see it too, except I can't set it for 05xx. You're in 24 hour mode, correct?

Yep. And I really need to get up between 6am and 7am in the morning :)

EDITED TO ADD: I just changed to 12 hour mode, scrolled through the hours and could access them all. Switched back to 24 hour mode and now I can pick 6 but not 5.

ccrome2
2009-10-08, 12:04
Bug filed.

https://bugs.slimdevices.com/show_bug.cgi?id=14675

lrossouw
2009-10-08, 18:36
Looks like the radio is not an early riser! :D

ccrome2
2009-10-08, 22:29
We'll get this one fixed quickly. If you can stand it, please switch to AM/PM time to ensure that fixes your problem.

unclemat
2009-10-08, 22:32
I see this bug, too. Being a programmer I need to admit this bug is quite intriguing :lol:

dsf
2009-10-09, 01:49
I see this bug, too. Being a programmer I need to admit this bug is quite intriguing :lol:

Ditto :) I had a look at all the lua and Perl but couldn't quite figure out what populates the list of hours and makes them (un)choosable.

OppfinnarJocke
2009-10-10, 02:31
For me, 24-hour clock, when doing Add Alarm, I cannot set time to 06.
Trying to Set Time for an existing alarm, I cannot Set Time to 05.

Done some testing, the time that's skipped depends on what the time was set at.
Do the following:
1a. Add Alarm, the default time is 07, time cannot be set to 06
1b. set the time to 21:00
2. Now choose that alarm and go to Set Time, time cannot be set to 20:00.
3. Set Time to 19:00
4. Now choose that alarm and go to Set Time, time cannot be set to 18:00
5. and so on...

Some index is off by one somewhere, I guess.

PS And shouldn't someone have tested this before release?

bklaas
2009-10-12, 14:51
FYI, this has been fixed in r7847, and it will be included in the 7.4.1 release (likely before the end of October). 12h formatted time works to set the alarm until then as a workaround.

It amounted to a one line fix, but not in a particularly obvious place.

cheers,
#!/ben

farrow
2009-10-14, 07:25
Just got my radio today and noticed this bug straight away but did find another way around it, which is to set the alarm from the mysqueezebox website that works perfectly for the time being.

Cheers

Farrow

0xdeadbeef
2009-10-14, 09:43
Which only allows a 12h scheme anyway...

samstreak
2009-10-14, 14:22
I hate to just jump in here... but if its only the previous hour of the current set that's unavailable... how about setting for 0800 then you should be able to select 06 as the hour (then 0700 would be unavailable). I see that its already fixed in the r7847, but until it comes out, this should work (if you hadn't thought of it already)