PDA

View Full Version : 7.4 - Save me from this nightmare!!



sam.woodley
2009-10-04, 14:34
My Squeezebox Duet and Squeezebox Boom have just been reduced to very expensive paper weights. Well, at least the Squeezebox Boom is also a very expensive clock radio.

So, on Wednesday I received Logitech's email announcement about the upgrade to Squeezebox Server 7.4. Excited, I downloaded and installed the update that night. I had been running SqueezeCenter 7.3.x on a ReadyNAS hard drive. My iTunes music library is also saved on that drive, which is what SqueezeCenter used as the source of my music. Everything had been working well.

After installing the upgrade, I found that it had erased all my settings. I had to set up my favorites, podcasts, alarms etc. from scratch. But I eventually got it to work. Then I tried to use the iTunes plug-in to scan my library. Disaster. Scanning this forum, I quickly learned that the new SqueezeServer was not compatible with the iTunes plug-in. No problem. I disabled it, restarted the server, rescanned my entire library, and then . . . . nothing. The software would not play any of my music (m4a files). I rebooted the hard drive and rescanned my entire library again. Same result. I have wasted my entire weekend troubleshooting this problem, to no avail. The players will not lay any of the music in my library. I note, however, that I can stream radio stations and podcasts just fine.

I just got on this forum again, to trouble shoot, and saw posts mentioning version 7.4.1 of the upgrade. Great, I thought, maybe this fixes the problem. So I went to download the 7.4.1 versions. To my horror I saw an announcement: "Squeezebox Server 7.4 is not currently available for ReadyNAS"

So, now I find that I have a version of the server software that is incompatible with my hard drive. And, I have no way to go back and instal the previous version that works.

I am at my wits end. Before this upgrade, I enthusiastically recommended these products to everyone. Now, I want desperately to return them, get my money back and buy a Sonos! Any constructive suggestions would be appreciated!!

mzpro5
2009-10-04, 14:44
Can't you just downgrade to 7.3.3?

http://downloads.slimdevices.com/

pablolie
2009-10-04, 17:35
Yikes.

Sometimes a clean reinstall is your friend. You still have your settings saved?

Good luck! Yeah, it's been a rough little update. On my side things seem to be settling now.

Matt Wise
2009-10-04, 18:45
My Squeezebox Duet and Squeezebox Boom have just been reduced to very expensive paper weights. Well, at least the Squeezebox Boom is also a very expensive clock radio.

So, on Wednesday I received Logitech's email announcement about the upgrade to Squeezebox Server 7.4. Excited, I downloaded and installed the update that night. I had been running SqueezeCenter 7.3.x on a ReadyNAS hard drive. My iTunes music library is also saved on that drive, which is what SqueezeCenter used as the source of my music. Everything had been working well.

After installing the upgrade, I found that it had erased all my settings. I had to set up my favorites, podcasts, alarms etc. from scratch. But I eventually got it to work. Then I tried to use the iTunes plug-in to scan my library. Disaster. Scanning this forum, I quickly learned that the new SqueezeServer was not compatible with the iTunes plug-in. No problem. I disabled it, restarted the server, rescanned my entire library, and then . . . . nothing. The software would not play any of my music (m4a files). I rebooted the hard drive and rescanned my entire library again. Same result. I have wasted my entire weekend troubleshooting this problem, to no avail. The players will not lay any of the music in my library. I note, however, that I can stream radio stations and podcasts just fine.

I just got on this forum again, to trouble shoot, and saw posts mentioning version 7.4.1 of the upgrade. Great, I thought, maybe this fixes the problem. So I went to download the 7.4.1 versions. To my horror I saw an announcement: "Squeezebox Server 7.4 is not currently available for ReadyNAS"

So, now I find that I have a version of the server software that is incompatible with my hard drive. And, I have no way to go back and instal the previous version that works.

I am at my wits end. Before this upgrade, I enthusiastically recommended these products to everyone. Now, I want desperately to return them, get my money back and buy a Sonos! Any constructive suggestions would be appreciated!!

Two things...

1) Please contact Support via phone... they sit around all day wanting nothing more than to help you solve your issues! Use them!

2) Your original post could really use some detailed info to clear things up... it sounds like your running SbS on ReadyNAS -- can you confirm that? Can you give us details about which ReadyNAS you have, which version of SC you were running before, and the exact steps you took to get to where you are now?

There is a known bug (https://bugs.slimdevices.com/show_bug.cgi?id=14451) dealing with what I am guessing is your issue. The good news is that there's a large group of people working on solving this. The bad news, its not yet solved. Its close, but not there yet.

(on a side note... I sincerely hope we NEVER change our software name again. its a huge pita that causes unbelievable problems!)

sam.woodley
2009-10-04, 20:09
Two things...

1) Please contact Support via phone... they sit around all day wanting nothing more than to help you solve your issues! Use them!

2) Your original post could really use some detailed info to clear things up... it sounds like your running SbS on ReadyNAS -- can you confirm that? Can you give us details about which ReadyNAS you have, which version of SC you were running before, and the exact steps you took to get to where you are now?

There is a known bug (https://bugs.slimdevices.com/show_bug.cgi?id=14451) dealing with what I am guessing is your issue. The good news is that there's a large group of people working on solving this. The bad news, its not yet solved. Its close, but not there yet.

(on a side note... I sincerely hope we NEVER change our software name again. its a huge pita that causes unbelievable problems!)

Yes, I have running SqueezeCenter (now Squeezebox Server) on a ReadyNAS Duo with the latest firmware (RAIDiator 4.1.6) installed. I did do a clean install of 7.4.0. It seemed to work fine at first. Then I tried enabling iTunes support and quickly ran into problems playing my music. I soon saw, reading posts on this forum, that the iTunes integration does not work in 7.4, so I disabled it. But then, even after another clean reinstall, I still could not play music in my library.

I did call technical support, and they have been very attentive. The person I spoke to acknowledged that there is a new 7.4.1 build for the ReadyNAS, and sent it to me. I did another clean reinstall, but still had the same problem. Of course, it was a few hours before I knew this, since each time I must rescan my music library (takes about 2.5 hours). By the time I called logitech again, the person who helped me (apparently the only person on call today who is familiar with ReadyNAS) had left for the evening. Someone knowledgeable about ReadyNAS will be on available tomorrow, and a note has been left for them to call me.

I'll be at work all day tomorrow. So I won't be able to follow through on any new advice they give me. I do not get home until 10:00 PM most week nights. Next weekend, I will be traveling for business. So I will not be able to troubleshoot this problem again for at least another two weeks. I have already wasted my first weekend off in six weeks dealing with this problem. So I am not interested in dealing with it any more -- at least, not until I know these problems have been fixed.

In the meantime, I have used mzpro5's link ,and done a clean reinstall of 7.3.4. It seems to be working normally again -- i.e., I can play music in my library. That will do for now. I feel like I am moving backwards. But, seeing that 7.4 for the ReadyNAS is no longer available from Logitech's website, it is clear that the update was released prematurely.

jposner
2009-10-05, 14:36
I also had a mare upgrading readynas from 7.3 to 7.4. see the thread here: http://forums.slimdevices.com/showthread.php?t=68406&highlight=7.4+readynas

look at the log file (server.log) - are you also getting the message "There is already another copy of the Squeezebox Server running on this machine" ??
Any other errors? I had a whole load, including spurious plugin problems.

Ended up uninstalling the whole 7.3 server, then installing the new one. Shame we have to lose all our settings, trackstat, etc every time we upgrade....what a pain

nightly builds here: http://downloads.slimdevices.com/nightly/?ver=7.4
- the 7.4.1 builds fix a number of bugs in the 7.4 release. Suggest you take one of these ?