PDA

View Full Version : Bitrate Limiting



David Frampton
2004-06-30, 14:05
Hi can anyone tell me how to check that the Bitrate limiting feature is working correctly. I am running slimsever 5.2.0 on windows 2003 server and have installed the lame.exe to the \bin directory and the software reports that lame is found and installed correctly. However when I stream to the media player on a different PC it still reports the stream is 320 kbs even though I have changed the bitrate down to 64kbs. I have started and stopped the server. All my songs are stored as MP3 at 192kbs and would like to listen to them at work but need to limit the bandwidth down to 64kbs.

Any advice on how to do this succesfully would be much appreciated.

Kind regards

David

kdf
2004-06-30, 14:33
A stream will send 320kbps silence after connecting, and while a song isn't
playing. Once you start a song, it should fall down to the limiting rate.
Also, the web UI should be showing the converted rate in the status pane.

you can also look at the d_source debug output. server settings->additional
server settings->debuggins, check d_source and click change. then view the log
at http://serverIP:9000/log.txt

-kdf


Quoting David Frampton <david (AT) frampton (DOT) biz>:

> Hi can anyone tell me how to check that the Bitrate limiting feature is
> working correctly. I am running slimsever 5.2.0 on windows 2003 server and
> have installed the lame.exe to the \bin directory and the software reports
> that lame is found and installed correctly. However when I stream to the
> media player on a different PC it still reports the stream is 320 kbs even
> though I have changed the bitrate down to 64kbs. I have started and stopped
> the server. All my songs are stored as MP3 at 192kbs and would like to listen
> to them at work but need to limit the bandwidth down to 64kbs.
>
> Any advice on how to do this succesfully would be much appreciated.
>
> Kind regards
>
> David
>