PDA

View Full Version : Fishbone Info-link error



Peter Olufsen
2004-06-28, 12:01
Ok, i cheked some more. I think the problem is in the tag. I use The
Godfather (http://users.otenet.gr/~jtcliper/tgf/) to tag my files, and if I
use them in SlimServer it breaks the server when I try to display song info.
If I let iTunes or Winamp rewrite the tag everything seems ok in SlimServer.

I've attached a small test-file that should reproduce the problem. If you
display info for that the server breaks with the error "Wide character in
syswrite at /PerlApp/Slim/Web/HTTP.pm line 897." I hope it can be used to
track this problem.

btw: As I had this problem with server breakdown I made a very simple
solution to keep SlimServer running after an error. I made this
batch/cmd-file:
----------
echo off
:retry
echo SlimServer...
slim.exe --logfile d:\slim\log.txt
goto retry
----------
That way the server will just load again after breaking down :-)

Peter
> ----- Original Message -----
> From: "kdf" <slim-mail (AT) deane-freeman (DOT) com>
> To: "Slim Devices Discussion" <discuss (AT) lists (DOT) slimdevices.com>
> Sent: Wednesday, June 23, 2004 9:11 PM
> Subject: [slim] Fishbone Info-link error
>
>
> > the only info I can find on this kind of error suggests some problem
with
> UTF-8
> > encoding. Is this crash repeatable with certain songs? If you select
> info for
> > a song that cuase the crash, instead of 1-5 at random, does it crash on
> the same
> > song every time?
> >
> > -kdf
> >
> > Quoting Peter Olufsen <po (AT) dsinet (DOT) dk>:
> >
> > > >From the eventlog (Error):
> > >
> > > Wide character in syswrite at /PerlApp/Slim/Web/HTTP.pm line 897.
> > >
> > > Do you want more info ?
> > >
> > > Peter
> > > ----- Original Message -----
> > > From: "kdf" <slim-mail (AT) deane-freeman (DOT) com>
> > > To: "Slim Devices Discussion" <discuss (AT) lists (DOT) slimdevices.com>
> > > Sent: Wednesday, June 23, 2004 12:59 AM
> > > Subject: [slim] Fishbone Info-link error
> > >
> > >
> > > > Quoting Peter Olufsen <po (AT) dsinet (DOT) dk>:
> > > >
> > > > > When I use the Info link (I) in the playlist a few times (1-3) the
> > > server
> > > > > breaks down.
> > > > >
> > > > > I run the latest nightly, win-xp and winamp
> > > > >
> > > > > Peter
> > > >
> > > > can you look in the log and see if it says anything about the crash?
> Does
> > > this
> > > > happen with any other skins.
> > > >
> > > > -kcv
> > > >

dean
2004-06-28, 16:34
Thanks Peter,

Can you file a bug on bugs.slimdevices.com and upload that file there
as well. This way we can track it...

-dean

On Jun 28, 2004, at 12:01 PM, Peter Olufsen wrote:

> Ok, i cheked some more. I think the problem is in the tag. I use The
> Godfather (http://users.otenet.gr/~jtcliper/tgf/) to tag my files, and
> if I
> use them in SlimServer it breaks the server when I try to display song
> info.
> If I let iTunes or Winamp rewrite the tag everything seems ok in
> SlimServer.
>
> I've attached a small test-file that should reproduce the problem. If
> you
> display info for that the server breaks with the error "Wide character
> in
> syswrite at /PerlApp/Slim/Web/HTTP.pm line 897." I hope it can be used
> to
> track this problem.
>
> btw: As I had this problem with server breakdown I made a very simple
> solution to keep SlimServer running after an error. I made this
> batch/cmd-file:
> ----------
> echo off
> :retry
> echo SlimServer...
> slim.exe --logfile d:\slim\log.txt
> goto retry
> ----------
> That way the server will just load again after breaking down :-)
>
> Peter
>> ----- Original Message -----
>> From: "kdf" <slim-mail (AT) deane-freeman (DOT) com>
>> To: "Slim Devices Discussion" <discuss (AT) lists (DOT) slimdevices.com>
>> Sent: Wednesday, June 23, 2004 9:11 PM
>> Subject: [slim] Fishbone Info-link error
>>
>>
>>> the only info I can find on this kind of error suggests some problem
> with
>> UTF-8
>>> encoding. Is this crash repeatable with certain songs? If you
>>> select
>> info for
>>> a song that cuase the crash, instead of 1-5 at random, does it crash
>>> on
>> the same
>>> song every time?
>>>
>>> -kdf
>>>
>>> Quoting Peter Olufsen <po (AT) dsinet (DOT) dk>:
>>>
>>>>> From the eventlog (Error):
>>>>
>>>> Wide character in syswrite at /PerlApp/Slim/Web/HTTP.pm line 897.
>>>>
>>>> Do you want more info ?
>>>>
>>>> Peter
>>>> ----- Original Message -----
>>>> From: "kdf" <slim-mail (AT) deane-freeman (DOT) com>
>>>> To: "Slim Devices Discussion" <discuss (AT) lists (DOT) slimdevices.com>
>>>> Sent: Wednesday, June 23, 2004 12:59 AM
>>>> Subject: [slim] Fishbone Info-link error
>>>>
>>>>
>>>>> Quoting Peter Olufsen <po (AT) dsinet (DOT) dk>:
>>>>>
>>>>>> When I use the Info link (I) in the playlist a few times (1-3) the
>>>> server
>>>>>> breaks down.
>>>>>>
>>>>>> I run the latest nightly, win-xp and winamp
>>>>>>
>>>>>> Peter
>>>>>
>>>>> can you look in the log and see if it says anything about the
>>>>> crash?
>> Does
>>>> this
>>>>> happen with any other skins.
>>>>>
>>>>> -kcv
>>>>>

kdf
2004-06-28, 17:33
I tried this file out, and I can't make the server crash. This is running under
Linux with cvs. Hopefully Dean can get to the bottom of it :)
-kdf

Quoting Peter Olufsen <po (AT) dsinet (DOT) dk>:

> Ok, i cheked some more. I think the problem is in the tag. I use The
> Godfather (http://users.otenet.gr/~jtcliper/tgf/) to tag my files, and if I
> use them in SlimServer it breaks the server when I try to display song info.
> If I let iTunes or Winamp rewrite the tag everything seems ok in SlimServer.
>
> I've attached a small test-file that should reproduce the problem. If you
> display info for that the server breaks with the error "Wide character in
> syswrite at /PerlApp/Slim/Web/HTTP.pm line 897." I hope it can be used to
> track this problem.
>
> btw: As I had this problem with server breakdown I made a very simple
> solution to keep SlimServer running after an error. I made this
> batch/cmd-file:
> ----------
> echo off
> :retry
> echo SlimServer...
> slim.exe --logfile d:\slim\log.txt
> goto retry
> ----------
> That way the server will just load again after breaking down :-)
>
> Peter
> > ----- Original Message -----
> > From: "kdf" <slim-mail (AT) deane-freeman (DOT) com>
> > To: "Slim Devices Discussion" <discuss (AT) lists (DOT) slimdevices.com>
> > Sent: Wednesday, June 23, 2004 9:11 PM
> > Subject: [slim] Fishbone Info-link error
> >
> >
> > > the only info I can find on this kind of error suggests some problem
> with
> > UTF-8
> > > encoding. Is this crash repeatable with certain songs? If you select
> > info for
> > > a song that cuase the crash, instead of 1-5 at random, does it crash on
> > the same
> > > song every time?
> > >
> > > -kdf
> > >
> > > Quoting Peter Olufsen <po (AT) dsinet (DOT) dk>:
> > >
> > > > >From the eventlog (Error):
> > > >
> > > > Wide character in syswrite at /PerlApp/Slim/Web/HTTP.pm line 897.
> > > >
> > > > Do you want more info ?
> > > >
> > > > Peter
> > > > ----- Original Message -----
> > > > From: "kdf" <slim-mail (AT) deane-freeman (DOT) com>
> > > > To: "Slim Devices Discussion" <discuss (AT) lists (DOT) slimdevices.com>
> > > > Sent: Wednesday, June 23, 2004 12:59 AM
> > > > Subject: [slim] Fishbone Info-link error
> > > >
> > > >
> > > > > Quoting Peter Olufsen <po (AT) dsinet (DOT) dk>:
> > > > >
> > > > > > When I use the Info link (I) in the playlist a few times (1-3) the
> > > > server
> > > > > > breaks down.
> > > > > >
> > > > > > I run the latest nightly, win-xp and winamp
> > > > > >
> > > > > > Peter
> > > > >
> > > > > can you look in the log and see if it says anything about the crash?
> > Does
> > > > this
> > > > > happen with any other skins.
> > > > >
> > > > > -kcv
> > > > >