PDA

View Full Version : Alarm fired when all alarms disabled



MrC
2009-09-26, 13:48
This morning my Boom woke me at 7am, despite *all* alarms being disabled. I disabled them via the web interface; I double checked they were disabled before going to sleep. The Alarm icon was not present on the Boom.

Yet still, the alarm fired and woke me up at 7am. The Boom was connected to my SC (via wireless), and the alarm playlist that played was from my server, so it wasn't an SN issue. I'm on the SVN trunk version of 7.3.4.

I've reviewed all bugs with the words "alarm" and "alarms", but didn't find any that seemed to fit. I reported this happening last year w/Boom, but under slightly different circumstances, in forum thread 52830. (http://forums.slimdevices.com/showthread.php?t=52830&page=3&highlight=alarm)

Have others experienced alarms firing when they were disabled? Is this a known issue?

ModelCitizen
2009-09-28, 00:07
I think the alarm code could do with some looking at. I've had quite a few problems with mine recently. Last night it woke me up at 1.17am despite only having one alarm set, and that for 06.30am. I think the alarm can sometimes keep settings that have subsequently been changed.

Mine also reports the lists of favourites available to it as an alarm sound incorrectly and will not accept BBC iPlayer playlists.

There are a number of enhancements against the alarm in Bugzilla too.

MC

MrC
2009-09-28, 09:44
Last night, I modified my Alarm 3 from 7am to 8am. It went off at 7am. I've enabled alarm logging in the code; its clearly broken for some operations.

I think it is time to go back to a regular alarm clock.

MrC
2009-09-28, 10:07
There are a number of bugs in Bugzilla re: alarms, but none Open that seemed to match my cases. So, I've created bug 14367 (https://bugs.slimdevices.com/show_bug.cgi?id=14367) as a tracker.

manoj
2009-09-29, 05:08
Have you looked at https://bugs.slimdevices.com/show_bug.cgi?id=11652 ? I had problems with spurious alarms until I made these changes, but they weren't applied to the 7.3 trunk last I checked.