PDA

View Full Version : Flac and apply-replaygain-which-is-not-lossless



2004-06-24, 12:19
Does anyone know if and how this switch works? I see vague references to it
in a few forums, but no concrete answers to my questions:

I have a Sqzbx with albums encoded to flac. I have applied replay-gain
during encoding. How can I add --apply-replaygain-which-is-not-lossless to
the convert.pref file to allow decoding based upon the replay-gain tags? I
wasn't able to get this to work.

Has anyone done this successfully? If so, how is it supposed to be entered
in the convert.pref file?

I am kinda at a loss... :)

Jason Holtzapple
2004-06-24, 12:59
tgoldstone (AT) earthlink (DOT) net wrote:
> Does anyone know if and how this switch works? I see vague references
> to it in a few forums, but no concrete answers to my questions:
>
> I have a Sqzbx with albums encoded to flac. I have applied replay-gain
> during encoding. How can I add --apply-replaygain-which-is-not-lossless
> to the convert.pref file to allow decoding based upon the replay-gain
> tags? I wasn't able to get this to work.

I've created a file called slimserver-convert.conf with these contents:

flc mp3 * *
$flac$ -dcs --apply-replaygain-which-is-not-lossless=a --skip=$START$ --until=$END$ $FILE$ | $lame$ --silent -b $BITRATE$ - -
flc wav squeezebox *
$flac$ -dcs --apply-replaygain-which-is-not-lossless=a --force-raw-format --endian=little --sign=signed --skip=$START$ --until=$END$ $FILE$

and placed it in the main slimserver directory. You can also edit
convert.conf, but this way your changes should be preserved between
upgrades.

You can leave out the --skip and --until options if you're not using
cuesheets with your flacs.

> Has anyone done this successfully? If so, how is it supposed to be
> entered in the convert.pref file?

It works fine for me. Make sure you're using a post 1.1 (CVS) version
of flac that actually supports the option!

--Jason

Jeffrey Gordon
2004-06-24, 13:11
How do you get slimserver to read the slimserver-convert.conf?

Jason Holtzapple wrote:
> tgoldstone (AT) earthlink (DOT) net wrote:
>
>> Does anyone know if and how this switch works? I see vague references
>> to it in a few forums, but no concrete answers to my questions:
>>
>> I have a Sqzbx with albums encoded to flac. I have applied
>> replay-gain during encoding. How can I add
>> --apply-replaygain-which-is-not-lossless to the convert.pref file to
>> allow decoding based upon the replay-gain tags? I wasn't able to get
>> this to work.
>
>
> I've created a file called slimserver-convert.conf with these contents:
>
> flc mp3 * *
> $flac$ -dcs --apply-replaygain-which-is-not-lossless=a
> --skip=$START$ --until=$END$ $FILE$ | $lame$ --silent -b $BITRATE$ - -
> flc wav squeezebox *
> $flac$ -dcs --apply-replaygain-which-is-not-lossless=a
> --force-raw-format --endian=little --sign=signed --skip=$START$
> --until=$END$ $FILE$
>
> and placed it in the main slimserver directory. You can also edit
> convert.conf, but this way your changes should be preserved between
> upgrades.
>
> You can leave out the --skip and --until options if you're not using
> cuesheets with your flacs.
>
>> Has anyone done this successfully? If so, how is it supposed to be
>> entered in the convert.pref file?
>
>
> It works fine for me. Make sure you're using a post 1.1 (CVS) version
> of flac that actually supports the option!
>
> --Jason
>

Jason Holtzapple
2004-06-24, 13:15
It should be found automatically when you restart the server if
it is in the right place.

There are a few locations searched, but the only one that I
remember is the main slimserver directory - where you find the
convert.conf file.

--Jason

Jeffrey Gordon wrote:
> How do you get slimserver to read the slimserver-convert.conf?
>
> Jason Holtzapple wrote:
>
>> tgoldstone (AT) earthlink (DOT) net wrote:
>>
>>> Does anyone know if and how this switch works? I see vague
>>> references to it in a few forums, but no concrete answers to my
>>> questions:
>>>
>>> I have a Sqzbx with albums encoded to flac. I have applied
>>> replay-gain during encoding. How can I add
>>> --apply-replaygain-which-is-not-lossless to the convert.pref file to
>>> allow decoding based upon the replay-gain tags? I wasn't able to get
>>> this to work.
>>
>>
>>
>> I've created a file called slimserver-convert.conf with these contents:
>>
>> flc mp3 * *
>> $flac$ -dcs --apply-replaygain-which-is-not-lossless=a
>> --skip=$START$ --until=$END$ $FILE$ | $lame$ --silent -b $BITRATE$ - -
>> flc wav squeezebox *
>> $flac$ -dcs --apply-replaygain-which-is-not-lossless=a
>> --force-raw-format --endian=little --sign=signed --skip=$START$
>> --until=$END$ $FILE$
>>
>> and placed it in the main slimserver directory. You can also edit
>> convert.conf, but this way your changes should be preserved between
>> upgrades.
>>
>> You can leave out the --skip and --until options if you're not using
>> cuesheets with your flacs.
>>
>>> Has anyone done this successfully? If so, how is it supposed to be
>>> entered in the convert.pref file?
>>
>>
>>
>> It works fine for me. Make sure you're using a post 1.1 (CVS) version
>> of flac that actually supports the option!
>>
>> --Jason
>>