View Full Version : Original Squeezebox doesn't work with Apple dual band routers with WPA2?

2009-09-03, 12:29
I've seen one post on here from another user with my exact issue. I use a Time Capsule wifiN dual band router for my wifi and network.

All other wifiG/N devices connect to it and its WPA2 passcode just fine. However my Squeezebox hangs while trying to connect and cannot. The only way it will connect is to the dedicated wifiG portion of the router. WHICH is a closed network for guests. So it cannot see my server.

I do not understand why the Squeezebox won't connect to the the open A/G/N portion of my router like my other G/N devices. I am hoping this can be resolved with a firmware update to the Squeezebox.

2009-09-03, 12:57
I'm a bit confused by your post - and this is probably me not understanding the TimeCapsule setup - you say that the A/G/N bit you want to connect to has WPA2 enabled, but then you refer to it as "open" portion. Does open mean "unsecured"?

Assuming that the part of the network you want to connect to is WPA2 secured, when you say "original" squeezebox, which one?

If you have an SB1 (the Squeezebox of the Hardware comparison) rather than an SB2 or SB3 (now called Classic), then it only supports WEP. Not much chance of an update to sort that out, I'm afraid.

If you are using a Classic/SB3, that supports supports WPA Personal, WPA2-AES and 64/128-bit WEP encryption. What type of WPA2 do you have set up?


2009-09-03, 13:06
Well by open I mean it's wpa2 protected but it can see my network. I'm not sure my model but it works with wpa2. Because the other guest portion is also wpa2.

2009-09-03, 13:10

How are the two parts of the network identified? Do both have separate SSIDs?
Are they on the same subnets?

It sounds like the Squeezebox can "see" the a/g/n part of the network ok, but just won't connect - is that right? If you unsecure the a/g/n part of the network, does the Squeezebox connect ok? Sorry if this is grandmother sucking eggs, but you haven't got any special characters or trailing spaces in the password have you?

2009-09-03, 13:42
First, thanks for the help.

I could try killing the WPA2 on the main network, haven't tried that yet.

They both have SSIDs. The main (where network is exposed) is a 10.x.x.x address and the other guest network (which is inet only) is a 174.x.x.x type of address.

They both use WPA2. I "believe" the guest network might be the dedicated wifiG only connection. But I am not sure on that. I might be misunderstanding how dual band works. I thought it meant one side was N and the other G. But from what I am reading right now, "dual band" means 2.4ghz and 5ghz at the same time, BOTH being able to do G/N.

So that makes it even more confusing for me but also may be a hint to why the Squeezebox is having issues. Also, as I said, my SB does work with WPA2 but I found out it is a PRE-Logitech Squeezebox.

2009-09-04, 11:31
If you open AirPort Utility and open the Wireless tab in airport you have a Radio Mode option.

I don't know if the options are country dependent but this is what I see:

Automatic =or= 802.11a/n - 802.11b/g =or= 802.11a - 802.11b/g

I have set 802.11a/n - 802.11b/g. The first option is for the 5 gHz, the second for 2.4 gHz.

This means that any n device will use 5 gig and my g devices will use 2.4 gig. This forces a sensible dual usage whereas automatic tended to stick everything on the 2.4 band because this gave the strongest signal for my particular set-up. I decided to sacrifice a bit of speed for true dual band operation. It all depends on your particular needs.

To find what is going on switch to Advanced, and click the Logs and Statistics button at the bottom of the panel. Wireless clients gives you an indication of signal strength and the channel type picked up. To work out what the client addresses refer to take a look in DHCP clients.

Apologies if you knew all this. Fun, isn't it. :-)

2009-09-04, 11:35
Another thought. Set WPA/WPA2 Personal in Wireless Security rather than just WPA2 Personal (if I understand your post correctly). This is the only way I can get my old Belkin USB wireless link working. If you need WEP then, sorry, but it has been dropped.

2009-09-05, 13:48
It is set to WPA/WPA2 mode. Tried the new settings and it still won't connect.

This is so odd. Why can it connect to my "guest" network but not the main? They both use the same signal and both use WPA/WPA2. This is baffling.

2009-09-05, 15:38
It is set to WPA/WPA2 mode. Tried the new settings and it still won't connect.

This is so odd. Why can it connect to my "guest" network but not the main? They both use the same signal and both use WPA/WPA2. This is baffling.

If you can connect as a guest then the WiFi bit is working - so it is down to the security. All I can suggest is (sorry if I suggest the obvious but I'm puzzled this end):

1. Reset the Wireless Password (not the base station password) taking care to get upper/lower-case letters correct. Re-enter the password into the SB which is the tedious bit.

2. Check that MAC Access Control is NOT set under the Access tab in Airport settings. This caught me out with another access point that someone had been messing with.

Beyond that I am stuck for ideas - but it has to be a security or permissions issue.

Incidentally I forgot to mention before that I have found it helpful to give the 5 GHz Network a different name to give full control over the frequency bands different devices use, but this should have no affect on the above.

I hope something works here. I have found the Airport Express, Extreme and Time Capsule relatively easy to work with. Given all the permutations possible for WiFi it is never going to be totally straightforward but this has me scratching my head.

2009-09-05, 16:08
Yeah TC is calling my Guest Network the same name but with "Guest" added to it. I'll keep trying, thanks again for the help.