PDA

View Full Version : Problem writing Plugin



BVOnline
2004-06-20, 06:30
I'm encountering some odd problems with a plug-in I am attempting to
write.

I run 5.1.5 on Windows 2000 Server, running as a Windows Service. At
startup, I receive no errors. However, when I run the perl script with
the --d_plugins option, I get the following error:

Can't require Plugins::ShowTimes for Plugins menu: Can't call method
"modeParameterStack" without a package or object reference at
Slim/Buttons/Common.pm line 978.

Compilation failed in require at (eval 36) line 3.

For the life of me, I cannot get this to work....There is a reference to

use Slim::Buttons::Common in my script. The mentioned code in Common.pm

appears to be dealing with getting preferences for the pugin. My script

does not use any preferences...

Can anyone shed some light on this problem??

Thanks in advance!

dean
2004-06-20, 12:02
Hi,

Try posting a copy of your plugin to the developers list. I'm sure
you'll get some help there.

Also, I recommend that you upgrade to the latest nightly release:

http://www.slimdevices.com/downloads/nightly/latest

-dean

On Jun 20, 2004, at 6:30 AM, BVOnline wrote:

> I'm encountering some odd problems with a plug-in I am attempting to
> write.
>
> I run 5.1.5 on Windows 2000 Server, running as a Windows Service. At
> startup, I receive no errors. However, when I run the perl script with
> the --d_plugins option, I get the following error:
>
> Can't require Plugins::ShowTimes for Plugins menu: Can't call method
> "modeParameterStack" without a package or object reference at
> Slim/Buttons/Common.pm line 978.
>
> Compilation failed in require at (eval 36) line 3.
>
> For the life of me, I cannot get this to work....There is a reference
> to
>
> use Slim::Buttons::Common in my script. The mentioned code in Common.pm
>
> appears to be dealing with getting preferences for the pugin. My script
>
> does not use any preferences...
>
> Can anyone shed some light on this problem??
>
> Thanks in advance!
>
>
>
>
>
>
>
>