PDA

View Full Version : Dead SB3



lrossouw
2009-08-12, 19:08
Hi

One of my SB3s died the other day (my fault entirely I have to add). I had dropped it years ago onto a hard floor and it had been a bit sensitive to small bumps since then (often needing a squeeze or two). http://forums.slimdevices.com/showthread.php?t=52617

It finally gave up. The screen is not showing anything, it is not connecting via wifi and no sound is coming out (via RCA or HP). When I connect it wired it however still shows up and is working according to SqueezeCentre. I.e. it "plays" music and shows progress on SqueezeCentre etc. but with no sound and a blank screen.

I have tried removing the wireless card on the inside but no luck. (I read somewhere that it may help)

Any ideas?

I have now moved to a country which is easier on the shipping to the US so may try to send it in for repairs (and/or get one of the new touch devices when they get released).

Cheers
Louis

michel
2009-08-16, 12:30
Resoldering all connections on the circuit board could help.

tcutting
2009-08-17, 09:09
As I recall there are previous threads about issues with the wireless card causing similar problems. An obvious suggestion would be to make sure the wireless card is completely seated. If that doesn't work, try removing the wireless card altogether and see if the unit starts working (assuming you can use it wired).

[OOPS]- that's what happens when you answer a post you read too quickly... looks like you've already tried these (... and I go back into the corner to be quiet now
:-<

lrossouw
2009-08-18, 10:40
Thanks, I'm sending it in...