PDA

View Full Version : INGUZ plugin does not load



milosz
2009-08-08, 08:22
I've put the Inguz plugin in ../Plugins and it appears in Plugins list, but there is no EQ menu item on SB's and clicking SETTINGS link next to PLUGIN_INGUZEQ_DISPLAYNAME (v0.9.30) item in Plugins list gives a 404 error-"404 Not Found: settings/plugins/InguzEQ/index.html"

I have rebooted, no help.

Any suggestions would be appreciated.

SYSTEM: Intel CoreDuo quad core CPU at 3.3 gHz, 8 GB RAM,Windows XP64, .NET 2.0 for x64, SqueezeCenter 7.3.4

How do I get Inguz to work?

(NOTE: I've tried to register on the Inguz support forum but the forum doesn't let me register - I never receive the confirm link Email.)

IMGrant
2009-08-11, 06:43
NOTE: I've tried to register on the Inguz support forum but the forum doesn't let me register - I never receive the confirm link Email.

Me neither, doesn't seem to be very active. Actually, just checked it now and it says forums down for maintenance, not sure if that is a promising sign or not...

milosz
2009-08-11, 10:28
OK, I unstalled and re-installed SqueezeCenter 7.3.4 and then installed Inguz. Now it loads.

The only thing I can think of is that when I originally installed SqueezeCenter 7.3.4 I did not have .Net 2.0 installed. I installed .Net while SqueezeCenter 7.3.4 was already installed; maybe it's importatnt to install SqueezeCenter 7.3.4 AFTER the .Net framework is in place for Inguz to work.

I am still having problems with the SQUEEZECENTER SETTINGS / PlUGINS / EQ SETTINGS screen, I am getting Silverlight errors.

I hope INGUZ comes back online, he has a cool product- one which I'd be willing to PAY $50 or so for if there was support to get it running..... although I am perfectly happy to use a free version too ;-)

iwalker
2009-08-23, 14:46
I am experiencing the same problems with the 404 error and have spent sevaral hours trying to get Inguz to work, without success.

Milosz,did uninstalling Squeezecenter 7.3.4 and reinstalling, solve the problem completely?

I am currently running 7.3.3 but don't want to uninstall in case this causes even more problems!

Any help or suggestioins much appreciated

milosz
2009-08-23, 18:37
I did the uninstall / reinstall and then it worked. It really seemed like that did the trick. My theory: I installed SqueezeCenter before I installed .NET. That may not allow Inguz to work, maybe.

So, since .NET was already installed, uninstalling and then re-installing SqueezeCenter made sure I had an installation where .NET came first, then SqueezeCenter.

Or maybe it was just that certain .dll's got re-registered, who knows.

At any rate, after I reinstalled SqueezeCenter I got Inguz to work.

I STILL have Silverlight errors trying to configure the EQ, but if I reload the page over and over eventually I get to a state where I can do what I need to do.

iwalker
2009-08-24, 05:49
Thanks for the tip.

As a matter of interest, where did you save the plugins?

I found that all my active plugins are currently on server/slim/plugins and not in the Squeezecenter/plugins folder.Therefore intend to use slim/plugins

Maybe active plugins are currently saved here because I originally started with Slimserver (2 years ago) and only recently updated to 7.3.3?

Will try complete uninstall of SC, re-install and see what happens.
Perhaps all of the 'slim' folders will upgrade to Squeezecenter.

Frustrating as the Inguz plugin looks very good..

milosz
2009-08-24, 10:23
I am using 64-bit XP, my plugin directory is C:\Program Files (x86)\SqueezeCenter\server\Plugins

This is the default plugins directory set up by the SqueezeCenter installer.

iwalker
2009-08-25, 15:17
Thanks for the very helpful suggestions.

I uninstalled SC as suggested by milosz, then downloaded it again.

I also deleted Inguz, and re-downloaded. It now loads.

I have been looking for some form of 'tone control' or equalisation, especially for poor recordings. Inguz has provided this, and it works really well.

Recommended!

milosz
2009-08-26, 01:34
It really is a pretty cool idea to use the Squeeze server to do DSP for EQ and also the "room compensation" can work really well with careful measurements. This is especially all very useful if your server PC has some computing horsepower that is otherwise going idle.

What amazes me is the effort and skill that went into developing this- writing this kind of code is no trivial project.

iwalker
2009-08-26, 04:12
I agree that Inguz is very clever.
Unfortunately, having got Inguz to work, by uninstalling Squeezecenter I've lost most of my library!
This is probably the wrong forum, but any suggestions as to how to get my library back would be appreciated!
I run iTunes, and all music has been ripped into Apple Lossless.
Music is stored on an internal hard drive, and I also have an external hard drive as a back up.
Whenever I rip a CD, I copy the folder from the internal drive (M) to the external(F). Each file appears as an an MP4 file.

The iTunes location is 'E'.

Having completely re scanned the whole library, Squeezecenter appears to have found all 8000 tunes, but when I try to play back, I find that on each album, whichever track is selected, I only get the first track on the album.

In iTunes, all the files still seem to be there, so I do hope I haven't actually lost the files. However,in iTunes, if I go into 'information' on any track, other than the first, an 'i' symbol comes up saying that the file cannot be found. It can be traced manually but this is laborious.

I haven't specified a 'path' for music in Squeezecenter as the instructions say to leave this blank. Is this wrong?

Is there any simple way of restoring the library to how it was?
Perhaps I was right to be wary of uninstalling Squeezecenter and all preferences.

I now have a great equalisation system but can only use it on about 10% of my music!!