PDA

View Full Version : 99% CPU Usage?



Clive Chater
2004-06-13, 06:28
There was a long delay before the exe file became available for 13 June.
But now I have it I will thoroughly test it. CPU is running at about 10%
with a few spikes at about 80% which seems very good. Time will tell.

Another bug on 12 June was that my Squeezebox could not connect to the
server. SliMP3 did. It went through setup ok, it could see the SlimServer
and returned its name and ip address, it just couldn't connect to play
music. I could even ping the Squeezebox ip address from any PC on my
network. Strange! It's working ok in 13 June. I only mention it just to
help others if they have the same problem.

Clive

-----Original Message-----
From: discuss-bounces (AT) lists (DOT) slimdevices.com
[mailto:discuss-bounces (AT) lists (DOT) slimdevices.com] On Behalf Of Clive Chater
Sent: 13 June 2004 11:08
To: 'Slim Devices Discussion'
Subject: [slim] 99% CPU Usage?

Hi,

Since 12 June update the gaps in music are much less, but not completely
gone. CPU has been at 99% ever since I installed it about 12 hours ago, but
strangely the music is playing with less gaps than before. The navigation
on the remote directly has been much improved. However the web interface is
not working at all.

Apparently 13 June corrects some of this, but the exe is not available for a
Windows download.

Clive

-----Original Message-----
From: discuss-bounces (AT) lists (DOT) slimdevices.com
[mailto:discuss-bounces (AT) lists (DOT) slimdevices.com] On Behalf Of dean blackketter
Sent: 13 June 2004 03:43
To: Slim Devices Discussion
Subject: [slim] 99% CPU Usage?

Thanks for the report. Vidur was able to reproduce and fix a CPU
hogging bug this afternoon! I've updated the nightly builds:

http://www.slimdevices.com/downloads/nightly/latest

If you can try downloading that and see if you can reproduce, that
would be great.

Thanks,

dean


On Jun 12, 2004, at 7:08 PM, Daryle A. Tilroe wrote:

> Daryle A. Tilroe wrote:
>> dean blackketter wrote:
>>> Yesterday we fixed a couple of bugs in the web interface that could
>>> cause broken connections as well as repair at least one memory leak.
>>>
>>> Can you try installing the latest nightly:
>>>
>>> And let us know if it resolves your problem?
>> Will do; although I don't have a reliable way to reproduce
>> the bug I can watch the memory.
>
> Well bad news: after 5.5 hours slim.exe has hung. This time
> it didn't die and the memory didn't leak but the cpu is
> pegged at around 80-90% and it is completely unresponsive
> to either a player (squeezebox or softsqueeze) or the web
> interface.
>
> --
> Daryle A. Tilroe
>
>